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HOW TO USE THIS MANUAL 
This manual is actually documenting three different applications, plus a common tool, at once. 

It is organised into the following chapters: 

1. ECCAIRS REPORTING SYSTEM AND APPLICATIONS 
An introduction to ECCAIRS and the ECCAIRS Reporting System. 

2. ECCAIRS BASIC CONCEPTS 
A definition of the objects and concepts used in all the ECCAIRS applications.  

3. START THE REPORTING SYSTEM AND APPLICATIONS 
How to start the applications using the Repository logon phase. 

4. BROWSER 
The application that let you browse and enter Occurrence data (Accident and Incident data). 

5. GRAPHER 
An application to crate graphics out of Occurrence data.  

6. DATA MANAGER 
A set of tools to load, save, copy, export, process Occurrences in batch mode. 

7. QUERY BUILDER TOOL 
The tool used by all the Reporting System applications to design and execute Queries on the 
Occurrences stored in the database. 

8. ATTRIBUTE AND VALUES NAVIGATION AND SPECIFICATION 
The functions used by all the Reporting System applications to enter Attribute Values and to 
select Attributes and Attribute Values, by navigating and filtering the Taxonomy structure. 

 
As for the manual itself, the main way to navigate through the pages is the Table of Contents (next page 
in this manual) which guides you as down as to menu-items, User Interface items and functions. 

 

 
To help in the "local" navigation of the manual pages, without getting back to the Table of Contents, you 
can also use the page header, which shows: 

 On the left the main chapter. 

 On the right the chapter 1st level sections, which, for instance, corresponds to menus and other 
main User interface items. 

 
 

The manual also uses cross references with target page numbers indicated and formatted in a specific 
link style for better spotting: 

(see page 32) 
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1. ECCAIRS REPORTING SYSTEM AND TOOLS 

1.1. ECCAIRS AND ITS MISSION 
The mission of ECCAIRS is to “assist National and European transport authorities and accident 
investigation bodies in collecting, sharing and analyzing their safety information in order to improve 
public transport safety”.  
ECCAIRS stands for European Coordination Centre for Accidents and Incident Reporting Systems. 

Transport Safety  

Our world is getting more and more complex. The well-being of an increasingly mobile population 
depends for a significant part on an economy relying on efficient and safe transport facilities. These 
factors have lead to a rapidly growing inter-modal transport system which the European Commission has 
described in its White Paper "European transport policy for 2010 : Time to decide“. A growing transport 
system would lead to an increasing number of fatal accidents if no measures are taken. Similarly, our 
environment would increasingly suffer from pollution caused by accidents on sea, in the air and on the 
rails. Only by diminishing the so called accident rate the EU will be able to maintain a safe and clean 
transport infrastructure. 

To decrease the rate of fatal commercial air traffic accidents, the European Commission is implementing 
a regulation on Occurrence reporting in civil aviation which would collect and disseminate information on 
aviation incidents on a European scale so that we can learn from events and produce a safer transport 
system. 

In individual States, the number of significant Occurrences may not be large enough to give an early 
indication of a potential serious hazard or to identify trends. Access to a larger database would certainly 
improve the quality of the safety information. 

Accident Prevention through Incident Analysis 

Accidents can occur every day, everywhere and involving anybody. What one might not realize is that 
practically all accidents have been preceded by similar, but non-fatal, incidents that followed a just 
slightly different scenario. If we understand these precursors we can make a quantum leap forward 
towards preventing similar accidents from happening.  

European effort in prevention 

Directive 2003/42/EC on Occurrence Reporting in Civil Aviation obliges Member States to collect and 
exchange the information about these incidents since July 2005. Analysts in the Member States as well 
as in the European Institutions will have a multitude of information available that can help them in their 
tasks on accident prevention.  

ECCAIRS Role and future 

ECCAIRS helps to cope with the implementation of the legislation. It offers standard and flexible accident 
and incident data collection, representation, exchange and analysis tools. Following the successful 
example given in the aviation domain, in the next future ECCAIRS will be applied in a similar way in the 
other two public transport domains: maritime and railways  
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1.2. ECCAIRS REPORTING SYSTEM 
The ECCAIRS Reporting System allows the EU authorities to collect and exchange information on 
transport Incidents and Accidents in a standardised way.  

More technically, the ECCAIRS Occurrence Reporting System is a set of software applications that 
provide together a complete solution to organisations that want to collect transport incidents and 
accidents (Occurrences). 

With respect to the previous version ECCAIRS 5 is a Taxonomy independent application, which allows to 
use it in different transport domains, such as air, sea and rail public transportation. 

The Occurrences are the basic data records within the ECCAIRS Reporting System.  
Occurrences are normally any type of accident or incident related to the transport domain the system is 
dealing with.  
However, since now the ECCAIRS framework is completely detached from the application domain, an 
Occurrence can be any object which can be described by an ECCAIRS Taxonomy.  
Repositories are used to give access to the ECCAIRS Reporting System, using specific Taxonomies, 
datastore, permissions and customisation.  

Occurrences are described using a set of Attributes which are organised in Topics and related Sections. 

The same Occurrence can be displayed using different Views. 

1.3. ECCAIRS BROWSER  
Occurrences are entered, modified, viewed and printed with the ECCAIRS Browser (see page 27). 

Occurrences can be stored locally in an ECCAIRS Occurrence file and can be stored in a relational 
database when the Browser is connected to a database server.  

ECCAIRS also allows storage of independent electronic documents related to Occurrences.  

Queries and Query Builder 

Which Occurrences will be retrieved, is determined by the User building a Query to select Occurrences 
from the database or from an Occurrence file. Queries (see page 17) are built and edited using the 
Query Builder tool (see page 257). 
Queries can be constructed easily without any knowledge of the used technology (e.g. SQL language). 
The Query Builder supports the creation of Query Libraries (see page 18) in which predefined Queries 
can be stored, exchanged and executed. 

Taxonomy 

The ECCAIRS system is built upon and implements standard Taxonomies. Up to and inclusive release 
4.2.7 the system has been developed for the aviation transport domain, in particular ICAO's ADREP 
standards. From release 5 onwards the complete ECCAIRS functionality can be exploited on different 
taxonomies, including, but not limited to, safety taxonomies for the other public transport domains. 

Extensibility 

In the Windows environment the ECCAIRS Browser functions can be used by other applications and, 
vice versa, the Browser can make use of custom built extensions that can enhance the functionality and 
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interoperability of the system. Extensions made for the Browser can be shared between the ECCAIRS 
User community.  

1.4. ECCAIRS GRAPHER 
In addition to the Browser application there is also the ECCAIRS Grapher, a graphing tool, which 
produces easily, quickly and on-line the most common statistical graphs (see page 113).  
Though the Grapher is not a full featured data-analysis tool, this application allows to produce a large 
range of graphs that can illustrate trends in the Occurrence data.  
The User can show the relation between 2 or 3 data fields in various 2D or 3D graphs. Most of the more 
common graphs can be made in a very simple way. Graphs can be made visible on the screen or printed 
in a report.  
These graphs are created once and can then be applied to any other subset of the local or compatible 
database. Occurrences in a database can be identified easily with the Query builder, which allows a 
User to compose Queries based on a combination of criteria using any of the ECCAIRS data fields. 

Occurrences, Queries and graphs can be stored in encrypted files that can be easily exchanged with 
other ECCAIRS Users. 

1.5. ECCAIRS DATA MANAGER 
The ECCAIRS Data Manager is an application encompassing a powerful set of tools to for the ECCAIRS 
Reporting System (see page 155). 

The Exporter tool exports subsets the Occurrences in the database in a variety of different formats, 
respecting the security profiles for the current User as defined in the Repository. 
The Batchelor tool makes Batch type of modifications to a set of Occurrences stored in a Repository or 
Occurrence file.  
This Data Exchanger tool includes four separate functionalities: Load from Occurrence file, Save to 
Occurrence file, Copy Between Repositories, Purge Repository. 
The Restorer tool restores identification data on de-identified Occurrence files. 
The Data Quality tool performs a quality check on Occurrences either from file or from a Query in the 
database. The quality is evaluated through a set of Rules stored in Rule Libraries. 

1.6. WEBDAS - WEB-BASED VERSION OF THE BROWSER 
The Reporting System also includes a web-enabled version of the ECCAIRS Browser : WebDAS (Web 
Data Access Services). WebDAS also includes the full Query Builder functionality. It covers also 
ECCAIRS Grapher functionality, with some limits, and that of the Export tool of the ECCAIRS Data 
Manager application, as for csv-text export format. 

This allows storage and retrieval of safety information also from places where the ECCAIRS software 
cannot be installed. 
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1.7. OTHER ECCAIRS APPLICATIONS 
The ECCAIRS product family is composed of various applications forming together a suite of products 
allowing organisations to create, maintain and deploy a Repository of accident and incident reports.  

There are applications for: 

 Data entry and retrieval - applications and services that can be used to enter accident or 
incident data in an ECCAIRS Repository.  

 Analysis - applications and services that contribute to the analysis of the information stored.  

 Utilities - handy little applications that perform functions not found in the standard software and 
useful for end-Users of the system.  

 System Tools - applications and services facilitating maintenance of the ECCAIRS system. 

 Data integration - applications and services required to perform integration of data at national 
and/or European level.  

 Data dissemination - applications and services performing the dissemination of data at 
organisational, national and/or European level. 

There are specific manuals, help files and documentation available for each of the applications.  
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2. ECCAIRS BASIC CONCEPTS 

Here are a few basic concepts used in ECCAIRS: 

 Occurrence 

 Topics, Sections, Attributes and Views 

 Taxonomy 

 Entities 

 Repository 

 Query 

 Query Library 

 Query Category 

 Occurrence File 

 

2.1. OCCURRENCE 
The Occurrences are the basic data records within the ECCAIRS Reporting System.  
Occurrences are normally any type of accident or incident related to the transport domain the system is 
dealing with.  
However, since now the ECCAIRS framework is completely detached from the application domain, an 
Occurrence can be any object which can be described by an ECCAIRS Taxonomy.  
Occurrences are described using a set of Attributes which are organised in Topics and related Sections. 

The same Occurrence can be displayed using different Views. 

ECCAIRS Occurrences can be stored both in ECCAIRS databases and in Occurrence files. 

Occurrences are retrieved from the database through Queries built by the Users. Queries can be 
formulated easily without any knowledge of the IT technology actually used (e.g. SQL language). 

Repositories are used to give access to the ECCAIRS Reporting System, using specific Taxonomies, 
datastore, permissions and customisation. 

2.2. ATTRIBUTES 
ECCAIRS data is collected in hundreds of different Attributes. The values of these Attributes are stored 
in the database specified by the ECCAIRS Repository the User is connected to. According to the type of 
Attribute defined in the Taxonomy, the values that it can assume may be manually entered or chosen for 
a list of predefined values. 
Independently on the underlying coding of Attributes and Values, the ECCAIRS Reporting System 
always allow the User to see corresponding textual descriptions and explanations.  
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2.3. SECTIONS 
For visualisation and editing purposes, Attributes are grouped together in Sections. For instance, in the 
air safety application domain and with ADREP Taxonomy, the two Attributes "Latitude" and "Longitude" 
of the place an Occurrence took place are grouped together in the "Where" Section . 

2.4. TOPICS 
For navigation purposes Sections can be grouped together in Topics.  
In fact some Attributes may be seen as direct properties of the Occurrence (like the ‘Date’ the 
Occurrence took place), others instead can be grouped under specific aspects of the Occurrence, which 
are called Topics.  
A Topic can be for instance the Aircraft involved in the accident/incident, within the air safety application 
domain. In this case the "Model" of the aircraft is an Attribute of the "Aircraft" Topic. 
An Occurrence may allow for multiple instances of specific Topics, for instance, again within air safety 
application domain, there might be more than one aircraft Topic involved in an Occurrence.  
All Topics together can form a hierarchical tree by which the User can identify the place to look for 
particular information.  

2.5. VIEWS 
Views are grouping of Topics placed in a particular sequence (hierarchical tree).  
The specific Views available depends on the specific Repository you are connected to, but also on your 
User Role and, possibly, to specific conditions during the Occurrence data entry. 
It is important to understand that Views and Topics only change the way the data becomes visible. 
Occurrences created in any View, can be looked at in any other View, since the Attributes that contain 
the information are always shared. 

2.6. TAXONOMY 
The Taxonomy of ECCAIRS is the catalogue of information describing what information can be stored in 
the ECCAIRS Repository and how this information is (possibly) encoded in the data fields. 

Each incident-accident item in ECCAIRS is called Occurrence. 
The Taxonomy of an Occurrence is built from Entities and related Attributes.  

Entities 

Entities are used to represent items to which a set of Attributes can be associated. An Entity can be, for 
instance, the "aircraft", "ship", etc involved in the incident-accident, or the related "events" description. 
There may be multiple instances of Entities, since more than one of these items can be involved.  
Also each Entity may have child Entities: for instance "engine" child Entity(ies) of the "aircraft" Entity. 

Attributes 

Attributes describe properties/values associated to each Entity. An Attribute of the aircraft " Entity is, for 
instance, its "manufacturer/model". 
Most of the Attributes contain actually numbers that represent textual descriptions.  
In ECCAIRS however the User never sees the numbers but instead sees the descriptions.  
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This approach facilitates the implementation of nationalised or customised versions, increases the 
consistency of the data and reduces the storage requirements. 

The ECCAIRS Dictionary is the implementation of the Taxonomy into a usable component for the 
ECCAIRS information system 

The ECCAIRS Taxonomy Browser application and Dictionary Viewer Web tool can be used to get a 
quick and complete view of the Taxonomy used by ECCAIRS, i.e. all Entities and Attributes available. 

2.7. REPOSITORY 
The Repository is a place where the manager of an ECCAIRS information system stores and manages 
centrally not only all the data but also all User specific settings related to security, access methods, 
database and application properties. 

When a User establishes a connection to a Repository the working environment and the User privileges, 
as set by the Repository administrator in the Repository Manager application, are transferred to the 
User’s desktop. Only then he/she is able to access the database in the Repository. This implies that 
User specific settings can be managed centrally and are applied anywhere from which the User makes 
the connection The Repository contains a number of Profiles which as required can be associated to one 
or more Roles. Profiles determine the behaviour of the system in a specific area. 

A User must be given a Role (only one). 
It is possible to have a Repository without a Database. In such a case the connected User can still 
access Occurrences in an .E5F file applying the settings as defined for the specific Repository but will 
not be able to access a database (for this Repository). 

The connection to a Repository also determines the Taxonomy that is used to describe the Occurrences. 

2.8. QUERY 
Occurrences are retrieved from the database through queries built by the Users. Queries can be 
formulated easily without any knowledge of the IT technology actually used (e.g. SQL language).  

Queries can be stored in Query Libraries, exchanged with other Users and re-executed any time. 
Users have complete freedom in defining their Queries. The Query can involve any Attribute which is 
part of the current Taxonomy.  
The basic building block of a Query is a Criterion. A Criterion is a requirement for a particular Attribute. 

Any of the Attributes can be used to build a Criterion.  
You can combine logically several Criteria using the AND and OR operators. 
If necessary you can use brackets to indicate grouping. 

 

You can also build Parametric Queries: i.e. the comparison value(s) of the Attribute are not defined at 
Query design time but rather at run-time.  
When you execute the Query you are prompted to provide the actual value(s) of the Attribute for the 
particular execution of the parameter Query. 
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2.9. QUERY LIBRARY AND CATEGORIES 
ECCAIRS Queries are organised and stored in Libraries, which can contain an unlimited number of 
Queries. Within the Browser, a Query can only be defined within a Query Library. 

Stand-alone Queries (i.e. not within Query Libraries) can instead exist within other applications (e.g. 
ECCAIRS Data Manager). 

Queries are listed in the Query Library panel of the Query Builder dialog window. 

Queries can be added, edited and deleted from the Library. 

Query Libraries allow a better User management of Queries, e.g. Users can group Queries of a specific 
type in Libraries so that they can easily be retrieved for specific purposes. 

Query Libraries can be created, opened, closed and saved with User-specified names. 

Libraries are saved in ECCAIRS Query Library format (*.eql). 

Hence Query Libraries also provide an easy mean to exchange Queries between Users and 
organisations, since Libraries are stored in files which can be easily sent and copied across. 

Query Category 

You can create Categories inside a Query Library and assign Queries to them. 

Inside a Query Library you can logically organise Queries in Categories.  
These may be considered as folders within the Query Library. 

There are no constraints brought by assigning Queries to different Categories. It is simply a question of 
cataloguing Queries to gain more order, in case. 

2.10. OCCURRENCE FILES 
ECCAIRS Occurrences can be stored both in ECCAIRS databases and in Occurrence files. Occurrence 
files have a (*.e5f) file extension and contain any number of ECCAIRS 5 Occurrences in an encoded 
format. 

Occurrences usually have a size between 50 and 200Kbytes, so that a file of 1000 Occurrences might 
take up as an average 100 Mbytes of disk space.  

The number of Occurrences in an Occurrence file is limited only by the capacity of your workstation but 
for practical reasons (performance and maintainability) it is suggested to limit the amount of Occurrences 
in an Occurrence file to approximately 1000 Occurrences. 

To do so you may wish to create Occurrence files that cover a specific time frame like a year or a month. 

Opening and Occurrence file requires parsing of its content. For large Occurrence files parsing can take 
some time. A progress bar is always displayed to inform the User on the loading status. 
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3. START THE APPLICATIONS - LOGGIN ON 

3.1. LOGGING ON THE REPOSITORY  
All the applications of the ECCAIRS Reporting System we are dealing with are started with the same 
Repository login sequence.  

The ECCAIRS applications can run only after a successful installation (either Client or Server 
installation) and after the configuration of Repositories, Roles and Users on an ECCAIRS Server. These 
steps are usually performed by the designated ECCAIRS System Administrator. Refer to the ECCAIRS 
Software Installation and Configuration manual for details. 

To start the application: 

 Browser - select "START > Programs > ECCAIRS 5 > Browser" from the Windows start menu. 

 Grapher - select "START > Programs > ECCAIRS 5 > Grapher" from the Windows start menu. 

 Data Manager - select "START > Programs > ECCAIRS 5 > Data Manager" from the Windows 
start menu. 

The ECCAIRS Reporting System proposes a Login window. 

 

The User must logon using the Username and the Password that have been setup by the ECCAIRS 
System Administrator, possibly choosing among the list of different Repositories configured. 

 

If the list of Repositories is empty, then the User cannot logon until at least one (or more) link to 
Repositories has been configured. 
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3.2. FINDING / CONFIGURING A REPOSITORY  
To be able to use a Repository, the ECCAIRS application must establish a link between the workstation 
and the Repository Server.  

If in the Login dialog the Repository you need is not yet listed in the "Repository" drop-down list, then you 
have to add a link to that Repository. 

To add a Repository reference start the application and click the "More" button of the "Login" dialog. 

 

New buttons are displayed at the bottom of the dialog. 

 

Click the "Add…" button.  
An "Add Repository" dialog box requires the name of an ECCAIRS Repository Server. 
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You first have to select the "Protocol type" and "Server name" to use to connect to the suitable 
ECCAIRS Server  and then you can select to which of its Repositories you wish to connect to. 

Dialog items: 

 Protocol type - (drop-down list) click here to see which protocols you can use to connect. 

 Domain/ Server name - (display box, read-only) click here to see how to enter the 
Domain/Server name. 

 List - (button) once you have connected to the ECCAIRS Server, click this button to display the 
list of the Repositories defined in that Server in the "Repository" tree-selection box below. 

 

 Repository - (tree-selection box) you have to select the Repository among those listed in the 
box. Repositories may have Sub-Repositories defined, so they are displayed ad a tree with 
nodes (Repository nodes) that you can expand in child nodes (Sub-Repositories). 
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 Alias - an ‘Alias’ can be used to personalize the Repository name. The use of an alias becomes 
mandatory if you are referencing a Repository on a Server,  but you already have a reference to 
a Repository with the same name but hosted on another Server. 

Click: 

 OK - to confirm. 

 Cancel - to discard  the selections made. 

The "Login" dialog is displayed again: this time the newly added Repository is available in the Repository 
drop-down list. 

3.2.1. REPOSITORY CONNECTION PROTOCOLS 

You select the connection protocol and its settings through the "Protocol type" drop-down list: items: 

 

 Local Server - this is the most straightforward connection type and connects to the Repository 
Server running on the same computer from which you are connecting, i.e. you are currently 
running the Browser on the ECCAIRS Server computer. There are no further settings 
needed: the local computer name is automatically displayed in the "Domain/Server name" field. 
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 DCOM - this is a protocol which can be used over the LAN, the local network, to access a 
Repository on an ECCAIRS Server in another computer.  
The ECCAIRS System Administrator must make suitable settings on the computer running the 
ECCAIRS Server for DCOM to work. 
Specify the Server name in the "Domain/Server name" field.  
You can also click the "Browse" button and browse the network for DCOM coonected ECCAIRS 
Servers.  

 

Enter the network password, which is the one defined for the E5Administrator user when 
installing and configuring the ECCAIRS Server you are connecting to. 

 Web service - this set of protocols allows to access Repository Servers both in the local network 
and over Internet. The ECCAIRS System Administrator must make suitable settings on the 
computer running the ECCAIRS Server for Web Services to work. 
In the "Service Type" drop-down list that shows up just below you can select Net.TCP, Basic 
HTTP and WS HTTP protocols. 

 

The service type and service address have to be filled with the information provided by the 
ECCAIRS System Administrator based on the specific ECCAIRS Server configurations set for 
Windows Services. 
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3.3. CHANGING THE LOGON PASSWORD  
To change the User Login password click the "More" button in the Login form. 
provided this function has been enabled for this User by the ECCAIRS System  Administrator 

 

 

New buttons are displayed at the bottom of the dialog. 

 

Click the "Change Pwd" button. 
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In the "Change Password for User" dialog which shows up, type in the corresponding text boxes first the  
"Old password", then the "New password" and repeat it in the "Confirm new password" box. 

Click: 

 OK - to confirm. 

 Cancel - to discard the changes. 
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4. BROWSER 

4.1. USING THE BROWSER 
The Browser application is a key component of the ECCAIRS Reporting System. 
The ECCAIRS Browser let you collect, store and retrieve information from a database and/or an 
ECCAIRS data format file.  
It is a customisable frontend to an ECCAIRS Repository and it allows very simple as well as complex 
'views' on the data stored in the database and/or in an ECCAIRS data format file. 

Before using the Browser you may need to read about the basics of ECCAIRS and ECCAIRS 
Occurrences: 

 ECCAIRS (see page 11). 

 ECCAIRS Reporting System (see page 12). 

 Basic concepts and items used in the Reporting Systems (see page 15). 

4.1.1. BROWSER LAYOUT, MENUS AND TOOLBARS 

You can then explore the Browser through its layout, menus and toolbars: 

 Starting the Browser (see page 19). 

 The Browser Main window (see page 30). 

 The Toolbars (see page 31). 

 File menu (see page 40). 

 Edit menu (see page 50). 

 View menu (see page 52). 

 Database menu (see page 76). 

 Occurrence menu (see page 84). 

 Help Menu (see page 94). 

 The Occurrence Edit Window (see page 95). 

 

You can also explore the Browser through its functions (see next section). 
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4.1.2. BROWSER USAGE BY FUNCTIONS 

4.1.2.1. WORKING WITH OCCURRENCE FILES 

You can perform the following functions with the Occurrence Files: 

 What are Occurrence Files (*.e5f) ? (see page 18). 

 Create a New Occurrence File (see page 42). 

 Open and Close Occurrence Files (see page 42). 

 Delete Occurrences (see page 87). 

 Restore deleted Occurrences (see page 45). 

 Save Occurrence Files (see page 42). 

 Save De-identified Occurrences (see page 44). 

 Send Occurrences as E-Mail (see page 44). 

 Filter the Occurrences form a file using Queries (see page 43). 

You can run most of these functions from the "File" menu (see page 40). 

4.1.2.2. WORKING WITH DATABASES 

You can perform the following functions with Occurrences within Databases: 

 Connect to a Database (see page 41). 

 Lock and Release Occurrences (see page 87). 

 Import Occurrences into the database ("File > Send to") (see page 42). 

 Build, select and execute Queries to select the Occurrences to display and work with (see page 
76). 

 Query by Date (see page 77). 

 Query by Example (see page 79). 

 Query Refresh (see page 79). 

 Show Current Query (see page 80). 

 Query Batches (see page 80). 

 Re-execute the last used Queries (see page 83). 

 Set User Properties which can be used in Queries (see page 41).  

You can run most of these functions from the "Database" menu (see page 76). 

4.1.2.3. OCCURRENCE LISTS 

You can perform the following functions on the list of Occurrences in the "Occurrence List" pane: 

 Select and Filter Occurrences (see page 38). 

 Search for Occurrences (see page 51). 

 Save Selected Occurrences (see page 44). 
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 Send Occurrences as E-Mail (see page 44). 

 Print Lists of Occurrences (see page 48). 

 Display File or Query Occurrence List (see page 55). 

 Detach "Occurrence List" panel (see page 54). 

 Delete Occurrences (see page 87). 

 Restore deleted Occurrences (see page 45). 

You can run most of these functions from the "Right-click" contextual menu within the "Occurrence List" 
panel (see page 38). 

4.1.2.4.  EDITING OCCURRENCES 

You can perform the following functions to edit Occurrences: 

 Create New Occurrences (see page 85). 

 Get to know the Occurrence Edit window (see page 95). 

 Add Topics (see page 106). 

 Specify Attributes (see page 301). 

 Modify Occurrences (see page 86). 

 Take an Occurrence Window Snapshot (see page 56). 

 Duplicate Occurrences (see page 86). 

 Add Attachments (see page 97). 

 Delete Occurrences (see page 87). 

 Restore deleted Occurrences (see page 45). 

You can run most of these functions from the "Occurrence" menu (see page 84). 

4.1.2.5. PRINTING OCCURRENCES 

The printing-related functions in ECCAIRS Browser are: 

 Print Lists of Occurrences (see page 48). 

 Print Occurrences (see page 90). 

 Preview Occurrence Printouts (see page 88). 

 Print as PDF (see page 92). 

 Set print page options (see page 47). 

 Generate a document with Occurrence data using templates (see page 92). 

4.1.2.6. SETTING OPTIONS 

The place where you can set options in the Brower: 

 Set the Browser Options (see page 57). 
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4.2. BROWSER MAIN WINDOW 

 

The ECCAIRS Browser Main window is made up by 2 main panels and 3 bars: 

 Menu bar - which hosts  menus to access the Browser functions. 

 Toolbar - a set of thematic Toolbars for a quick access to the some of the functions. 

 "Information" panel - a one/two panel area showing the Occurrence data. 

 "Occurrence List" panel - displays a list of either the results of a Query to the database or the 
contents of an ECCAIRS Occurrence file. There is also a "Occurrence List" Right-click menu. 

 Status bar - placed at the bottom, it displays general information. 

When the Browser starts the "Occurrence List" is empty and will be populated when you either open an 
existing Occurrence file ( "File > Open" menu item) or execute a Query on the Repository database 
("Database > Build Query" or "Database > Re-execute Last Queries" menu-items).  

The Occurrence List may be already populated by the result of the execution of a "default" pre-defined 
automatic Query, if the "Automatic Query" feature is enabled in the Repository Profile of the User/Role 
you are logged in. You can also set and modify the "Automatic Query" with the Browser's own 
"View > Options > Automatic > Query" menu-item, if this option is allowed for the User/Role you are 
logged in. 
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4.2.1. MENU BAR 

The Menu bar includes different menus to access the Browser functions: 

 

 File menu (see page 40). 

 Edit menu (see page 50). 

 View menu (see page 52). 

 Database menu (see page 76). 

 Occurrence menu (see page 84). 

 Add-Ins menu (see page 93) - displayed only if Add-Ins are configured in User menu. 

 Help menu (see page 94).  

The menu and menu-items are completely customisable and may contain fewer items than those 
described here, depending on the specific User/Role and Repository you are logged in.  

4.2.2. TOOLBAR 

The Toolbar offers a quick visual access to a set of commonly used functions in ECCAIRS Browser. 

 

The Toolbar is made up by a customisable set of task-specific Toolbars: 

 File Toolbar - icon-buttons performing the same functions of the "File" menu-items. 

 

 Edit Toolbar - icon-buttons performing the same functions of the "Edit" menu-items. 

 

 Database Toolbar - icon-buttons performing the same functions of the "Database" menu-items. 

 

 Occurrence Toolbar - icon-buttons performing the same functions of the "Occurrence" menu-
items. 

 

 View Toolbar - icon-buttons performing the same functions of the "View" menu-items. 

 

Stopping the mouse pointer (no clicking !) over the Toolbar icon-buttons causes the display of a Tooltip, 
i.e. a brief description of the actions-functions associated. 
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The toolbars completely customisable and may contain fewer items than those described here, 
depending on the specific User/Role and Repository you are logged in.  

Choose the Toolbars to display 

Using the "View > Toolbars" submenu-items you can toggle visible (default) or invisible each of the five 
Toolbars. 

4.2.3. STATUS BAR 

The Status bar displays: 

 the current User. 

 the current Organisation. 

 the number of (a) selected, (b) visible and (c) total Occurrences in the "Occurrence List" panel. 

 the percentage of database indexing - when the database index is being rebuilt you will see this 
number increasing. If the database indexing percentage is not 100% then the result of a Query 
may be incomplete.  

 the current Repository name. 

 the connection status to the database.  

 the current time and date. 

 

Occurrence List batches 

In case more Occurrences should result from the Query then the batch size specified in the Repository 
you are logged in, you  also find the current batch number of resulting Occurrences displayed in the 
"Occurrence List" pane.  

The "Database > Go to batch" menu-item (see page 80) let you navigate among batches and gives more 
details and options. 



BROWSER BROWSER MAIN WINDOW 
 

 

33 

4.2.4. INFORMATION PANEL 

The "Information panel" is the area where you can view the content of the Occurrence currently selected 
in the "Occurrence List" panel (see page 36). 

 

The panel is most of the times divided into two: 

 Topic-tree - (sub-panel) the leftmost part. 

 Topic-data - (sub-panel) the rightmost part. 

This compound Topic-tree & Topic-data panel rendering is the most commonly used. 
Some specific Views can instead use a simplified structure where all the information is condensed in a 
single Topic. 
The Attributes, always grouped in Sections, are shown in a single pane. An example is the "ADREP 
preliminary view" in the ADREP aviation safety Taxonomy. 

"Topic-tree" sub-panel 

The right panel shows the Occurrence Topics arranged in a tree structure. When you select a Topic in 
the tree the corresponding data is displayed in the "Topic-data" sub-panel on the left. 

In Views working on a single Topic the "Topic-tree" sub-panel is not displayed. 

By default only non-empty Topics are displayed (i.e. containing any information). 

If you select the "View > Options > Show all topics in a tree" menu-item then all the Topics are displayed 
in the Topic-tree left pane. 

There may be more than one Topic instance needed for an Occurrence: indeed this is a quite common 
situation.  
For instance, in the transport safety application domain, multiple instances of a Topic are used to host 
information on each of the aircrafts/ships/trains involved in the same Occurrence. 

"Topic-data" sub-panel 

By clicking on the left-panel icons (the tree nodes), the specific Topic is opened and the related 
information, i.e. Attributes labels (names) and corresponding Values, is displayed. Attributes labels and 
Values in a Topic are always organised in Sections. Each Section is often distinguished visually in the 
panel. 
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In the example shown above the Sections are surrounded by a bounding box with a Section name 
marked in red close to the upper left corner. 

Displaying information on Attributes and Values 

To display the coding, definition and description of either an Attribute or its current Value just stop the 
mouse pointer over the Attribute or Value.  

 
 

4.2.5. DISPLAY ATTACHMENTS 

An Occurrence may have any sort of documents attached. Attachments are handled as Attributes, and 
may be used within any Section of any Topic. However the Section which includes Attachments uses 
some specific layout to manage them.  
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The Section including Attachments has is displayed with a panel that lists all the Attachments included. 

 

You can use a Right-click menu inside the "Attachment List" panel to open and extract Attachments. 

For each Attachment in the list the following properties are displayed: 

 Name - the Attachment file Name. 

 Description - the description entered for the Attachment when it was added to the Occurrence. 

 Type - the MIME type of the Attachment file. 

 Size - the size of the Attachment file. 

 Date - the last Modification Date of the Attachment file. 

To access an Attachment you first select it in the list and then you can either: 

 Open - use the "Right-click > Open" menu-item in the panel or double-click on the Attachment 
line to open it using the associated application in Windows.  

 Save - use the "Right-click > Save" menu-item to save the Attachment. Use the standard "Save 
as" dialog to select the target folder and, if needed, to rename the Attachment file.  

You can add Attachments using the "Edit" window when editing/creating Occurrences (see page 97). 
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4.2.6. OCCURRENCE LIST PANEL 

The "Occurrence List" panel displays a list of Occurrences that is either the result of a Query on the 
database or the content of an ECCAIRS Occurrence file.  

 

You can: 

 Click on Occurrence - to display its content in the "Information" panel. 

 Double-click on Occurrence - to edit it using the "Occurrence Edit" window (see page 95). 

 Use the Right-click menu - the Right-click menu (see page 38) let you browse, search, narrow 
down or organize the results of a Query or the contents of an Occurrence file. 

 Select Occurrences - single-clicking on an Occurrence both displays its content in the 
"Information" panel and selects it.  
To select multiple Occurrences in the Occurrence List use the standard Windows ways: i.e. use 
the mouse, also with "CTRL" and "SHIFT" keys for multiple (not)/contiguous/not selections. 
You can then perform actions of the selected Occurrences using the: 

o Right-click menu (see page 38).  

o Edit menu (see page 50). 

o Occurrence menu (see page 84). 

o "File > Send to" menu-items - for sending the Occurrences to a file, to the database or 
via E-Mail using the "File > Send to" (see page 42) and "File > Send deidentified to" (see 
page 44) menu-items. 

 Display Occurrences from File or Database - you can select to display either the database 
Query results or the ECCAIRS Occurrence file currently loaded via the "View > Show Occurrence 
List" menu-item (see page 55). 

 Display Occurrence batches - in case more Occurrences should result from the Query then the 
batch size specified in the Repository you are logged in, the resulting Occurrences are displayed 
in batches. The Status bar displays the number of the current batch of Occurrences being 
displayed in the "Occurrence List" panel (see page 32).  
The "Database > Go to batch" menu-item (see page 80) let you navigate among batches and 
gives more details and options. 

 Detach or dock the panel - using the "View > Detach/Dock the Occurrence List" menu-item (see 
page 54). 

Automatic Query at Login 

When you start the ECCAIRS 5 Browser and you log on to a Repository with a database, or you 
subsequently (re)connect to a Repository using the "File > Connect" menu-item, the Browser program 
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may execute automatically a pre-defined Query, if any has been set, and then displays the resulting 
Occurrences in the "Occurrence List" panel. 

You can use this feature to automatically retrieve and show, for instance, the Occurrences entered 
yesterday, or during last week, or those still in a processing-state that you wish to monitor. 

The "Automatic Query" is set in the Repository within the profile associated to the User/Role currently 
logged in. However you may edit or change the Query to be used, if the related profile in the Repository 
allows you to do so. You can customise the pre-defined "Automatic Query" by selecting the 
"View > Options > Automatic Query" menu-item. 

"Occurrence List" panel customisation 

The only difference when operating on the  result of database Queries, rather than on Occurrence files, 
is additional information related to locking of Occurrences in the database when looking at the results of 
a Query. 
The background colours used for the file and database Occurrence List can be customised in the 
"View > Options > Appearance" menu-item. 

Note that you will be able to customise only the colours and font of the  panel with the type of 
Occurrences you are currently displaying in the  list. This means that if you are displaying Occurrences 
from a database  Query then your colours and font customisation will be applied to that  case only (and 
not to the Occurrence List from ECCAIRS Occurrence files). 
With the "View > Options > Occurrence List" menu-item also the  Attributes displayed in the "Occurrence 
List" panel can be customised. 
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4.3. RIGHT-CLICK MENU 
The Right-click menu, active in the "Occurrence List" pane, includes functions related to Occurrence 
Lists. 

 

Menu items: 

 Edit  

 Filter by 

 Filter excluding  

 Filter for 

 Remove filter 

 Cut, Copy, Paste 

 Delete 

 Select all 

 Find 

 Find next 

 

The menu and menu-items are completely customisable and may contain fewer items than those 
described here, depending on the specific User/Role and Repository you are logged in.  

4.3.1. RIGHT-CLICK > EDIT 
Same as the "Occurrence > Edit" menu-item (see page 86). 

4.3.2. RIGHT-CLICK > FILTER BY 
You can show only Occurrences sharing the same Attribute value with a reference one.  
Click on an Attribute column containing the reference Value in the Occurrence List and then select the 
"Right-click >Filter...by" menu-item. 
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4.3.3. RIGHT-CLICK > FILTER EXCLUDING  

You can show only Occurrences that have a different Attribute Value with respect to a reference one.  
Click on an Attribute column containing the reference Value in the Occurrence List and then select the 
"Right-click >Filter...excluding". 

4.3.4. RIGHT-CLICK > FILTER FOR 

To display (filter) Occurrences possessing a specific Attribute, without referring to any other visible 
reference value, first click on any item in the Attribute column wanted in the Occurrence List, then select 
"Right-click >Filter for" menu-item. and specify the Attribute value to use as display filter. 

The number of Occurrences selected, visible (because of the possible filter applied) and total are shown 
in the bottom status bar.  

4.3.5. RIGHT-CLICK > REMOVE FILTER 

To remove any display filter set on the Occurrence List, select "Right-click> Remove filter" menu-item. 

4.3.6. RIGHT-CLICK > CUT, COPY, PASTE 

Same as the "Edit > Cut, Copy, Paste" menu-item (see page 50). 

4.3.7. RIGHT-CLICK > DELETE 

 Same as the "Occurrence > Delete" menu-item (see page 87). 

4.3.8. RIGHT-CLICK > SELECT ALL 

Same as the "Edit > Select all" menu-item (see page 51). 

4.3.9. RIGHT-CLICK > FIND 

Same as the "Edit > Find" menu-item (see page 51). 

4.3.10. RIGHT-CLICK > FIND NEXT 

Same as the "Edit > Find next " menu-item (see page 51). 
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4.4. FILE MENU 
The File menu includes mainly functions related to Occurrence files and printing. 

 

Menu items: 

 Connect 

 User Properties 

 New 

 Open 

 Save 

 Save as 

 Save as (without attachments) 

 Close 

 Filter file 

 Send to 

 Send Deidentified to 

 Recycle bin 

 Page setup 
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 Print Occurrence List 

 Open one of the Most Recently Used Occurrence files 

 Exit 

The menu and menu-items are completely customisable and may contain fewer items than those 
described here, depending on the specific User/Role and Repository you are logged in.  

4.4.1. FILE > CONNECT 

Selecting "File > Connect " you go through the same the Repository Logon process made when starting 
the application (see page 19). 

This may be useful if you need either to change the Repository you are logged in or refresh the 
Repository settings, in case they have been modified in the meantime. 

Note that: 

 The connect icon in the status bar (bottom right) will be turned active if the new Repository 
contains a database. If the Repository only allows for file access the connect icon will turn (or 
remain) inactive 

 The "Occurrence List" panel is automatically switched to the "Show the Query Occurrence List " 
view mode (different background colour - pale blue by default). 
However since no Query has been run yet, the Occurrence List is now empty. 

In fact connecting to a database does not automatically display Occurrences in the Repository. 
To extract/list information into the "Occurrence List" panel a Query must be created and executed. 

4.4.2.  FILE > USER PROPERTIES 

You can enter values for the User Properties (Name, Organisation, Country, etc) through the "User xxx" 
dialog box which shows up (xxx is the name of the User logged in).  

 

The User Properties can be used in Queries as comparison values (see page 304). 
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Some of these fields may be already filled in since they may have been pre-defined in the Repository for 
the current User. 
In any case you may modify any User Property value already set. 

4.4.3. FILE > NEW 

Creates a new Occurrence file. 

This will bring up the standard file selection dialog window in which you can define the location and 
name of the Occurrence file you wish to create. 

4.4.4. FILE > OPEN 

Opens an existing Occurrence file. Occurrence files use the ECCAIRS Data File format and have the 
(*.e5f) file extension (see page 18). 

This will bring up the standard Windows dialog form in which you can define the location and name of 
the Occurrence file you wish to open. 

he Occurrence file will then be loaded and the "Occurrence List" panel will be accordingly populated. 

Since any Occurrence have a size between 50 and 200Kbytes the process may not be quick for large 
files. For practical reasons it is suggested to limit an Occurrence file to about 500 Occurrences. 

4.4.5. FILE > SAVE 

Saves the Occurrences in the "Occurrence List" panel into the currently open Occurrence file. This 
requires that you have opened an Occurrence file before. 

If the "Save" menu-item and the "Save" icon-button in the Toolbar are disabled (i.e. greyed out), this may 
be because either: 

 no change has been made to the Occurrences, so there is nothing to save. 

 the "Occurrence List" is not displaying Occurrences from the Occurrence file, but those extracted 
from the Database Repository.  
In this case select the "View > Show Occurrence list > Show the 'File' Occurrence List" menu-
item, or the corresponding Toolbar item. 

4.4.6. FILE > SAVE AS 

Saves all the Occurrences in the "Occurrence List" panel into an Occurrence file, including possible 
Attachments. Use the standard "Save as" dialog to specify the target Occurrence file and location. 

If the "Save as" menu-item is disabled (i.e. greyed out), this may be because the "Occurrence List" is not 
displaying Occurrences from the Occurrence file, but those extracted from the Database Repository.  
In this case select the "View > Show Occurrence list > Show the 'File' Occurrence List" menu-item, or the 
corresponding Toolbar item. 

File > Send to > File 

To save only the Occurrences currently selected in the "Occurrence List" panel you can use the 
"File > Send to > File" menu-item (see page 44). 
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4.4.7. FILE > SAVE AS (WITHOUT ATTACHMENTS) 

Same as "File > Save as", but this time no Attachments are saved in the target Occurrence file. 

4.4.8. FILE > CLOSE 

Closes the currently open Occurrence file. 

The file-originated "Occurrence List" panel is cleared. 

If any change has been made to the file-originated "Occurrence List" then you will be asked to save them 
into the Occurrence File or discard them. 

The ECCAIRS Browser application remains open. 

4.4.9. FILE > FILTER FILE 

You may wish to show in the in the "Occurrence List" panel only Occurrences, from the currently open 
Occurrence file, matching a specific Query.  

You use exactly the same tools and functions used for selecting Occurrences from the database. 

This is done through the sub-items of the "File > Filter file" menu-item: 

 Use Query library - starts the "Query Builder" facility to define/select Queries and their Libraries, 
just as in "Database > Build Query" menu-item (see page 77). 

 Use Query by example - you can fill one or more Attribute values of a Section (pre-defined for 
your User/Role in the Repository) to filter Occurrences with the same values. Just as in 
"Database > Query by Example" menu-item (see page 79). 

 Remove filter - removes the filter applied. All the Occurrences form the ECCAIRS Data file will 
be displayed in the "Occurrence List" pane. Just as in "Right-click > Remove filter" menu-item 
(see page 39). 

 Re-execute last Queries - these last items are the last four Queries executed. You can directly 
pick up one to re-run it. Just as in "Database > Re-execute Last Queries" menu-items (see page 
83). 

The number of Occurrences visible (because of the possible filter applied) and total are shown in the 
bottom Status bar.  
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4.4.10. FILE > SEND TO 

It is possible to send the Occurrences currently selected in the "Occurrence List" panel, either to an E-
Mail address, or to an Occurrence file or to the database associated with the Repository. 

To do this, select the required Occurrences and select: 

 File > Send to > E-Mail - the MAPI-compliant mail client defined in the system is invoked with a 
pre-typed test, including date, time, current ECCAIRS operator and related organization, and the 
selected Occurrences are grouped and attached as an Occurrence file. 

 File > Send to > File - use he standard "Save" dialog to specify the name and location of the 
target Occurrence file. 

 File > Send to > Database - a consistency check is performed on the Occurrences before 
inserting them into the database. Suitable success/error reports are displayed with dialog 
windows. 
Using this function you can save into the database Occurrences loaded from an Occurrence File. 

Note 

The "File > Send to > Database" menu-item is enabled only if the "Occurrence List" panel displays 
Occurrences from a file (i.e. yellow-background "Occurrence List" pane, by default). You can use 
"View > Show the Occurrence List > Show the 'File' Occurrence List" or the corresponding Toolbar icon-
button to switch to File Occurrence display. 

Additional Tools 

The same file-to-database import function can be performed using the stand-alone specific external 
application "ECCAIRS Data Manager" (see page 155). This tool offers more options and the capability to 
handle several input files, so could be more suitable for "mass-import" of Occurrences. 

4.4.11. FILE > SEND DEIDENTIFIED TO 

Exports de-identified Occurrences into a new Occurrence file. 

This means that a number of Attributes Values will be removed form the saved Occurrences. 

The User/Role within the Repository you are logged in has some preset Attributes which will be 
mandatorily de-identified, when you select to save them so. However you can add other Attributes to de-
identify. 

The selected Occurrences, properly de-identified, can be saved in different places, according to the 
specific the sub-menu-item selected: 

 File > Send Deidentified to > E-Mail 

 File > Send Deidentified to > File 

In case "File" is selected, a standard Windows browse dialog is displayed to choose the target file and 
folder. 
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4.4.12. FILE > RECYCLE BIN 

If the "Recycle Bin" feature is enabled (see the end of this Section), than all the Occurrences deleted in 
the Browser are automatically stored in the "Recycle Bin".  
If so, in case of need, it is possible to restore any Occurrence deleted in the currently open Occurrence 
file or export them in a new Occurrence file. 

The "Recycle Bin" dialog window shows in its man panel all the Occurrences that have been deleted. 
More precisely, it shows the Occurrences deleted when the Recycle Bin has been enabled and since the 
last Recycle Bin purge operation. 

 

Dialog items: 

 List Box content - the central list box displays the Occurrences that have been deleted. 
Occurrences deleted from the database are marked with a pale-blue icon, while those deleted 
from an Occurrence file are marked with a yellow icon.  
For each Occurrence deleted the following information is displayed: 

o Taxonomy-specific "Special Attributes" - a number of columns with the "Special 
Attributes" specific to the Taxonomy in use. These are defined in the Taxonomy itself and 
are normally used as mandatory data to uniquely identify the Occurrence. For instance 
"File Number" and "Responsible Entity" in the Aviation domain, or "Casualty Report 
number" and "State Reporting" in the Maritime domain. 

o Taxonomy - the Taxonomy and its version in use within the Repository when the 
Occurrence was deleted.  

o Deleted on - the date and time when the Occurrence was deleted. 

o Deleted from - either the text "Query" or the "Occurrence File" name, depending whether 
the Occurrence was deleted from the Occurrence List resulting from a database Query or 
from the Occurrence List from an "Occurrence File". 

o Last modified on - the last modification date and time of the Occurrence.  

o Created on - the creation date and time of the Occurrence. 
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 List Box headers (sort) - you can sort the list of deleted Occurrences by clicking on the header 
of the columns of the upper display pane. Clicking again reverses the sort order. 

 View - (calendar-controls and check-boxes) by default the panel shows the Occurrences deleted 
during the last week.  
Using the "From" and "To" drop-down calendar-controls you can specify to display only 
Occurrences deleted within a defined time interval. If you uncheck the "From" check-box then you 
display all Occurrences deleted up to the "To" date and since the last "Empty Recycle bin" action.  
Conversely, if you uncheck the "To" check-box then you display all Occurrences deleted from the 
"From" date up to now. If a "Empty Recycle bin" action has been performed in between, then  you 
display all Occurrences deleted from the last "Empty Recycle bin" date up to now. 

 Right-click menu - you can select one or more of the deleted Occurrences in the list , using the 
standard Windows multi-selection methods, and then right-click to display a corresponding menu. 

 

Menu items: 

o Append to current file - to restore the Occurrence(s) into the currently open Occurrence 
file. If no Occurrence file is already open, a new one is implicitly created and the restored 
Occurrence(s) are displayed in the "File-Occurrence List" panel. If you should need to 
restore those Occurrence(s) into the database, select them in the "File-Occurrence List" 
panel and use the "File > Send to > Database" menu-item to do the job. 

o Export - to export the selected Occurrence(s) in a new Occurrence file. 

o Delete - to  remove only selected Occurrence(s). 

o Remove All - to remove all Occurrences displayed. 

o Empty Recycle bin -  to remove all Occurrences, even those which are not displayed in 
the upper list because out of the date-range view-filter possibly set. 

 Enabled - (check-box) choose this option to enable the "Recycle Bin" feature. 

 



BROWSER FILE MENU 
 

 

47 

4.4.13. FILE > PAGE SETUP 

All print output in the ECCAIRS Browser (i.e. File > Print Occurrence List, Occurrence > Print, etc) is 
directed to the printer currently selected in Windows . 

If you select the "File > Page setup" menu-item you can use the "Page Setup" dialog set the printing 
preferences: paper size and source, page orientation and page margins.  

 

To exit the dialog click: 

 OK - to save the selections made so far. 

 Cancel - to discard the selections made so far. 
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4.4.14. FILE > PRINT OCCURRENCE LIST 

Prints the list of either the selected Occurrences or the whole Occurrence List, if no Occurrences are 
selected in the "Occurrence List" panel. 

The menu-item is enabled only if a proper printing layout/template has been defined in the Browser 
profile for the User/Role you are logged in to the Repository. 

The function invokes the standard Windows print dialog, where you can choose printer and options. 

Before any printing the "Print Preview" dialog is displayed (see page 89). 

The printout follows the layout/template that has been set in the Browser profile for your User/Role.  
The pages include headers and footers and, for each Occurrence, a set of columns as in the 
"Occurrence List" panel. The Attributes listed may be a subset of them and also in different order. 
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4.4.15. FILE > OPEN THE MOST RECENTLY USED FILES 

It is also possible to directly re-open any of the most recently used files, listed in the bottom part of the 
"File" menu. 

 

  

 

4.4.16. FILE > EXIT 

Exits the ECCAIRS Browser application. 

If any change has been made to the file-originated "Occurrence List", if one is currently opened-loaded 
into the application, then you will be asked to save them into the Occurrence file or discard them. 
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4.5. EDIT MENU 
The Edit menu includes functions operating on the List of Occurrences displayed. 
The same functions, and additional ones, can be invoked by the Right-click contextual menu available 
within the "Occurrence List" panel (see page 38).  

 

Menu items: 

 Cut, Copy, Paste 

 Select all 

 Find 

 Find next 

The menu and menu-items are completely customisable and may contain fewer items than those 
described here, depending on the specific User/Role and Repository you are logged in.  

4.5.1. EDIT > CUT, COPY AND PASTE  

Cut/Copy and Paste may be used to move or copy Occurrences from one Occurrence List to another 
(i.e. from the file-based Occurrence List to the database-Query based Occurrence List, and vice versa)  

If you copy and then paste an Occurrence in the same Occurrence List then you will be warned that you 
are trying to insert a duplicate Occurrence. 

 

You have to specify the "Operation to execute" among: keep existing Occurrence, Insert as a new 
Occurrence, Merge Occurrences, Overwrite existing Occurrence, Stop uploading.  
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The same applies if you are pasting a copied Occurrence in an Occurrence List that already includes an 
Occurrence with same unique signature. 

In case you select "Insert as a new Occurrence" then you will be able to modify the "ECCAIRS number", 
so that the new Occurrence is actually distinguished form the one you used as copy source. 

Once you have selected the "Operation to execute" click the "Execute" button to perform the action. 

4.5.2. EDIT > SELECT ALL 

Selects all the Occurrences in the list. 

To select single or multiple Occurrences in the Occurrence List use the standard Windows ways: i.e. use 
the mouse, also with "CTRL" and "SHIFT" keys for multiple (not)/contiguous/not selections. 

4.5.3. EDIT > FIND  

Searches and selects an Occurrence containing a specific. 

Enter the search string in the "Find text" dialog box displayed and click the "OK" button to search. Only 
the first Occurrence matching the string is found and selected, if any. 

 

4.5.4. EDIT > FIND NEXT 

Finds and selects the next Occurrence matching the string already specified on selecting "Edit > Find 
Text" menu-item. 
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4.6. VIEW MENU 
The View menu includes miscellaneous display options.  

 

Menu items: 

 View with 

 Toolbars 

 Detach Occurrence List / Dock Occurrence List 

 Show Occurrence List 

 Copy Data window 

 Show all Topics in Tree 

 Options 

 

The menu and menu-items are completely customisable and may contain fewer items than those 
described here, depending on the specific User/Role and Repository you are logged in.  
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4.6.1. VIEW > VIEW WITH 

Each Repository has one or more User-Roles defined, and every User belongs to a Role. 
One or more Views are made available to a Role, and therefore to all the Users with that Role. 
Each View is actually a "view" upon the data stored for each Occurrence. Changing the View only 
changes the way data is presented/organised, and not the data itself.  

You use the "View > View with" sub-menu-items to select any of the Views available to your Role.  

 

For instance, in the Aviation domain, there are 4 Views that are commonly used: 

 The ADREP view organises the data according to the complete ADREP 2000 revision 2009 
Taxonomy 

 The ADREP Preliminary view is a quick kind of preliminary report focused on flight operations 
information 

 The ATM view focuses on the Air Traffic Management issues 

 The ATM Preliminary view is a quick kind of preliminary report focused on ATM specific type of 
information 

Below the Views made available to your Role, and therefore to all the Users with that Role, you can have 
other Views that you may use within the Browser using the "View > Options > View Management" menu-
item. 

You can select the View also using the corresponding drop-down list in the Toolbar. 

 



BROWSER VIEW MENU 
 

 

54 

4.6.2. VIEW > TOOLBARS 

Using the "View > Toolbars" submenu-item you can toggle each of the five Toolbars as visible (default ) 
or invisible the Toolbar. 

 

4.6.3. VIEW > DETACH/DOCK OCCURRENCE LIST 

The "Occurrence List" panel is detachable via the "View > Detach Occurrence List" menu-item or the 
corresponding Toolbar item. This allows, for instance, to deal more easily long lists of Occurrences or 
devote more space to the "Occurrence Information" panel. 

When the list of Occurrences is detached, its window is completely self-standing, Toolbar inclusive, and 
can be made as large as needed. 

 



BROWSER VIEW MENU 
 

 

55 

Dock Occurrence List 

The Occurrence List can be re-linked to the main window by using "View > Dock Occurrence List" menu-
item or the corresponding Toolbar items. 

4.6.4. VIEW > SHOW OCCURRENCE LIST 

You can select to display either the database Query results or the ECCAIRS Occurrence file currently 
loaded can be done via the "View > Show Occurrence List " sub-menu items or the corresponding 
Toolbar items. 

File > Show Occurrence List > Show the 'File' Occurrence List 

Displays the list of Occurrences from an ECCAIRS Occurrence file over a pale yellow background. The 
colours can be different with the User/Role you are logged in to your Repository. You can in any case 
customise them using the "View > Options > Appearance" menu-item (see page 57). 

 

This list will be non-empty provided that previously both: 

 an ECCAIRS Occurrence file has been opened. 

 filtering and/or Querying on the corresponding Occurrences leaves some Occurrences. 

File > Show Occurrence List > Show the 'Query' Occurrence List 

Displays the list of Occurrences extracted from the database Query over a pale blue background. The 
colours can be different with the User/Role you are logged in to your Repository. You can in any case 
customise them using the "View > Options > Appearance" menu-item (see page 57). 

 

This list will be non-empty provided that previously both: 

 a database connection has been provided. 

 a Query has been selected executed and returns some Occurrences. 

 filtering on the resulting Occurrences leaves some Occurrences. 
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4.6.5. VIEW > COPY DATA WINDOW 

Takes a snapshot of the currently displayed Tree-data part of the "Occurrence Information" pane. 

It is possible to take and manage more than one snapshot. 

Each snapshot is kept in a separate window and can be moved around, resized, etc. 

 

Note 

When minimising (to an icon) the "read-mode" main Browser window, also the snapshots get minimised 
and thus not visible.  
If you plan to display snapshots while using the "Occurrence Edit" then it is advisable to resize rather 
than minimize the Browser window. 
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4.6.6. VIEW > SHOW ALL TOPICS IN A TREE 

By default the Topic-tree panel only shows Topics containing some information.  

If you select the "View > Options > Show all topics in a tree" menu-item then all the Topics are displayed 
in the Topic-tree left panel. 

4.6.7. VIEW > OPTIONS 

The User can control a number of options of the Browser by selecting the "View > Options" menu-item. 

 

Sub-menu items: 

 Appearance 

 View Management 

 Occurrence List 

 E-Mail signature 

 Automatic Query 

 Deidentifiable Attributes 

 Add-Ins 

4.6.7.1. VIEW > OPTIONS > APPEARANCE 

The Appearance (display) options are grouped into sections and control the colour and font options of 
the Browser Main window, i.e. when reading/browsing Occurrences. 
To set the appearance options in the Occurrence data entry mode use the 
"View > Options > Appearance" menu-item in the "Occurrence Edit" window (see page 108). 
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The Repository can be configured in such a way that not all options are available or can be changed. 
Contact your ECCAIRS System Administrator to have more information. 

 

 

You can either set or reset to default program values: 

 Data panel appearance: 

o Sections title colour 

o Sections background colour 

o Sections labels colour 

o Controls text colour 

o Controls background colour 

o Highlighted controls background colour 

o Controls border style (no border, solid black, 3D style) 

o Tooltips (none, on controls, on drop-down lists, all).  

 Topics tree appearance: 

o test colour 

o background colour. 

 
 Occurrence List appearance. 

If you are currently displaying the Occurrences from an Occurrence data file then you are 
customising that specific panel.  
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If, conversely, you are displaying Occurrences from a Query on the database then you are 
customising this other panel. 

 

You can set: 

o text colour 

o background colour 

o text for Locked Occurrences (either by you or by another User) 

o text font. 

Clicking on any of the colour selector displays a colour drop-down control.  

 

You can choose web-safe colours, Windows-system colours or even define a custom colour. 

Other non-colour related options are set via standard drop-down menus or font setting dialogs. 



BROWSER VIEW MENU 
 

 

60 

4.6.7.2. VIEW > OPTIONS > VIEW MANAGEMENT 

The "View Management " menu-item allows to add extra Views to the Browser, in addition to those made 
available for your Role in the Repository you are logged in. You can also configure when these extra 
Views will be available and also export them. 

You can select the extra Views using the "View > View with" sub-menu items and the "View" Toolbar 
drop-down list. The Views are listed after the Repository-preset Views. 
To manage Views you can right-click either on an empty part inside the "View Management" dialog 
which shows up or on one of the Views already listed, if any. 

 

Using the Right-click menu items you can:  

 Import and export Views. 
The Views are stored in View Project files (*.evd). Views are designed, produced and managed 
using the "View Designer" application.  

 Move the Views up and down in the list. 
This affects the order in which the Views are displayed in the selection menus ("View > View 
with" sub-menu items and the "View" Toolbar drop-down list). 

 Expand and collapse the conditions for the activation of each View. 
These are displayed as "children-properties" of each View. 

Once you have imported one or more Views you can set conditions that restrict (filter) the use of the 
Views.  

For instance some Views may be available only at Occurrence creation time, but not when subsequently 
editing them and other Views may be available only when displaying Occurrences but not when 
modifying them, etc. Furthermore a View can be available for reading or editing an existing Occurrence 
only if specific conditions on its Attribute(s) are satisfied. 

The panel lists all the Views imported arranged in a tree-view. Each View is a parent node of three 
standard Occurrence Management events:  

 View - when displaying an Occurrence.  

 Create - when creating a new Occurrence. 

 Edit - when modifying (editing) an existing Occurrence. 
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Availability Properties 

To each of these child nodes you can apply availability properties, using the Right-click menu-items: 

 

 Always available - the View Profile is available. 

 Never available - the View Profile is not available. 

The next menu-items are a set of logical operators to define conditions affecting the availability of the 
View. 

 Available only if - the View is available only if all conditions are satisfied (i.e. a logical AND of 
the conditions to allow the action).  
You have to specify one or more conditions (see next section). 

 Available unless - the View is available unless all conditions are satisfied. I.e. if all conditions 
are met then the action is denied (i.e. a logical AND of the conditions to deny the action). 
You have to specify one or more conditions (see next section). 

 Available if at least - the View is available if one (or more) conditions are satisfied (i.e. a logical 
OR of the conditions to allow the action).  
You have to specify one or more conditions (see next section). 

The next section shows how to specify the conditions and the order in which they are evaluated. 
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Specify Conditions on Views 

Once you have selected one type of logical operator on the conditions (only if, unless, if at least one) you 
have to specify the conditions.  
A "placeholder" condition is added by default as a child of the node representing the logical operator, 
and is labelled with the text "(missing conditions)". 

 

When you right-click on the condition placeholder you get an additional "Add condition" Right-menu item:  

 

 Add Condition... - the "ECCAIRS Query Builder" dialog shows up and you can set a Query that 
specifies the condition. The newly created conditions is listed as a child node of the type of 
condition chosen. 

When you right-click on items with a condition already set you get the following menu-items: 

 Edit Condition... - to edit and existing condition with the "ECCAIRS Query Builder" (see page 
259). 

 Remove condition - to remove the condition. 

 Move up/Move down - to change the order of evaluation of the conditions.  

 

To exit click use the two buttons at the bottom: 

 OK - to save the changes. 

 Cancel - to discard the changes made so far. 
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4.6.7.3. VIEW > OPTIONS > OCCURRENCE LIST 

The "Occurrence List " menu-item allows to select which Attributes are displayed as columns in the 
"Occurrence List" panel. By default the "Occurrence List" displays, for each Occurrences, a set of 
Attributes which have been defined for your Role in the Repository.   
The "Occurrence List" menu-item displays a sub-menu. 

 

Sub-menu items: 

 Advanced options - the set of Attributes to display in the "Occurrence List" panel is initially that 
foreseen for your Role in the Repository you are logged in. Selecting this menu-item you can 
change the set of Attributes, if the Browser Profile associated to the Role allows it. 
You can define the new set of Attributes using the "Occurrence List columns" that shows up (see 
below ). 
The Attributes chosen are then listed as items at the bottom of the sub-menu. 

 One row per Occurrence - there may be cases where some Attributes to be displayed belong to 
Topics which have multiple instances.  
For instance, in the Aviation domain, you may have the "aircraft registration" Attribute to display 
and more than one aircraft involved, i.e. more than one "Aircraft" topics defined in the 
Occurrence. 
Select/deselect this menu-item to choose whether to display them in a single line or with multiple 
lines within the Occurrence List. 

 Show all columns - you can return to the default set of Attributes by selecting "Show all 
columns". 

 list of Attributes to display - by default all the Attributes listed are displayed in the "Occurrence 
List" panel and a squared. 
You can remove/insert any of them by clicking on the corresponding menu-item. 
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Advanced Options: selecting Attributes to display in Occurrence List columns 

You can define the new set of Attributes to display using the "Occurrence List columns" dialog that 
shows up when selecting the " View > Options > Occurrence List > Advanced" menu-item. 

 

Dialog items: 

 List panel - (list box) the panel shows the Attributes that are currently displayed in the columns 
of the Occurrence List.  

 Restore Default Columns - (button) click to restore the set of Attributes that have been pre-set 
for the User/Role and Repository you are logged in. 

 OK - (button) click to save the changes made so far. 

 Cancel - (button) click to discard the changes made so far. 

 Edit - (button) click to show a "Query" dialog that let you change the Attributes to display, and 
their layout and display order. 
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The central panel shows which Attributes to display in Occurrence list, in the order in which they appear 
as columns in each Occurrence row. 

You can work on this list by way of a Toolbar and an Edit menu, offering the same functions: 

 Add - to add an Attribute to the list. You get a "Selection Builder" dialog where you can select the 
Attribute, through its Attribute Id. of via an Attribute browser dialog, and specify its Layout (e.g. 
which level to display for multiple-level Attributes, how to display a time/date Attribute, etc).  
You can also specify a sorting order, if any, on the Attribute values. The overall sorting for the 
Occurrence in the list is also determined by the order of the Attributes in the list (see "Move 
Up/Down" below). 

 Multiple Add - to add multiple Attributes in one go to the list. You get a standard "Attribute 
Selection" dialog with standard multiple selection functions, filtering and sorting options (see 
page 300). 

 Edit - same as "Add" but to edit the currently selected Attribute. 

 Remove - to remove an Attribute. 

 Clear - (only as menu-item, not in the Toolbar) clear the list, i.e. removes all the Attributes in the 
list. 

 Move Up/Down - to move up/down in the list the Attribute, i.e. the corresponding column will be 
moved left/right in the Occurrence list row.  If more than one Attributes in the list has a sorting 
options set (in the dialog shown for the "Add" or "edit" functions), then the order of the Attributes 
in the list will specify the overall sorting priority. The Occurrences will be sorted first by the 
"sorted" Attribute coming before in the list and then by the second "sorted", etc.   

 Cut, Copy, Paste - cut, copy and paste Attributes (and the associated display layout, etc) in the 
list. You can use these functions to easily duplicate Attributes in the list, for instance.  

 Query Description - (only in the Toolbar) to show the description of the query used to extract the 
Attribute to display. 

To exit the dialog there are two buttons at the bottom: 

 OK - to save the changes made so far. 

 Cancel - to discard the changes made so far. 
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4.6.7.4. VIEW > OPTIONS > E-MAIL SIGNATURE 

The ECCAIRS 5 Browser can send any number of Occurrences, selected in the "Occurrence List" pane, 
as an Occurrence file attached to an E-Mail message.  

You can do this by selecting the "File > Send to > E-Mail" menu-item.  
This function prepares the Occurrence file and opens a "New Message" window in your default E-Mail 
program, with the Occurrence file attached and a pre-defined E-Mail Subject and Body text. 

You can customise the pre-defined E-Mail Subject and Body text by selecting the 
"View > Options > E-Mail Signature" menu-item.  
An "E-Mail Signature" dialog shows up. 

 

Note that, depending on the specific Repository configuration set, the editing of E-Mail Signature options 
may be disabled. In this case you get a read-only version of the dialog. 
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Dialog items: 

 Subject - the Subject text-line of the message.  
You will always be able to edit the Subject text within your own E-Mail program, before actually 
sending the message. 

 Message - the text included in the Body of the message.  
You will always be able to edit the message text within your own E-Mail program, before actually 
sending the message. 

 Attachment filename - the name of the Occurrence file that will be generated and attached to 
the message. By default the name is "OccurrenceFile.e5f", or whatsoever file name set in the 
Repository for the profile associated to the User/Role currently logged in. 

 Ask Attachment filename - by selecting this item you will be asked the file name to generate 
and attach, each time you actually send Occurrences via the "File > Send to > E-Mail" menu-
item. This option may be disabled, depending on the specific Repository configuration set. 

Click: 

 Restore default - to reset the dialog items to the pre-defined values set in the Repository for the 
profile associated to the User/Role currently logged in. 

 OK - to confirm the settings made. 

 Cancel - to cancel the action. 

4.6.7.5. VIEW > OPTIONS > AUTOMATIC QUERY 
When you start the ECCAIRS 5 Browser and you log on to a Repository with a database, or you 
subsequently (re)connect to a Repository using the "File > Connect" menu-item, the Browser program 
may execute automatically a pre-defined Query, if any has been set, and then displays the resulting 
Occurrences in the "Occurrence List" panel. 

You can use this feature to automatically retrieve and show, for instance, the Occurrences entered 
yesterday, or during last week, or those still in a processing-state that you wish to monitor. 

The "Automatic Query" is set in the Repository within the profile associated to the User/Role currently 
logged in. 

However selecting the "View > Options > Automatic Query" menu-item you may edit or change the 
Query to be used, if the related profile in the Repository allows you to do so. An "Automatic Query" 
dialog shows up. 
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Note that, depending on the specific Repository configuration set, the Query editing  may be disabled.  
In this case you get a read-only version of the dialog. 

 

Dialog items: 

 Name - the field shows either the name of the Query currently in use, if taken from a Query 
Library, of the generic text "(Query)" if the Query has been defined standalone on the spot  (see 
below). 

The icon-buttons on the right let you:  

o Edit the Query - if you click the "pencil" icon-button the system displays the "Query 
Editing" window where you can: 

 Edit locally a Query already opened from a Query Library without the need to edit 
or define Queries using the Query Builder. 

 Create and edit standalone Queries, i.e. not stored in a Query Library. 

o Open a Query Library - if you click the "open" icon-button the system starts the 
ECCAIRS Query Builder application (see page ) that let you access and define Query 
Libraries and Queries. 

o Erase the Query - if you click the "eraser" icon-button to erase the currently defined 
Query.  
This way you can either get rid of the "Automatic Query" or then click the "pencil" icon-
button to define a Query form scratch, for instance. 

 Details - the explanation of the Query currently in use as "Automatic Query", where you see all 
the Criteria and the logical operators making up the Query. 

Click: 

 Restore default - to reset the dialog items to the pre-defined Query set in the Repository for the 
profile associated to the User/Role currently logged in. 

 OK - to confirm the settings made. 

 Cancel - to cancel the action. 
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4.6.7.6. VIEW > OPTIONS > DEIDENTIFIABLE ATTRIBUTES 

You can choose to save the Occurrences as de-identified in all the end-User applications of the 
ECCAIRS Reporting System that can export Occurrence data (e.g. Browser, Exporter, etc).  
This means that a number of Entities/Attributes/Values will be made unavailable in the saved 
Occurrences. 

The User/Role within the Repository you are logged in specifies some preset Attributes which will be 
mandatorily de-identified, when you save them as deidentified. 

However you can add extra Attributes to be de-identified. 

The dialog which shows up allows to select Attributes in the Taxonomy tree. 

 

In the "Attribute to deindentify" dialog there is a tree with check boxes for avereyEntity and Attribute. 
Browsing, filtering and sorting works as in the standard Attribute selection dialog (see page 293). 

Checking an item de-identifies the corresponding Attribute. 

All the set of Attributes of an Entity is displayed as a special Entity child node, marked in green colour 
and named "All Attributes".  
Checking this node you select for de-identification all the Entity Attributes. 

If you check the Entity node itself you select both all the Entity Attributes and also its child Entities (and 
corresponding Attributes) and its check box is marked. 
If you check only some Attributes/child Entities of an Entity then its check box will be still marked but the 
background will be displayed in gray. 

To exit the dialog there are two buttons at the bottom: 

 OK - to save the de-identify selection made so far. 

 Cancel - to discard the selections made so far. 
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4.6.7.7. VIEW > OPTIONS > ADD-INS 

This same menu-item is also available in the "View" menu of the "Occurrence Edit" window, in addition 
to the Browser Main window. 

The ECCAIRS 5 Browser can be connected to external software modules and applications in various 
ways. 

In the "Add-Ins" dialog you can define which programs to activate when some Attributes are changed, 
some additional menu-items are selected and some events take place.  

Note that, depending on the specific Repository configuration set, the editing of external module 
parameters may be available only to administrators.  

Each type of activation has a corresponding tab-panel. 

 

Dialog tab-panels: 

 Editor Extender - to activate Add-ins when editing a specific Attribute of the Occurrence. 

 User Menus - to activate Add-ins when you select a corresponding item in the menu. 

 Event Handlers - to activate Add-ins when some specified event takes place (e.g. after Query 
execution, when an Attribute added, before Occurrence deletion, before Occurrence insertion, 
etc). 

Each panel shows the list of Add-Ins currently defined for the corresponding activation type. 

Using the buttons on the right of the panel you can add, delete, edit external software modules to be 
invoked and also change the their activation order, when more than one module is defined for each 
category of activation. 
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Note that, depending on the specific Repository configuration set, the editing of external module 
parameters may be available only to administrators. 

When you add or edit a specific Add-In, an activation-type specific configuration dialog shows up. 

 

Depending on the type of activation you have to provide activation-related data. 

However, for all the Add-Ins, whatever their activation type, you have to provide some basic software 
module information (in the "Activation" section top part of the Add/Edit dialog). 
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Software module information items: 

 Name - a name for the Add-In. 

 Activation type - the software framework in which the Add-In has been programmed to 
communicate with the ECCAIRS system: .NET or COM. 

 Assembly / class - the Assembly (software library module) and the specific class (method) to 
invoke when the triggering action takes place. All the assemblies and corresponding classes are 
selectable via drop-down lists. The selections you should make are described in the 
installation/technical documentation provided with the Add-In or from the ECCAIRS System 
Administrator. 

 Configuration - clicking on the corresponding "Edit" button on the right you get an activation-
type specific dialog where you may configure the Add-In, whenever appropriate.  
The information to be provided in the dialog depends on the specific Add-In and is described in 
the  Add-In technical documentation. 
If configuration is needed and you have not yet done so when closing the Add/Edit dialog, 
ECCAIRS displays a warning message. 

 

 Properties - displays summary technical information on the Add-In. 

Also, in the bottom of the Add/Edit dialog you find three other controls, shared by any type of activation-
specific Add-In dialog: 

 Enabled - choose this option to enable the Add-In. Each Add-In enabled by default. 
If you do not want the Add-In to be executed, without removing it, than you can deselect the 
check-box. 

 OK - click the button to confirm the Add-In settings made. 

 Cancel - click the button to discard the settings made. 
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In the central "Details" section of the Add/Edit dialog you can specify how/when the Add-In is triggered 
(activated).  
The parameters to provide depend on the type of activation and are illustrated below.  

Editor Extender 

The Add-In is activated when you edit a specific Attribute in the Occurrence. 

 

In the "Editor Extender" dialog that shows up when you add/edit modules you have to specify, in the 
"Detail" section, the Attribute whose editing will trigger the external software module.  
This is done via the standard Attribute selection dialog. (see page 293). 

User menus 

The Add-In is activated when you select a corresponding item in the menu. 
When you add/edit this type of Add-In a "User Menu" dialog shows up. 

 

Dialog items: 

 Name - Group Name - the module name that you specify in the "Name" field will also be the 
name of the menu-item that will be shown. This menu-item will be placed in the sub-menu "Add-
Ins > Group Name", where "Group Name" is a text field that you specify in the Details section of 
the dialog.    
In practice, if "Name" is set to "New menu-item 1" and "Group name" is set to "My New Menu 
Group", then the new menu-item  is located in "Add-Ins > My New Menu Group > New menu-item 
1" in the Browser Menu bar. 
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 Available in - You then have to specify, again in the Details section, when the Add-In menu-item  
will be available. You may have any number of availability rules. Each of them will be evaluated 
and if any of them is satisfied then the menu-item is displayed in the corresponding Scope/View 
and Topic context. 
When you add/edit availability rules you get a "Custom menu available in" dialog. 

 

Dialog items: 

o Scope - specifies in which ambit the rule operates, i.e. within the Browser Main window, 
the Editor, etc. 
By default you get "Any scope" selected. 

o View - the specific View where the Add-In menu-item will be available, chosen among 
those available for your Role in the Repository you are logged in. This means that the 
Add-In menu-item may be displayed in some Views and not in other ones.  
By default you get "Any view" selected. 

o Topics - if you select a View then you have to specify for which of its Topics the Add-In 
menu-item will be available. By default the Occurrence (root Topic) and all its child Topics 
are selected. You can keep the keyboard "CTRL" key pressed when selecting Topics to 
select or deselect also their child Topics. 

Click: 

o OK - to confirm the availability settings. 

o Cancel - to cancel the action. 
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Event handlers 

The Add-In is activated when some specified event takes place. 
In the "Event Handler" dialog that shows up  you have to select, in the "Details" section, the triggering 
events among the "Activation events" listed . 

 

The events which can trigger the Add-In are: Active Occurrence List changed, After Occurrence delete, 
After Occurrence insertion, After Occurrence update, After Query batch execution (i.e when switching to 
another batch of results for the Query execution), After Query execution, Attribute added, Attribute 
edited, Attribute removed, Before Occurrence delete, Before Occurrence insertion, Before Occurrence 
update, Before Query execution, Creating new Occurrence, Editing Occurrence, Opening a file, Stop 
Occurrence editing, Viewing / retrieving Occurrence. 

Note 

A detailed description on how these Add-Ins should be used can be obtained from your ECCAIRS 
System Administrator.  
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4.7. DATABASE MENU 
The Database menu includes functions related to Occurrences in the database. 

 

Menu items: 

 Build Query 

 Query by date 

 Query by example 

 Refresh Query 

 Show current Query 

 Go to Batch 

 Re-run the Most Recently Used Queries 

 

The menu and menu-items are completely customisable and may contain fewer items than those 
described here, depending on the specific User/Role and Repository you are logged in.  
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4.7.1. DATABASE > BUILD QUERY 

The ECCAIRS Browser selects the Occurrences from the database through Queries. 

Whenever you select the "Database > Build Query" menu-item the system shows the "Query Builder" 
tool (see page 259). Within the "Query Builder" tool you can design or select the Query to execute. 

To exit the "Query Builder" window there are two buttons at the bottom: 

 OK - to execute the Query and display the Occurrences selected in the "Occurrence List" pane. 

 Cancel - to exit the dialog. 

The "Occurrence List" panel uses a specific display colour layout when showing the Occurrences 
resulting from database Query.  
This colour layout is different from the one used when displaying Occurrences from files.  

In case more Occurrences should result from the Query then the batch size parameter specified in the 
Repository you are logged in, the resulting Occurrences are displayed in batches.  
You can display and navigate through different batches of Occurrences using the "Database > Go to 
Batch" menu-item (see page 80). 

4.7.2. DATABASE > QUERY BY DATE 

The ECCAIRS Browser provides the facility to sort and plot in an date-based grid the count of 
Occurrences selected with a Query. 

Proceed as follows: 

 Select the "Database > Query by date" menu-item. The "Query By Date" dialog opens. 
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 Select a Query among those listed in the "Based on Query" drop-down list. The list includes all 
the Queries within the currently open Query Library. 
The related year/month plot is immediately displayed. 

 Pushing the "Query details" button displays a dialog with a natural language explanation of the 
currently selected Query. 

 You can select one of the pre-defined set of "type of date-Attribute and grid-layout" through the 
"Name" drop-down list. These heave been set in the Repository manager for your User/Role 
profiles. 

 If you click on a specific cell (i.e. for instance on a specific month and year combination) and then 
clicking on the "OK" button, the related Occurrences are loaded into the "Occurrence List" pane. 

Choose the "Include empty values" option to include also Occurrences with an empty date Attribute in 
a separate column. 

 

You can refresh the Query by clicking on the "Refresh Result" blue link below the "Query details" 
button. This may be useful in case the database data has changed in the meantime. 

To exit the dialog click the "Cancel" button. 
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4.7.3. DATABASE > QUERY BY EXAMPLE 

The ECCAIRS Browser provides the facility to make a Query by filling a template a Section with the data 
Values you wish to select. The Section used for the example-based Query is set in the Repository for the 
specific User/Role you are logged in. 

The programs shows a "Query by Example" dialog with the Query Section template. Fill in the values 
you wish to use as selections for the Query. You do it exactly the same way as when editing an 
Occurrence.  

 

To exit the dialog click: 

 OK - to run the Query. 

 Cancel - to exit the dialog. 

4.7.4. DATABASE > REFRESH QUERY 

Since the content of the ECCAIRS database Repository is dynamic and may be updated at the same 
time a User is executing a Query, the Query results may vary. 

Selecting "Database > Refresh Query" menu-item will re-execute the last Query executed on the 
database. 

In case more Occurrences should result from the Query then the batch size parameter specified in the 
Repository you are logged in, the resulting Occurrences are displayed in batches.  
You can display and navigate through different batches of Occurrences using the "Database > Go to 
Batch" menu-item (see page 80). 
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4.7.5. DATABASE > SHOW CURRENT QUERY 

Selecting this menu-item opens a "Query Explanation" dialog containing a natural language explanation 
of the current Query, i.e. the last Query executed. 

 

You can use the buttons at the bottom to: 

 Save - save the explanation text to a text file.  
A standard file browser dialog let you set the folder and filename. 

 Copy - save the explanation text to the clipboard. 

 Print - print the explanation. 

 Close - close the "Query Explanation" dialog. 

4.7.6. DATABASE > GO TO BATCH 

When a Query is executed, the matching Occurrences are listed  in batches, i.e. the Occurrence List 
panel displays only a number of Occurrences equal (or at most equal) to the batch size.  
The batch size is specified in the Repository Profiles for the Role/Users of the Repository you are logged 
in. If not specified otherwise, the default size of the batch is 500 Occurrences. 

When operating with databases containing a large number of Occurrences, batch and warning settings 
may be very useful to optimise system resources and response times.  

When the number of Occurrences returned by a Query exceeds the batch size specified in the 
Repository Profile, then you use: 

 Status bar Batch Numbering - the Browser Status bar displays the total number of 
Occurrences, resulting from the Query, the number of Occurrences displayed in the Occurrence 
List, which corresponds at most to the batch size, the current batch number and the total number 
of batches (e.g. "Batch1/2" means batch 1 out of 2). 
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  Batch navigation via menu - you can switch from one batch of results to another by .selecting 
the "Database > Go to batch > Batch n/m" menu-items. 

 

 Sorting Occurrences in batches - if you try to sort the Occurrences in the "Occurrence List" by 
clicking on the header of any of its columns, you may choose between "Sort all results" form the 
Query, i.e. sorting across all batches, or "Sort current batch",  i.e. sorting the Occurrences 
displayed in the current batch only. 

 

Additional Batch and Query result size options 

The ECCAIRS System Administrator may have set, for the Repository you are logged in, some 
additional parameters to optimise the system when using batches with large amounts of Query results: 

 Count Occurrences and warn when it exceeds a value - if  this option has been set  then 
whenever you execute a Query a preliminary Query matching "count" is performed. 
If the count exceeds a value specified in the Repository Profile then you get a warning dialog.  

 

You can confirm with "Yes" and go on with the Query execution or cancel it by clicking on "No". 
This option turns out useful when you would get a very large number of Occurrences form the 
Query. Since the actual execution may take a considerable amount of time and system 
resources, you have the opportunity to cancel the current Query and reformulate it to get fewer 
results. 
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 Full batch navigation quota -  (check box and numeric entry) if  this option has been set and 
the Query returned ones exceeds the value specified for the Repository you are logged in, then 
only that number of Occurrences will be extracted and made available immediately. The "batch 
quota exceed" situation is reported in the ECCAIRS Browser both in the: 

o Status bar - where  the "+" sign is appended both to the "Total" number of Occurrences 
and to the number of "Batches". 

 

o "Database > Go to batch" menu-item - where  the "+" sign is appended to the batch 
items listed as sub menu-items. 

 

Selecting the "Database > Go to batch > Next batch" last menu-item causes the 
Browser to execute the next "chunk" of Query and get the next Occurrences (up to the 
quota value, again). 

Using with the "Full batch navigation quota" option allows to use less system resources and get 
quicker response in case of large number of Occurrences resulting from a Query.  
But ECCAIRS has actually executed, and has ready available for the Browser, only a part of the 
Query results.  
So if, in the Occurrence List", if you try to "sort all results" form the Query (rather than those 
shown in the current batch displayed),  
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then you get an "operation non supported" warning and you can actually only sort Occurrences 
within the current batch (the sample warning dialog below refers to a "quota" value of 40). 

 

4.7.7. DATABASE > RE-EXECUTE LAST QUERIES 

The last items in the "Database" menu are the last four Queries executed.  

Each item is identified by the Query name, as given in the Query Library. 

You can then easily re-run any of them by selecting the corresponding menu-item. 

In case more Occurrences should result from the Query then the batch size parameter specified in the 
Repository you are logged in, the resulting Occurrences are displayed in batches.  

You can display and navigate through different batches of Occurrences using the "Database > Go to 
Batch" menu-item (see page 80). 

 



BROWSER OCCURRENCE MENU 
 

 

84 

4.8. OCCURRENCE MENU 
The Occurrence menu includes functions related to Occurrence editing and printing. 

 

Menu items: 

 New 

 Edit 

 Delete 

 Lock Occurrence 

 Release Occurrence 

 Print preview 

 Print 

 Print as PDF 

 Generate Document with Template 

 

The menu and menu-items are completely customisable and may contain fewer items than those 
described here, depending on the specific User/Role and Repository you are logged in.  
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4.8.1. OCCURRENCE > NEW 

A new Occurrence can be created by selecting "Occurrence > New" from the Menu bar, or clicking on 
the corresponding icon-button in the Toolbar. 

The new Occurrence may be is created with some predefined Attribute Values defined in a template, if 
any. 
Templates for new Occurrences are associated to specific Views, i.e. may depend on the specific View 
selected. The Views are both those defined in the Repository and associated to your User/Role (and are 
grouped in the "Views" View-group sub-menu) and those defined by the User (see page 60).  

The sub-menu system to select the template can be quite complex. You have to select: 

 first select either "Views", to use the group of predefined Views, or the display name of any of the 
custom Views, if defined. 

 then, for predefined Views, select the specific View. 
For custom Views you have a single sub-menu item with the name of the View. 

 then select one of the specific templates associated with the View. 

 

This creates a new Occurrence, with the default Attribute Values specified in the template and opens it in 
a separate Occurrence Edit window (see page 95). 
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4.8.2. OCCURRENCE > DUPLICATE 

You can create a copy of an Occurrence by selecting the source Occurrence in the "Occurrence List" 
panel and then either the "Occurrence > Duplicate Occurrence" menu-item, or the corresponding icon-
button in the Toolbar. 

The duplicated Occurrence is created and opened using a specific View. 

So you have to use a 2-level sub-menu to select a View among those listed in the 
"Occurrence > Duplicate" sub-menu items. 

 

The Views available are both those defined in the Repository and associated to your User/Role (and are 
grouped in the "Views" View-group sub-menu) and, if any, those defined by the User, which are grouped 
under other View-group sub-menus. 

The system creates a new Occurrence and opens it within the Occurrence Edit window (see page 95)., 
This duplicated Occurrence contains exactly the same Attribute Values as the source one, except for a 
set of special Attributes specified in the Taxonomy used by the Repository.  

4.8.3. OCCURRENCE > EDIT 

An Occurrence can be modified either selecting "Occurrence > Edit " or the "Right-click-menu > Edit" 
menu-items, or even by double-clicking on an Occurrence in the "Occurrence List" pane. 

This opens the Occurrence Edit Window (see page 95). 

A modified Occurrence is always stored back in the originating source, either the database or the 
Occurrence file from which it was taken. 

During editing, the Occurrence in the database is automatically locked for other Users: they can display 
the Occurrence but cannot edit it. 
When editing is over the Occurrence lock is automatically released. 

You can also manually lock an Occurrence and release the lock. You do this with the 
"Occurrence > Lock" and "Occurrence > Release" menu-items.  
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4.8.4. OCCURRENCE > DELETE 

You can delete the selected Occurrences by either the "Occurrence > Delete" menu-item or, within the 
"Occurrence List" pane, the "Right-click > Delete" menu-item. 

If you have enabled the "Recycle Bin" feature then the Occurrences deleted are kept in the Browser 
Recycle Bin. You can recover them up to the moment you will empty Recycle Bin. You access the 
Recycle Bin by selecting the "File > Recycle bin" menu-item (see page 45). 

A dialog asks you to confirm before actually performing the Occurrence(s) removal. 

 

Click: 

 OK - to confirm the Occurrence(s) removal. 

 Cancel - to close the dialog without removing any Occurrence. 

4.8.5. OCCURRENCE > LOCK OCCURRENCE 

Automatic Occurrence Lock 

When creating or modifying Occurrences in the database, ECCAIRS automatically puts a lock on the 
Occurrence. The User can also manually put and release locks on selected Occurrences. 

The lock prevents other Users to edit or delete the same Occurrence at the same time. 

In the "Occurrence List" panel the locked Occurrence is marked with a key-shaped icon and a specific 
colour. The lock-marking colour is different when the lock has been put by a different ECCAIRS User 
from the one who is currently logged in, and hence cannot be released by the current User. Positioning 
the mouse over locked Occurrences in the "Occurrence List" pane, displays additional data on the 
Occurrence lock: the author of the locking and the initial locking date and time. 

 

The colours used to mark the lock can be customised in the Appearance tab of the 
"View > Options > Appearance" menu-item. 

After the editing completion the Occurrence is automatically released. 
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User-requested Occurrence Lock 

Occurrence locking can also be explicitly set by the User, even when no editing is in course, to prevent 
other Users from modifying the Occurrence. 

This is achieved by selecting the Occurrence(s) and selecting the "Occurrence > Lock Occurrence" 
menu-item. 
The Occurrence(s) remains locked until the User releases the Occurrence, even if the locking User 
disconnects from the Repository or logs off the system. 

4.8.6. OCCURRENCE > RELEASE OCCURRENCE 

The locked Occurrence can be released, by the same User who put the lock, by selecting the 
Occurrence and selecting the "Occurrence > Release Occurrence" menu-item. 

4.8.7. OCCURRENCE > PRINT PREVIEW 

The "Occurrence > Print Preview" menu-item let you preview the printout of all the Occurrence sections 
that have been filled-in in the currently selected Occurrence. 

The layout is the same as that illustrated for the "Occurrence > Print" menu-item, and you will be able to 
command a print directly from the preview as you would have done in that function. 

A "Print preview" dialog displays the printout preview.  
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Print Preview dialog 

In the "Print preview" dialog there are number of options are available through the Toolbar and the 
navigation bar at the top. 

 

You can: 

 print - invoke the standard Windows print dialog, where you can choose printer and options. 

 zoom - select the zoom level with the drop-down selector. 

 1 page - preview 1 page at a time. 

 2 pages - preview 2 page at a time. 

 3 pages - preview 3 page at a time. 

 4 pages - preview 4 page at a time. 

 6 pages - preview 6 page at a time. 

 close - close the "Print preview" dialog. 

 page select - a box with the number of the page being previewed.  
To go to a specific page you can: 

o use the step up/down controls at the right of the page-number box to move to the 
next/previous page. 

o enter a page number in the page-number box. 

You can also use the "Page Up" and "Page Down" keyboard keys to move to the next/previous 
page. 
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4.8.8. OCCURRENCE > PRINT 

The "Occurrence > Print" menu-item allows to print all the Occurrence Sections that have been filled-in 
for the currently selected Occurrences. 
This menu item is also available in the "File" menu of the "Occurrence Edit" window, in addition to the 
Browser Main window.  
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The printing layout is preset and is bound to the View currently selected: each View may have a different 
printing page layout. 
The picture below shows a different printing layout bound to another View ("Bird strike notification" in this 
example). 

 

The function invokes the standard Windows print dialog, where you can choose printer and options. 
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4.8.9. OCCURRENCE > PRINT AS PDF 

The "Occurrence > Print as PDF" menu-item works Same as the "Occurrence > Print" menu-item.  

The only difference is that you have to enter a name and select a folder for the PDF file that is being 
created using the standard "Save" dialog. 

  

4.8.10. OCCURRENCE > GENERATE OCCURRENCE DOCUMENT WITH 
TEMPLATE 

You can generate a document with data from the Occurrences selected in the "Occurrence List" panel 
using any of the preset templates available as submenu-items. 

 

The templates listed are preset in the profile associated to the User/Role currently logged in the 
Repository. 

You can anyway use your own templates selecting the "Occurrence > Generate Occurrence document 
with template > Browse for template" sub menu-item.  
Instructions on how to build templates are included in dedicated documentation, normally available in the 
ECCAIRS portal site: 

http://eccairsportal.jrc.ec.europa.eu 

 

You can also directly select the last used template file, listed as last item. 
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4.9. ADD-INS MENU 
The ECCAIRS 5 Browser can be connected to external software modules called Add-Ins.  

Depending on the configuration set on the Repository for the Role/User you are logged in, you may be 
have some "Add-Ins" that you can execute when you select a specific additional menu-item.  

The Add-Ins menu-items can also be made available only for specific Views, Topics or operating mode 
(read or edit mode). 

Note that, depending on the specific Repository configuration set, you may also be able to modify the 
configuration for the Add-Ins using the "View > Options > Add-Ins" menu-item in the Browser itself (see 
page 70). 

In any case, if Add-Ins are available, the Add-Ins menu is displayed in the Menu bar. 

It has sub-menus grouping menu-items specific to each Add-In. 
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4.10. HELP MENU 

 
Menu items: 

 Contents  

 Taxonomy Browser  

 About 

4.10.1. HELP > CONTENTS  
Displays online help for the application you are running. 
You can also invoke the online help at any time by pressing the "CTRL" and "F1" keyboard keys at the 
same time. 

4.10.2. HELP > TAXONOMY BROWSER  
Starts the Taxonomy Browser application, which allows you to examine in a separate window all details 
of the Taxonomy in use. This can be useful while editing Queries, selecting and editing Attributes. 

4.10.3. HELP > ABOUT 
Opens a dialog displaying details on the version of the application you are running. 
Click the "OK" button to acknowledge and close the dialog. 
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4.11. OCCURRENCE EDIT WINDOW 
The "Occurrence Edit" window is based on the "Information" panel of the main Browser window. 
However, it is a separate independent window and thus co-exists with the main Browser window. 

 

The "Occurrence Edit" window has a different default background and colour scheme, to distinguish it 
from the browse-read Info Panel of the main window . 

The colour scheme used can be customised using the "View > Options > Appearance" menu-item in the 
"Edit Occurrence" window (see page 108). 

The "Occurrence Edit" window is used to: 

 add/edit Topics (see page 106). 

 add/edit the Attributes Values included in the Topic (see page 301). 

The Topics and Sections are View-dependent. You can change the current View by using the 
"View > View with" menu-item or the corresponding Toolbar item: both work exactly as the same items in 
the Browser Main window. 

"Occurrence Edit" window items: 

 Menu bar - to access all the Occurrence editing functions (see page 96). 

 Toolbar - offers a quick visual access to a set of commonly used functions (see page 96). 

 Information Panel - hosting the "Topic-tree" and "Topic-data" sub-panels, exactly the same 
items in the Browser Main window. This time however you can enter/edit Topics and Attributes. 

 Right-click menu - available inside the "Topic-tree panel" to work with the Topics inside the 
Occurrence being edited. Its menu-items are the same as those in the Topics menu (see page 
105). 
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4.11.1. MENU BAR 

The Menu bar includes different menus to access the editing functions: 

 

 File menu (see page 100). 

 Topics menu (see page 105). 

 View menu (see page 107). 

 Add-Ins menu (see page 110) - displayed only if Add-Ins are configured in User menu. 

 Help menu (see page 111). 

The menu and menu-items are completely customisable and may contain fewer items than those 
described here, depending on the specific User/Role and Repository you are logged in.  

4.11.2. TOOLBAR 

The Toolbar offers a quick visual access to a set of commonly used functions in the "Occurrence Edit" 
window. 

  

In fact the Toolbar is a customisable ("View > Toolbars" menu-item) set of task-specific Toolbars: 

 Occurrence Toolbar - icon-buttons performing the same functions of the "File" menu-items. 

 

 View Toolbar - icon-buttons performing the same functions of the "View" menu-items. 

 

Stopping the mouse pointer (no clicking !) over the Toolbar icon-buttons in ECCAIRS causes the display 
of a Tooltip, i.e. a brief description of the actions-functions associated. 

 

The menu and menu-items are completely customisable and may contain fewer items than those 
described here, depending on the specific User/Role and Repository you are logged in.  
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4.11.3. ADDING ATTACHMENTS 

You can attach any document to an Occurrence, provided that the Repository Taxonomy and the View 
that you are using both envisage Attachments, and also if the User/Role you are logged in with allows to 
manage Attachments. 

Attachments are handled as a specific type of Attribute which can be placed in any Section of a Topic of 
a View.  

Attachments may be used wherever the View in use foresees them. So it may well be that, for the same 
Occurrence, a View allows to add Attachments and another does not.  

To add Attachments: 

 Select the Topic/Section where the Attachments are foreseen. 
There may be, for instance, a specific "Attachment" Topic, including a single Section with the 
"Attachment" Attribute. 
Or there may be a Section with an "Attachment" Attribute in any Topic. 
In case of a specific "Attachment" Topic, you need to add it first to the Occurrence, if not already 
present. 
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 The Section including Attachments displays the list of Attachment included with the Occurrence. 

 

You can select any item and view it and save it Same as you do when viewing Occurrences with 
Attachments (see page 34). 

 Click the large "add" icon-button on the right of the panel.  
An "Attachments" dialog shows up. 

 

In the dialog you can perform a number of functions through the "File" menu-items and the 
corresponding "Right-click" menu-items in its Attachments list central pane: 

o Add - to add an Attachment using the standard "Open" dialog to pick up the file. 

o Open - to open the selected Attachment using the associated application in Windows.  

o Detail - to show a dialog with a set of properties of the Attachment file. 
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o Save - to save the selected Attachment using the standard "Save as" dialog to select the 
save folder and, if desired, rename it at the same time.  

o Remove - to remove the selected Attachment. 

Close the "Attachments" dialog by clicking on:  

 OK - to save the changes made 

 Cancel - to discard them. 

 

Attachments can be listed and displayed/extracted in the Browser read mode (see page 34). 
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4.12. FILE MENU (EDIT WINDOW) 
The File menu includes mainly functions to save and print the Occurrence while editing. 

 

  

Menu items: 

 Save Occurrence 

 Save Occurrence and stop editing  

 Check for duplicated Occurrences  

 Send to 

 Append to current file  

 Page setup  

 Print preview 

 Print  

 Print as PDF  

 Generate Occurrence document with template  

 Exit  

 

The menu and menu-items are completely customisable and may contain fewer items than those 
described here, depending on the specific User/Role and Repository you are logged in.  
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4.12.1. FILE > SAVE OCCURRENCE  

When saving a new Occurrence you are asked to save it in either: 

 

 Database - the currently opened database.  

 File - the currently opened Occurrence file. If these is no file Occurrence file already opened the 
Occurrence is placed in the empty File-originated "Occurrence List" in the Browser Main window. 

If the Occurrence is missing any mandatory Attribute value then an "Invalid Occurrence" error dialog is 
displayed.  

 

You can choose to display details and you can also copy them to the clipboard, save them to a text file 
and print them. The "Close" button exit the dialog. 
You then have the information needed to provide the missing Attribute values. 

When you save the Occurrence and automatic detection of duplicated Occurrence is performed.  
In case a potential duplication is detected the Occurrence is not saved and the system displays an error 
dialog. 
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4.12.2. FILE > SAVE OCCURRENCE AND STOP EDITING  

Saves the Occurrence as with "File > Save Occurrence" and then exits the "Occurrence Edit" window. 

4.12.3. FILE > CHECK FOR DUPLICATED OCCURRENCES  

The check for duplicated Occurrences is made between the Occurrence being edited and the 
Occurrences currently in the database. This check is in any case executed automatically when saving 
the edited Occurrence in the database.  

The menu-item is enabled only if a proper "Duplicate Occurrences" detect condition has been set in the 
"Browser Profile" assigned to the current User/Role in the Repository.  

If any duplicate Occurrence is found a "Duplicate Occurrences" dialog is displayed. 

 

The dialog is a self-standing window that you may keep open while working with the "Occurrence Edit" 
and Browser Main windows.  
You may wish, for instance, to keep the dialog open while you modify in the "Occurrence Edit" window 
the Attributes values which trigger the duplication detection. 

Its layout includes a Menu bar and a Toolbar at the top and a Status bar at the bottom. 
The central panel is Same as the "Occurrence List" panel in the Browser Main window, and so is its 
"Status bar". 

The Toolbar is composed by the "Edit" and the "File" sections, that you can separately enable/disable 
from the "View > Toolbars" menu-item. 

The Menu bar has four menus: File, Edit, View and Filter. 

All of the menu-items correspond to functions available in the Browser Main window menus, but are 
specific to the duplicated Occurrence(s) found and listed in the central pane. You can, for instance, send 
the duplicated Occurrence(s) to a File or E-Mail address, filter the list, etc. 
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The only "Duplicate Occurrences" dialog-unique menu-item is "View Occurrence" which, in turn, when 
selected opens a "Mini Browser" window where you can examine the content of the duplicate 
Occurrence selected as with the "Occurrence Information" panel in the Browser Main window. 

 

4.12.4. FILE > SEND TO  

Sends the Occurrence to either an E-Mail address, or an Occurrence File or to the current Database. 
Same as the "File > Send to" menu-item in the Browser Main window (see page 44). 

4.12.5. FILE > APPEND TO CURRENT FILE  

Appends the Occurrence to the Occurrence file currently open.  

This menu-item is enabled only when editing an existing Occurrence from the database.  

In this case the edited Occurrence will be saved to the currently opened Occurrence file rather than to 
the database. 

4.12.6. FILE > PAGE SETUP  

 Same as the "File > Page setup" menu-item in the Browser Main window (see page 47). 

4.12.7. FILE > PRINT PREVIEW - OCC. EDIT WINDOW 

Same as the "Occurrence > Print preview" menu-item in the Browser Main window (see page 88). 
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4.12.8. FILE > PRINT  

 Same as the "Occurrence > Print" menu-item in the Browser Main window (see page 90). 

4.12.9. FILE > PRINT AS PDF  

 Same as the "Occurrence > Print as PDF" menu-item in the Browser Main window (see page 92). 

4.12.10. FILE > GENERATE OCCURRENCE DOCUMENT WITH TEMPLATE  

Same as the "Occurrence > Generate Occurrence document with template" menu-item in the Browser 
Main window (see page 92). 

4.12.11. FILE > EXIT  

 Exits the "Occurrence Edit" window. 
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4.13. TOPICS MENU (EDIT WINDOW) 
The Topics menu-items let you select any child Topics that you wish to add to the Topic currently 
selected in the "Tree-data" sub-panel in the "Occurrence Edit" window.  

  

Menu items: 

 Add Topic  

 Link Topic  

 Remove "Topic-type"  

 

The menu and menu-items are completely customisable and may contain fewer items than those 
described here, depending on the specific User/Role and Repository you are logged in.  
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4.13.1. TOPICS > ADD TOPIC  

To add a Topic to the Occurrence you have to select the parent Topic, which may be the Occurrence 
itself, then select either the "Topics > Add Topic" or the "Right-click > Add Topic" menu-item and the type 
of child Topic to add.  

 

The system proposes as the "Topic > Add Topic" menu-items all the available types of child Topics for 
the parent Topic selected.  
The possible child Topics are set in the View you have currently selected, whose content is strictly bound 
to and constrained by the underlying Taxonomy. 

4.13.2.  TOPICS > LINK TOPIC > "TOPIC TYPE" 

You get this menu-item only if the currently selected Topic allows linkable Topics  
Use its sub menu-items to select the Topic to link. Linking a Topic let you refer to a Topic which is not a 
child Topic. This means that multiple Topics can be linked to the same Topic, which you cannot do with 
child Topics.  

4.13.3. TOPICS > REMOVE "TOPIC-TYPE"  

Removes the Topic currently selected in the Topic-tree. Beware that if you select the root Topic, i.e. the 
Occurrence itself, than you will remove the whole Occurrence. 

4.13.4. TOPICS > UNLINK  

If the Topic that you try to remove is not a child Topic but is link to another Topic (linked Topic), then you 
remove the link. The linked Topic is not removed. 
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4.14. VIEW MENU (EDIT WINDOW) 
The View menu includes miscellaneous display options.  

 

Menu items: 

 View with  

 Toolbars  

 Copy data window  

 Show all Topics in tree  

 Options 

 

The menu and menu-items are completely customisable and may contain fewer items than those 
described here, depending on the specific User/Role and Repository you are logged in.  
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4.14.1. VIEW > VIEW WITH  

Same as the "View > View with" menu-item in the Browser Main window (see page 52). 

4.14.2. VIEW > TOOLBARS  

By default all the Toolbars are visible. You can however select which of the Toolbars to display: 

 Occurrence Toolbar. 

 View Toolbar. 

4.14.3. VIEW > COPY DATA WINDOW  

Same as the "View > Copy Data Window" menu-item in the Browser Main window (see page 56). 

4.14.4. VIEW > SHOW ALL TOPICS IN TREE  

Same as the "View > Show All Topics in a Tree" menu-item in the Browser Main window (see page 57). 

4.14.5. VIEW > OPTIONS  

4.14.5.1. VIEW > OPTIONS > ADD-INS 

Same as the "View > Options > Add-Ins" menu-item in the Browser Main window (see page 70). 

4.14.5.2. VIEW > OPTIONS > APPEARANCE 

The Appearance (display) options are grouped into sections and control the colour and font options of 
the "Occurrence Edit" window. 
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You can instead set the appearance options of the Browser Main window, i.e. when reading/browsing 
Occurrences, with corresponding the "View > Options > Appearance" menu-item (see page 57). 

You can either set or reset to default program values: 

 Data panel appearance: 

o Sections title colour 

o Sections background colour 

o Sections labels colour 

o Controls text colour 

o Controls background colour 

o Highlighted controls background colour 

o Controls border style (no border, solid black, 3D style) 

o Tooltips (none, on controls, on drop-down lists, all)  

 Topics tree appearance: 

o text colour 

o background colour 

Clicking on any of the colour selector displays a colour drop down control.  

 

You can choose web-safe colours, Windows-system colours or even define a custom colour. 

Other non-colour related options are set via standard drop-down menus or font setting dialogs. 

Note 

Your Repository Administrator can configure your environment in such a way that not all options are 
available or can be changed. Contact your ECCAIRS Reporting System administrator to have more 
information. 
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4.15. ADD-INS MENU (EDIT WINDOW) 
The ECCAIRS 5 Browser can be connected to external software modules called Add-Ins.  

Depending on the configuration set on the Repository for the Role/User you are logged in, you may be 
have some "Add-Ins" that you can execute when you select a specific additional menu-item.  

The Add-Ins menu-items can also be made available only for specific Views, Topics or operating mode 
(read or edit mode). 

Note that, depending on the specific Repository configuration set, you may also be able to modify the 
configuration for the Add-Ins using the "View > Options > Add-Ins" menu-item in the Browser itself (see 
page 70). 

In any case, if Add-Ins are available, the Add-Ins menu is displayed in the Menu bar. 

It has sub-menus grouping menu-items specific to each Add-In. 
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4.16. HELP MENU (EDIT WINDOW) 

 
Menu items: 

 Contents  

 Taxonomy Browser  

 About 

4.16.1. HELP > CONTENTS  
Displays online help for the application you are running. 
You can also invoke the online help at any time by pressing the "CTRL" and "F1" keyboard keys at the 
same time. 

4.16.2. HELP > TAXONOMY BROWSER  
Starts the Taxonomy Browser application, which allows you to examine in a separate window all details 
of the Taxonomy in use. This can be useful while editing Queries, selecting and editing Attributes. 

4.16.3. HELP > ABOUT 
Opens a dialog displaying details on the version of the application you are running. 
Click the "OK" button to acknowledge and close the dialog. 

 



BROWSER HELP MENU (EDIT WINDOW) 
 

 

112 

 

THIS PAGE IS LEFT INTENTIONALLY BLANK 

 



GRAPHER USING THE GRAPHER 
 

 

113 

5. GRAPHER 

5.1. USING THE GRAPHER 

5.1.1. WHAT IS THE ECCAIRS GRAPHER 

The ECCAIRS Grapher application is used to extract basic statistical information from Occurrences in an 
ECCAIRS database and display it in a comprehensible graphical format.  

Graphs can be viewed on the screen, printed as a report and copied and pasted into another application 
as a bitmap.  

The underlying Graph data can be exported in a standard tab-separated text format to be imported in 
applications like, for example, MS Excel.  

Specific features of the ECCAIRS Grapher are: 

 Graphs are taken dynamically from the ECCAIRS database and thus reflect a real time situation. 

 Graphs can be exchanged, and thus re-applied and compared, between different organisations. 

 Graphs can be customised and extended to hide specific information, calculate and include 
aggregate functions (Sum, Average, Max, Min, etc.) and normalise the Query results to make 
data series comparable. 

 Created Graphs can be saved as templates to serve as a starting point for new Graphs. 

5.1.2. WHAT IS A GRAPH 

A Graph is an electronic document presenting in a graphical format extracted information from an 
ECCAIRS database. The purpose of the Graph is to present in a re-usable, easy and understandable 
format, usually statistical information out of the database. 

ECCAIRS Graphs consist of four basic elements: 

 A Query that defines the subset of Occurrences from the database which is used to create the 
Graph. 

 The X-Axis, defined by elements out of the database (Values, possibly aggregated, of a particular 
Attribute, retrieved with a series) which are plotted horizontally in the chart. 

 The Y-Axis, defining the data-series plotted in the Graph for each value of the X-Axis. Data-series 
can be of two types: database Queries resulting in Values of other Attributes or calculations on 
other data-series. 

 The optional Z-Axis, which defines categories for the X, Y plot by such adding a third dimension 
to the Graph. 
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5.1.3. GRAPH LIBRARIES 

The Graph Library is a file containing all the information needed to store and retrieve Graphs.  

Graphs can be exchanged between Users by simply copying the Graph Library in which they exist. 

Graph Libraries are only identified by their file names. It is best practice to give the Libraries significant 
names. 

Graph Libraries are stored in "Graph Library" files, which have a (*.e5g) file extension. 

Note 

All four properties of a Graph can be defined by the User based on any Attribute from the ECCAIRS 
Taxonomy. Obviously in many cases the results could have no significant meaning.  

The ECCAIRS Grapher provides the tools for producing the output, however it is the responsibility of the 
ECCAIRS Users and Administrators to define useful Graphs and take care of data quality in the 
database. 

5.1.4. USING THE GRAPHER 

The minimum steps required to create and draw a Graph are: 

 Start the Grapher (see page 19). 

 Create a Graph Library (or open an existing one) (see page 125). 

 Create a New Graph (see page 126). 

 Set the Database Query which defines the subset of data from the database which is used to 
create the Graph (see page 138). 

 Define the X and Y Axes of the Graph. You may optionally define a Z Axis (see page 139) 

 Draw the Graph (see page 140). 

You can then explore the Grapher through its functions. 

Working with Graph Libraries 

 Working with the "Graph Library" window you can: 

 Create a new Library (see page 125). 

 Open an existing Library (see page 125). 

 Change Graph Names and Icons (see page 132). 

 Cut, Copy and Paste Graphs (see page 132). 

 Import and Export Libraries (see page 128). 

You can also: 

 Create a new Graph (see page 126). 

 Open an existing Graph (see page 127). 

 Display the list of the Graphs in different modes (see page 120). 
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Working with Graphs 

 The main activities you can perform with Graphs are: 

 Create a new Graph (see page 126). 

 Open an existing Graph (see page 127). 

 Delete a Graph (see page 127). 

 Change Graph Names and Icons (see page 132). 

 Cut, Copy and Paste Graphs (see page 132). 

 Save Graphs and create Graph templates (see page 134). 

 Copy a Graph into the clipboard for pasting in external applications (see page 134). 

 Print Graphs and choose a Printer (see page 135). 

 Draw-Execute a Graph or All Graphs in a Library (see page 140 and 128). 

 Set/Enable a Global Filter on Occurrence Data for all Graphs and enable/disable it for single 
Graphs (see page 129). 

 Set and Edit the Query to extract Occurrence data for the Graph (see page 138). 

 Set the Graph Axes (see page 139). 

 Set other Graph properties (see page 136). 

 Zoom and pan the Graph (see page 138). 

 Set Label options. (see page 141). 

 

Windows Layout, Menus and Toolbars 

You may also explore the Grapher through its layout, menus and toolbars: 

 The Grapher Main window (see page 116). 

 The Toolbar (see page 117). 

 File menu (see page 124). 

 Edit menu (see page 131). 

 Graph menu (see page 133). 

 Options menu (see page 141). 

 Window menu (see page 142). 

 Help Menu (see page 146). 

 The "Graph Library" window (see page 120). 

 The "Graph" window (see page 122). 

 The Data Grid (see page 148). 
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5.2. MAIN WINDOW AND MENUS 

 

The ECCAIRS Grapher Main window is made up of a large open area and 3 bars: 

 Menu bar - at the top. Provides menus to access the all the Grapher tasks. 

 Toolbar - provides shortcuts to the most used menu items related to the ECCAIRS Grapher 
Library. 

 Workspace - the central area where the current Graph Library and its opened Graphs are 
displayed. 

 Status bar - placed at the bottom. Displays general information. 
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5.2.1. MENU BAR 

The ECCAIRS Grapher Main window has six main menus accessible from the Menu bar. 

 

 File menu (see page 124). 

 Edit menu (see page 131). 

 Graph menu (see page 133). 

 Options menu (see page 141). 

 Window menu (see page 142). 

 Help menu (see page 146). 

5.2.2. TOOLBAR 

The Toolbar offers a quick visual access to a set of commonly used functions in ECCAIRS Grapher. 

 

All the functions provided by the Toolbar con be performed by some of the items in the "File", "Edit", 
"Graph" and "Help" menus. 

Stopping the mouse pointer (no clicking !) over the Toolbar icon-buttons causes the display of a Tooltip, 
i.e. a brief description of the actions-functions associated. 

 

5.2.3. STATUS BAR 

 

The Status bar displays, from left to right: 

 the current User. 

 the current Organisation. 

 the current Repository name. 

 the connection status to the database. 

 the current time and date. 
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5.2.4. GRAPHER WORKSPACE 

The ECCAIRS Grapher Workspace is the Multiple Document Interface (MDI) area in the ECCAIRS 
Grapher application. This means that you can have several windows open at the same time. 

 

However you can have one, and only one, "Graph Library" window which lists all the Graphs within the 
currently open "Graph Library". 
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By clicking on any of the existing Graphs or creating a new Graph you open the corresponding "Graph" 
window. You can open any number of "Graph" windows. 

 

Each window can be minimised, maximised or restored to the original size, following standard Windows 
controls on the window.  
Furthermore the windows can be tiled (horizontally or vertically), cascaded or arranged automatically 
from the various Window menu-items (see page 142). 

Note 

It is recommended to open only a limited number of Graphs (not more then 10) at the same time.  

Each Graph takes away system resources which, at the end, could result in a degraded performance. 
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5.3. GRAPH LIBRARY WINDOW 
This is the window that is displayed when you open an existing Graph Library or create a new Graph 
Library. Its panel shows the Graphs included in the currently open Graph Library. 

To Open a graph select the graph you wish to open and press the "Open" button or double click the 
icon. To create a New graph select the "New" button. 

 

The window includes: 

 "Graph Library" file name - the top title bar of the window displays the complete file-system 
path to the currently open "Graph Library" file (*.e5g). 
A "*" at the end of the path indicates that the content of the Library has been modified but not yet 
saved to the "Graph Library" file. 

 Graph List panel - you find here all the Graphs included in the Graph Library.  
Using the three top buttons on  the right you can display the Graphs as icons, list or detailed list. 
If you select the "detailed list" mode the list includes also the last modification date for each 
Graph. 



GRAPHER GRAPH LIBRARY WINDOW 
 

 

121 

 

 Right-click menu - if you select a Graph and you right-click on it, you get a right-click contextual 
menu. See next section for details. 

 Buttons right-panel - you have a few buttons: 

o Graphs list mode - to display the Graphs within the "Graph list" panel as icons, list or 
detailed list. 

o Open - to open a "Graph Library" file. Same as the "File > Open Library" menu-item (see 
page 125). 

o New - to create a new "Graph Library" file. Same as the "File > New Library" menu-item 
(see page 125). 

5.3.1. LIBRARY RIGHT-CLICK MENU 

When you right-click inside the "Graph list" panel of the "Graph Library" window you get its "Right-click" 
contextual menu. 

 

The menu-items are exactly those included in the "Edit" menu of the Grapher Main window (see page 
116). 
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5.4. GRAPH WINDOW 
The "Graph" window shows up when you open a Graph. 

 

The "Graph" window includes: 

 Toolbar - (see next section). 

 Graph - the Graph shown corresponds to the last (re)draw made with the "Graph > Execute" 
menu-item.  
If the Graph has never been drawn (executed), then its appearance is not yet meaningful. 

 Right-click menu - (see next page).  

5.4.1. GRAPH TOOLBAR 

The Toolbar that is shown in the top of the Graph window includes functions operating on the Graph 
displayed in the window itself. 

 

The functions are exactly those available in the "Graph" menu of the Grapher Main window (see page 
133). 

Stopping the mouse pointer (no clicking !) over the Toolbar icon-buttons causes the display of a Tooltip, 
i.e. a brief description of the actions-functions associated. 

 

Clicking on the Toolbar and dragging it you can detach it and move it wherever you wish, even outside 
the Grapher Main window. 
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5.4.2. GRAPH RIGHT-CLICK MENU 

The right-click contextual menu includes a few of the functions that you have in the "Graph" menu in the 
Grapher Main window and in the "Graph" window Toolbar .  
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5.5. FILE MENU 
The File menu includes functions operating on Graph Libraries, including creating, opening and deleting 
of Graphs inside them.  

 
Menu items: 

 Connect 

 New Library 

 Open Library 

 Save Library 

 Save Library As 

 Close Library 

 New Graph 

 Open Graph 

 Delete Graph 

 Execute All Graphs 

 Import 

 Export 

 Edit Global Filter / Disable Global Filter 

 Printer 

 Open Most Recently Used Library 

 Exit 
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5.5.1. FILE > CONNECT 

Selecting "File > Connect " you repeat the Repository Logon made when starting the application (see 
page 19). 

This may be useful if you need to change the Repository you are logged in. 

5.5.2. FILE > NEW LIBRARY 

To create a new Library select "File > New Library" menu-item. 

The new, empty Graph Library is displayed in the Workspace. 

Now you are ready to create a Graph (see page 126). 

5.5.3. FILE > OPEN LIBRARY 

To open a Library select the "File > Open Library" menu-item. 
Then find and select a "Graph Library" file (see page 114) in the dialog window that shows up.  

After closing the dialog window the new Graph Library is displayed in the ECCAIRS Grapher Workspace.  

5.5.4. FILE > SAVE LIBRARY 

Select the "File > Save Library" menu-item to save the currently open Library into its "Graph Library" file 
(see page 114). 

If it is the first time you save the Library then you have to specify the file as with the "File > Save Library 
As" menu-item.  

5.5.5. FILE > SAVE LIBRARY AS 

Select the "File > Save Library As" menu-item to save the currently open Library into a different "Graph 
Library" file (see page 114). 

Specify the "Graph Library" file name and the folder where to save it using the standard "Save" dialog. 

5.5.6. FILE > CLOSE LIBRARY 

Select the "File > Close Library" menu-item to close the currently open Library. 

If you made any change inside the Graph Library (deleting, editing, renaming and creating Graphs) and 
you have not saved it, when you close it a dialog window will show up and ask you to confirm all 
changes.  
If you answer "No" to this question then all changes previously initiated will not be made and the Library 
returns to the original state as it was when you opened it. 
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5.5.7. FILE > NEW GRAPH 

To create a new Graph select the "New" button on the right hand side of the Library window or select the 
"File > New Graph" menu-item in the Grapher Main window. 

You can select the type of Graph you want within the "New Graph" dialog that shows up. 

 

A preview of the Graph you have selected is shown on the right to help you make your choice.  

Using the three top buttons in the right you can display the Graphs as icons, list or detailed list. 

If you have saved Graphs as templates (see page 134) then these are presented in a similar way inside 
the "Custom" tab-panel of the "New Graph" dialog . 

Once selected the Graph type you have to assign a name to the Graph by typing it into the "Set Graph 
Name" dialog which shows up. 

The Graph is then saved and displayed in the "Graph Library" window (see page 120). 

It is possible to change the name and the Icon of a Graph later from the "Edit" menu (see page 131). 

An icon and a name is assigned to every new Graph. If you change the type of Graph, or its function, it 
might be necessary to change the name and/or icon of the Graph. 

To exit click: 

 OK - to confirm. 

 Cancel - to discard the changes. 
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5.5.8. FILE > OPEN GRAPH 

To open an existing Graph select it first the Graph in the "Graph Library" window.  

Then either: 

 Click the "Open" button - the button is on the right hand side of the "Graph Library" window., or 

 Double-click on the Graph icon, or 

 Select the "File > Open Graph" menu-item. 

The corresponding "Graph" window opens. You work inside there to set details and draw the Graph. 

Note that the Graph shown on opening the "Graph" window corresponds to the last (re)draw made with 
the "Graph > Execute" menu-item.  

If the Graph has never been drawn (executed), then its appearance is not yet meaningful. 

Though it is only possible to open one Graph Library in the Workspace, more than one of its Graphs can 
be opened at the same time. 

5.5.9.  FILE > DELETE GRAPH 

To delete a Graph, select it inside the "Graph Library" window and then select "File > Delete Graph" 
menu-item. 

A confirmation dialog window shows up. 

Select: 

 OK - to confirm the deletion. 

 Cancel - to abort the function. 
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5.5.10. FILE > EXECUTE ALL GRAPHS  

The "File > Execute all Graphs" menu-item runs an "Graph > Execute" on all the Graphs in the currently 
open Graph Library. 

An "Execute all graphs" dialog shows the progress and requires you to acknowledge the end of the job 
by clicking "Close". 

 

5.5.11. FILE > IMPORT 

To import an existing Graph Library into the currently opened one, select "File > Import" menu-item. 

Select the name and location of the Graph Library to import using the standard "Open" dialog window 
shows up. 

If the selected Library contains a Graph with the same name as the one already existing in the current 
Library then the imported Graph will have a number (between parenthesis) concatenated to its name in 
order to make it unique. 

5.5.12. FILE > EXPORT 

To export selected Graphs in a New Graph Library, select the Graphs you want to export and select 
"File > Export" menu-item. 

Set the name and location of the new Graph Library using the standard "Save" dialog window shows up. 
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5.5.13. FILE > EDIT A GLOBAL FILTER 

You can define and apply a "Global Filtering" Query that will be executed upstream to pre-select 
Occurrences fed from the database to the Grapher application. 

This will be executed upstream and independently from any other Query used within the ECCAIRS 
Grapher. 

The "Edit Global Filter" dialog that it is shown displays in its lower panel either the Query used to perform 
the filter currently active, if so, or the Query used during the last filter activation. 

 

Enable the Existing Global Filter Query 

If you just click its "OK" button you accept the existing Query. This means that you are enabling the last 
used Query as Global Filter. 

To define or edit Global Filter you can use either: 

 "Defined on the Spot" Query - you can define an ah-hoc Query by clicking on the upper "pencil-
shaped" icon-button on the top right of the dialog. 
You then use the standard "Query Editing" dialog form the "Query Builder" (see page 281) to 
define the Query performing the Global Filter. 

 Query from a Query Library - you can use any Query included in a Query Library by clicking on 
the "folder-shaped" icon-button. You then use the standard "Query Builder" window to open 
Libraries and select the Query that will perform the Global Filter (see page 259).  
You can perform any operation allowed for Query Libraries and Queries within "Query Builder" 
window, for instance create new Queries in Libraries or edit existing Queries. 
In particular you may wish to open a Query in a Library and modify it in an ad-hoc mode for the 
Global Filter. Once the Query from the Library is selected, the "Query Builder" window closes, 
and the Query is displayed in the lower panel of the "Edit Global Filter" dialog. You can always 
use the "pencil-shaped" icon-button to modify "on the spot" the Query. 

Click: 

 OK - to exit and automatically enable the Global Filter. 

 Cancel - to cancel the action. 
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5.5.14. FILE > DISABLE GLOBAL FILTER 

Once a Global Filter is defined/enabled the "File > Edit Global Filter" menu-items turns into the 
"File > Disable Global Filter". If you select this menu-item you disable the filter. 

5.5.15. FILE > PRINTER  

When you print a Graph using the "Graph > Print" menu-item (see page 135), it is printed on the default 
Windows printer. 

If you want to print on a different printer you can set the target printer for the current session by selecting 
"File > Printer" menu-item. 

 

5.5.16. FILE > OPEN MOST RECENTLY USED GRAPH LIBRARIES 

The "File" menu will list just before the "File > Exit" menu-item the last four Graph Libraries that have 
been opened in previous sessions.  
You can quickly open any of the last opened Graph Libraries by selecting its name. 

5.5.17. FILE > EXIT  

Exits the ECCAIRS Grapher application. 

If any change has been made to the currently open Graph Library and its Graphs, then you will be asked 
to save them into the Occurrence Library File or discard them. 

Click: 

 OK - to confirm all changes.  

 Cancel - cancel all changes made. The Library returns to the original state as it was when you 
opened it. 
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5.6. EDIT MENU 
The Edit menu includes functions operating on Graphs inside Graphic Libraries. 

 

Menu items: 

 Cut 

 Copy 

 Paste 

 Rename 

 Change Icon 

 

You can easily cut, copy and paste Graphs within a Graph Library. It is also possible to cut, copy and 
paste Graphs across different Graph Libraries.  
For instance you can copy them on the clipboard, open the other Library and paste them there from the 
clipboard. 
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5.6.1. EDIT > CUT 

Cuts selected Graphs.  In case of multiple Graphs use the standard "CTRL" and "SHIFT" keyboard keys 
for multiple selections. 

Then select the "Edit > Cut" menu-item. 

The Graphs are removed from the "Graph Library" and "placed on the clipboard and can be taken from 
there using the "Edit > Paste" function. 

5.6.2. EDIT > COPY 

Copies one or more Graphs. In case of multiple Graphs use the standard "CTRL" and "SHIFT" keyboard 
keys for multiple selections. 

Then select the "Edit > Copy" menu-item. 

The Graphs are now placed on the clipboard and can be taken from there using the "Edit > Paste" 
function. 

5.6.3. EDIT > PASTE 

Pastes one or more Graphs. You must have either cut or copied them before.  

Then select "Edit > Paste" menu-item. 

The Graphs are now automatically taken from the clipboard and pasted in the library, changing their 
names if needed by concatenating a number in parenthesis. 

5.6.4. EDIT > RENAME 

To change the name of a Graph, select the Graph in the Library and then the "Edit > Rename" menu-
item. You can also use the corresponding "Graph Library Right-click" menu-items. 

This may be useful if you change the type of Graph or its function. 

5.6.5. EDIT > CHANGE ICON 

To change the icon associated to a Graph, select the Graph in the Library and then "Edit > Change Icon" 
menu-item. You can also use the corresponding "Graph Library Right-click" menu-items. 

This may be useful if you change the type of Graph or its function. 
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5.7. GRAPH MENU 
The Graph menu includes functions operating on Graphs. 

 

Menu items: 

 Save Graph 

 Save Graph As 

 Save Graph As Template 

 Save to Clipboard  

 Print 

 Vertical Grid / Horizontal Grid / Legend / 3D / Rotate / Z Clustered / Font / Properties 

 Datagrid 

 Zoom 

 Scroll bar 

 Build Query 
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 Edit Query 

 Edit Axis 

 Show Query Definition 

 Use Global Filter 

 Execute 

 Toolbar 

5.7.1. GRAPH > SAVE GRAPH 

When a Graph has been created or has been modified it needs to be saved in the Library in order to 
keep the changes. 

Select the "Graph > Save Graph" menu-item to save the Graph into the current Graph Library. 

If it is the first time you save the Library then you have to specify its name as with the "Graph > Save As" 
menu-item.  

5.7.2. GRAPH > SAVE GRAPH AS 

Select the "Graph > Save Graph As" menu-item to save the Graph with a different name into the 
currently open Library. 

Specify its new name and folder location in the "Set Graph Name" dialog.  
Click: 

 OK - to confirm the save. 

 Cancel - to cancel the action. 

5.7.3. GRAPH > SAVE GRAPH AS TEMPLATE 

New Graphs can be created from any of predefined Graph templates distributed with the application.  

In addition the you can define your own custom template by opening the Graph you wish to use as 
template and selecting the "Graph > Save Graph As Template" menu-item. 

The new template is listed in the "Custom" tab-panel of the "New Graph" dialog (see page 126) so that it 
can be used as the basis for new Graphs.  

5.7.4. GRAPH > SAVE TO CLIPBOARD  

The Graph's bitmap can be copied into the clipboard and used to paste it into any Windows application 
that accepts images, for instance MS Word. 

Open a Graph from the Library, execute it if not yet done so, and size it to your preferences or to the 
requirements of the target application. Sizing is important, since the bitmap sent to the clipboard reflects 
the size of the Graph as plotted on the PC screen. 

Then select the "Graph > Save to Clipboard" menu-item. 

Remember the Graph is copied as a bitmap, which is a static snapshot of the Graph taken at the 
moment you issued the "Graph > Save to Clipboard" command. 
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5.7.5. GRAPH > PRINT  

To print a report with the Graph open it from the Library and then select "Graph > Print" menu-item. 

 

The report consists of the Graph itself complemented with the Query description resulting from the main 
Graph properties. 

Note 

Calculated Data Series are not shown in the graphs Query description as printed on the Graph report.  
If you prefer to have a dedicated layout of a Graph you might consider to copy into the clipboard the 
Graph's bitmap (see page 134). paste it into a suitable application (e.g. MS Word) and add there 
manually the explanation text . 
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5.7.6. GRAPH > PROPERTIES 

The visual properties of a Graph can be set from the "Graph" window Toolbar and/or from the items of 
the "Graph" menu of the Grapher Main window. 

There is also a "Graph Right-click" menu available when right-clicking inside the "Graph" window. 

Many of these properties can also (or only) be set by right-clicking in the Graph on the target item (axis, 
legend, title, etc.). Depending on the item selected a different pop-up menu is presented.  

Typical properties that can be changed this way are colours, fonts, titles and chart type. 

The properties you can set are: 

 Vertical Grid 

 Horizontal Grid 

 Legend 

 3D 

 Rotate 

 Z Clustered 

 Font 
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5.7.7. GRAPH > DATAGRID 

To display the Data Grid of an open Graph select "Graph > Datagrid". The data matrix is displayed below 
the Graph inside the "Graph" window. 
The Data Grid is the spreadsheet-like matrix of values which is fed by the Queries on the database made 
to draw the Graph and possibly completed by additional calculated data-series. The Data Grid has a 
direct link to the Chart visualised in the Graph. 

 

In the Data Grid, the first row and column define the labels to be used at the X-Axis and the Z-Axis or 
Legend.  
The inner cells of the matrix contain the values linked to the Y-Axis values. 

When executing a Graph, its Queries linked to the three axes retrieve data from the database and 
populate the Data Grid.  
At this point you can perform additional elaborations on the Data Grid like adding rows or columns, 
hiding and filtering data, sorting and ordering information, normalisation, etc.  
This flexibility makes it possible to prepare a number of useful standard Graphs that can be re-executed 
easily on the data and provide directly a set of safety indicators. 

You can perform all the task on the Data Grid by the Data Grid Toolbar that is displayed on top of the 
matrix (see page 148). 
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5.7.8. GRAPH > ZOOM 

By selecting this item from the menu or the Toolbar you can draw a rectangle around a certain area of 
the Graph to look in details at its contents.  
You may still move around the other part of the Graph using the scroll bars which are displayed around 
the enlarged Graph. 

To zoom out and see the whole Graph just select again the "Graph > Zoom" menu-item. 

5.7.9. GRAPH > SCROLL BAR 

If the number of values plotted on the X-Axis is high it might be useful to enable scrolling.  
This will zoom in on a subset of data, while maintaining the scaling of the Y-Axis.  
By using the scroll bar that comes up the User can move the visible part of the Graph. 

To disable the scrolling select again the "Graph > Scroll bar" menu-item. 

You can enable/disable the same zoom and scroll functions from the "Graph" window Toolbar.  

  

5.7.10. GRAPH > BUILD QUERY 

To determine which subset of the Occurrences in the database will serve as the starting point for 
populating the Graph you need to specify a Query. 

To choose an existing Query or create a new one select the "Graph > Query Build Query" menu-item 
when a Graph is opened in the "Graph" window. 
This action will start the ECCAIRS Query Builder (see page 257) application that, in the usual way, 
allows you to define the Query as restricting as needed. 

5.7.11. GRAPH > EDIT QUERY  

To restrict or modify a Query locally within the ECCAIRS Grapher environment, select "Graph > Edit 
Query" menu-item when a Graph is opened in the "Graph" window. This displays the "Query Editing" 
window used within the "Query Builder" (see page 281).  

This allows to: 

 Restrict locally a Query already opened from a Query Library, e.g. for any reason bound to the 
Graph to be created and not to the scope of the Query itself, without the need to edit or define 
new Queries using the Query Builder 

 Execute or restrict Queries associated to a specific Graph, but not stored in a Query Library 
available locally, e.g. when modifying or refreshing a Graph in a Graph Library received by 
another User. 

All subsequent actions of the ECCAIRS Grapher will only take into account the subset of the 
Occurrences resulting from the Query. 
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5.7.12. GRAPH > EDIT AXIS 

This is a key point in the creation of a Graph: you choose the Attributes to be plotted in the Graph. 

You first have to open the Graph you wish to operate on. 
Then select "Graph > Edit Axis" menu-item The system displays an "Edit Axis" dialog. 

 

To define any of the Axes click the "play" triangle-shaped button on the right of the corresponding Axis 
field. 

The "Selection Builder" window that comes up is made of 2 sections: 

 Attribute definitions - to choose the Attribute that feeds the Axis by navigating through the 
Taxonomy data definition hierarchy. 

 Function definitions - to choose a grouping scheme for the Attribute selected. The grouping 
schemes available depends on the specific Attribute chosen in the previous step. For example 
dates allow for grouping in weeks, months etc. 

For any other details refer to information on the "Selection" window within the "Query Builder" (see page 
289).  

Each Graph must have the X-Axis and Y-Axis set otherwise the Graph will be considered not valid. 

The Z-Axis is an optional property and can be left empty if not required for a specific type of Graph.  
Choose the "Define Z-Axis" option to enable the field.  

5.7.13. GRAPH > SHOW QUERY DEFINITION 

Select "Graph > Show Query Definition" menu-item to show a textual description of the overall Query 
that feeds data to the Graph. 

 

The Query Definition only shows which data-items are taken from which sub-set of the database.  

It does not describe the additional data series possibly added to the Data Grid (see page 147). 
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5.7.14. GRAPH > USE GLOBAL FILTER 

You can enable or disable the Global Filter for the Graph currently open through the "Graph > Use 
Global Filter" menu-item. 

If you select this menu-item when Global Filtering is enabled will disable it and vice versa. 

If the Global Filer is disabled for the whole Grapher application, using the "File > Edit or Disable Global 
Filter" menu-item (see page 129) then enabling it for the Graph currently open has no effect. 

    If the Global Filter is enabled for the Graph you see the icon associated with the menu-item 
displayed as a "pushed button". The same applies for the equivalent icon-button in the "Graph" 
window Toolbar. 

    Otherwise the icon is displayed as a "un-pushed button". 

5.7.15. GRAPH > EXECUTE 

When you open a Graph the "Graph" window shows the results of the latest execution.  
To draw the Graph with the actual information extracted from the Occurrence database it is necessary to 
Execute the Graph.  

Selecting the "Graph > Execute" menu-item the Query is (re)executed into the database and all the 
Global Filtering (if any) and selection functions are applied. The result is plotted in the "Graph" window. 

If you try to execute the Graph but you still have not defined at least the X and Y Axes then you get an 
error message. 

You can also execute all the Graphs at once using the "File > Execute all Graphs" menu-item (see page 
128). 

5.7.16. GRAPH > TOOLBAR - ENABLE/DISABLE THE TOOLBAR 

To show or hide the Graph window Toolbar right-click anywhere in the Graph and select the "Right-
click > Toolbar" menu-item, or even select the "Graph > Toolbar" menu-item in the Grapher Main 
window. 
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5.8. OPTIONS MENU 
The Options menu allows to set some options for the ECCAIRS Grapher application. 

 

Menu items: 

 Label Type 

 Always recalculate Y-Axis  

 

 

5.8.1. OPTIONS > LABEL TYPE 

For those Attributes where a multilevel value structure exists it is sometimes difficult to understand 
exactly the meaning of the value at the lowest level since it is normally derived from the hierarchical path 
leading to the value.  

In these cases it is necessary, even if it results in long strings, to print in the graph the long description of 
the Attribute, not only the lowest level. 

To force Graphs to use long descriptions or short ones select "Options > Label Type > Extended" menu-
item or "Options > Label Type > Compact". 

 

 

5.8.2. OPTIONS > ALWAYS RECALCULATE Y-AXIS  

You select this option if you wish the Y-Axis to auto-scale to fit the content of the Graph while modifying 
it, for instance when adding or hiding columns, rows, etc. 
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5.9. WINDOW MENU 
The Windows menu specifies how to display the sub-windows that you may open within the workspace 
inside the Main window. 

 

Menu items: 

 Cascade the sub-windows 

 Tile Vertically the sub-windows 

 Tile Horizontally the sub-windows 

 List of Currently Open document windows 
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5.9.1. WINDOW > TILE HORIZONTAL 

When multiple sub-windows are displayed in the Main window workspace you can display them tiled in 
Horizontal. 
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5.9.2. WINDOW > TILE VERTICAL 

When multiple sub-windows are displayed in the Main window workspace you can display them tiled in 
vertical. 
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5.9.3. WINDOW > CASCADE 

When multiple sub-windows are displayed in the Main window workspace you can display them in 
cascade. 

 

 

5.9.4. WINDOW > LIST OF CURRENTLY OPEN DOCUMENT WINDOWS 

If you click on one of the windows listed the corresponding window is brought to the foreground and 
become the active window (i.e. mouse and keyboard input will be directed to that window). 
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5.10. HELP MENU 

 
Menu items: 

 Contents 

 Taxonomy Browser  

 About  

5.10.1. HELP > CONTENTS  
Displays online help for the application you are running. 
You can also invoke the online help at any time by pressing the "CTRL" and "F1" keyboard keys at the 
same time. 

5.10.2. HELP > TAXONOMY BROWSER  
Starts the Taxonomy Browser application, which allows you to examine in a separate window all details 
of the Taxonomy in use. This can be useful while editing Queries, selecting and editing Attributes. 

5.10.3. HELP > ABOUT 
Opens a dialog displaying details on the version of the application you are running. 
Click the "OK" button to acknowledge and close the dialog. 
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5.11. DATA GRID WITHIN A GRAPH WINDOW 
The Data Grid is the spreadsheet-like matrix of values which is fed by the Queries on the database made 
to draw the Graph and possibly completed by additional calculated data-series. The Data Grid has a 
direct link to the Chart visualised in the Graph. 

 

In the Data Grid, the first row and column define the labels to be used at the X-Axis and the Z-Axis or 
Legend.  
The inner cells of the matrix contain the values linked to the Y-Axis values. 

When executing a Graph, its Queries linked to the three axes retrieve data from the database and 
populate the Data Grid.  
At this point you can perform additional elaborations on the Data Grid like adding rows or columns, 
hiding and filtering data, sorting and ordering information, normalisation, etc.  
This flexibility makes it possible to prepare a number of useful standard Graphs that can be re-executed 
easily on the data and provide directly a set of safety indicators. 

You can perform all the task on the Data Grid by the Data Grid Toolbar that is displayed on top of the 
matrix. 
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5.12. DATA GRID TOOLBAR AND FUNCTIONS 
The Data Grid offers functions to elaborate Occurrence data retrieved from the database. These 
functions are available via the Data Grid's Toolbar or its Right-click menu.  

 

Stop the mouse over a button to show a tooltip describing its function. 

 

Toolbar items/functions: 

 Adding Row and Columns 

 Hide Rows and Columns 

 Filter 

 Sorting and Ordering 

 Command List 

 Load and Save Data 

 Decimals 

 Normalization 

 Show and Hide Data Grid 

 

5.12.1. ADD ROW OR COLUMN 

In addition to the data retrieved from the database by setting properties for Query, X-Axis, Y-Axis and Z-
Axis it is possible to add rows and columns to the Data Grid, whose content is determined by simple 
calculations. 

To add a row or a column in the grid use either: 

 Data Grid Toolbar - the "Append Row" and "Append Column" icon-buttons on the Data Grid 
Toolbar, which adds a row/column at the last position of the grid. 

 Right-click menu - select the row/column after which you wish to add the row/column and select 
the suitable Right-click menu-item. This way you can exactly determine where the new 
row/column will be added. 

After you have added an "Insert Row/Column" dialog shows up to ask you what function should be used 
to populate the row/column added. The items displayed in the dialog varies according to the function you 
choose in its left function list.  
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The functions that can be applied are: 

 Sum - Adds up the selected rows or columns (if available from the query) or any row or column in 
the Data Grid independent of what comes out of the query 

 Group - Adds up the selected rows or columns (if available from the query) and hides these rows 
automatically in the graph. 

 Average - Calculates the average of selected (if available from the query) or any cell of the same 
column or row.  
You have to specify also if empty cells should be interpreted as ZERO (for example the average 
count of Occurrences) or NULL (for example the average age of a pilot). 

 Moving Average - Calculates a moving average over the data-series indicated.  
The moving Average calculates the average over a column and its 'n' preceding columns.  
The value of 'n' can be set in the dialog window 

 Min - Calculates the minimum of all the cells in the same row or column.  
You have to specify also if empty cells should be interpreted as ZERO or NULL. 

 Max - Calculates the maximum of all the cells in the same row or column.  
You have to specify also if empty cells should be interpreted as ZERO or NULL. 

 Threshold - Inserts a new row or column with a constant value for all the cells.  
The constant value can be set in the dialog window. 

 None - Inserts an empty row or column. You can type in values for each cell. 

5.12.2. DELETE ROW OR COLUMN 

Calculated rows and columns can be deleted from the Grid by selecting them and use either the "Delete 
Row"/"Delete Column" icon-buttons on the Data Grid Toolbar or the corresponding "Right-click" menu-
items on the header of the selection.  
Rows and columns resulting directly from the Query cannot be deleted from the grid. However they can 
be made invisible. 
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5.12.3. EDIT ROW OR COLUMN 

To edit rows or columns in the Data Grid select the row or column use either the "Edit" icon-button on the 
Data Grid Toolbar or the corresponding "Right-click" menu-item with the mouse on the header of the 
selection. 

5.12.4. SHOW/HIDE ROWS AND COLUMNS  

Any row or column in the Data Grid can be made invisible in the Graph.  

This is done by selecting the row or column and click the "Data Grid Toolbar > Hide/Unhide" icon-button 
or right-click with the mouse on the header of the selection and use the corresponding "Data Grid Right-
click" menu-item. 

An invisible row or column can be recognised in the Data Grid since it has a grey colour. 

You may use the "Data Grid Right-click > Filter" function instead to show/hide rows and columns based 
on the result of a comparison function on the Data Grid.  

5.12.5. SHOW ROWS AND COLUMNS UPON CONDITIONS 

It is possible to hide automatically information by applying a filter on the Data Grid. 

To filter a Data Grid click the "Data Grid Toolbar > Filter" icon-button.  
A "Filter" dialog shows up where you can set the parameters for the filter: 

 

Dialog items: 

 Show only those - choose to filter out rows or columns. 

 Where Column (or Row) - specify the condition required to show the column/row.  
You may show only columns where the corresponding row satisfies a comparison function with a 
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reference value or row. 
Vice versa you may show only rows where the corresponding column satisfies a comparison 
function with a reference value or column. 

 Operator - define the operator for the comparison described above. 

 Value / Row / Column - specify the reference value for the comparison. You set a fixed value or 
the values assumed in a specific row/column. 

 Top - you can choose to hide all columns or rows but the top 'n' ones.  

Filters can be applied and based on any type of row and column: those generated directly by the Query 
as well as those resulting from adding manually an item. 

The concept of filtering is very powerful but needs some exercises to get used to.  
For optimal results it is recommended to create some examples and analyse the results. 

  

5.12.6. SORTING AND ORDERING 

The Data Grid is filled exactly following the output of the database Query.  
It is likely that the order in which the columns or rows are presented needs to be adapted to obtain a 
clearer result.  
To facilitate this, it is possible to reorder and sort the Grid based on row and column headers as well as 
on the cell contents.  
To differentiate between the two sorting approaches the order of columns and rows must be based on 
the contents of the Grid. 

Ordering 

Ordering is the process where the contents of the grid is not taken into account, but instead the meaning 
of the columns and rows, normally expressed by their headers and labels, determine the position in the 
grid.  
This can be done by clicking on the "Data Grid Toolbar > Reorder Labels" or "Data Grid 
Toolbar > Reorder Headers". 

In both cases a dialog comes up that allows for alphanumeric sorting as well as manually changing the 
order. 

Sorting 

Sorting can be done by clicking on the "Data Grid Toolbar > Sort Ascending" or "Data Grid 
Toolbar > Sort Descending". 

The Data Grid and the Graph immediately shows the result of the sorting. 

In all cases the relation between the row-labels, column headers and the data is never changed since 
this would make the data inconsistent. 

5.12.7. COMMAND LIST 

All the actions you perform on a Graph (for example adding rows and columns, changing the visibility, 
editing cells, sorting the Grid, etc) are maintained in a list of commands that will be applied every time 
you execute the Graph (see page 140).  
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It is possible to view and modify the Command List by clicking on the "Data Grid Toolbar > Command 
List" icon-button. 

 

The dialog window that shows lists all the commands, one per row. 
You can remove individual commands, or even all, that are have been attached to the core Query of the 
Graph to obtain the current Data Grid content. You can use the standard Windows multi-selection to 
select commands. 
When the dialog window is closed you will be asked if the changes are to be applied immediately on the 
Graph. 

The Command List can grow rather rapidly and might contain superfluous commands (i.e. hide and show 
the same row).  
When the final result of the Graph is satisfactory it is wise to evaluate if there are unused commands 
present in the Command List of the Graph and remove them from the list. 
Sometimes it may be wiser to recreate the Graph by hand, avoiding unnecessary actions. This will 
increase performance and reproducibility of the Graph.  

5.12.8. LOAD AND SAVE GRID DATA 

The data contained in the Data Grid can be saved in a TAB delimited text file (*.txt) so that it can be used 
in other environments that offer additional functionality (for example, MS Excel). 

To save data, click the "Data Grid Toolbar > Save" icon-button. 

There are four different text output formats: 

 Text Files - all data in the grid. 

 Transposed Text Files - all data in the grid in a transposed format. 

 Text Files (Visible items only) - only the visible data in the grid. 

 Transposed Text Files (Visible items only) - only the visible data in the grid in a transposed 
format. 

For your convenience it is also possible to load data back in the Data Grid from a TAB delimited text file. 

To load data from a text file, click the "Data Grid Toolbar > Load" icon-button. 

When loading data, the Graph will have no link with the database. It could be used for simple 
visualisation purposes. 
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5.12.9. DECIMALS 

In many cases the Data Grid and the Graph should present the numbers with a specific number of 
decimals.  

This preference can be set from the Data Grid Toolbar by using the "Decimals" control. 

 

5.12.10. NORMALISATION 

Normalisation is the process where the sum of all values in a series is set to 1. Each value is then 
recalculated appropriately.  
In ECCAIRS Grapher normalisation is implemented by expressing each value as percentage of the total. 

Three types of normalisation can be applied on the Data Grid: 

 Normalisation on the X-Axis - whereby the sum of all values for a particular value of the X-Axis 
is set to 100%. 

 Normalisation on the Z-Axis - whereby the sum of all values for a particular value of the Z-Axis 
is set to 100%. 

 Normalisation by all values - whereby the sum of all values in the grid is set to 100%. 

Usage of normalisation functions can be somewhat confusing in particular when applied together with 
filters and calculated columns or rows.  
Try to apply normalisation as the last command in a Graph command list. 
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6. DATA MANAGER 

6.1. WHAT IS THE DATA MANAGER 
The ECCAIRS Data Manager application is a collection of tools for managing Occurrences in ECCAIRS 
Repositories. 

They use the same basic building blocks of the ECCAIRS core applications: e.g. the Query Builder, 
logons, User interface elements, etc. 

6.1.1. EXPORTER 

The Exporter tool exports subsets the Occurrences in the database in a variety of different formats, 
respecting the security profiles for the current User as defined in the Repository. 

Some examples of possible usage are: 

  Creation of proprietary customised reports. 

 Analysis of sub-sets of information in 3rd party environments. 

 Free text searches on all Attribute values. 

 Passing information to Users of non compatible systems. 

 Creating de-identified Occurrence files. 

6.1.2. DATA EXCHANGER 

This tool includes four separate functionalities: Load from Occurrence file, Save to Occurrence file, Copy 
Between Repositories, Purge Repository. 

6.1.2.1. LOAD FROM OCCURRENCE FILE 

This function loads ECCAIRS Occurrence files in a Repository database. Occurrence files can be used 
to store, exchange and backup occurrences in an Repository.  

Usage of this function is mandatory when you migrate from one version of ECCAIRS to a newer major 
version of ECCAIRS and the data format and/or Taxonomy has been changed. In this case passing your 
data via Occurrence files guarantees you that all appropriate conversions and adaptations are 
performed. You will then restore the Occurrences in the new version via the "Data Exchange > Load 
from Occurrence file" function. 

6.1.2.2. SAVE TO OCCURRENCE FILE 

This function saves Occurrence files into a Repository database. It is important to know that this function 
always respects the security settings of the repository's security profile, so that confidentiality, if applied, 
is maintained. 

Though it is possible to save and load Occurrences from within the Browser application, in many cases 
using the "Data Exchange > Save to Occurrence file" and "Data Exchange > Load from Occurrence file" 
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is more efficient, more clear, less likely to generate problems and better documented in the form of 
extensive logging options. 

Typical usage of the "Data Exchange > Save to Occurrence file" and "Data Exchange > Load from 
Occurrence file" functions are for saving/restoring the contents of your database to/from (a series of) 
Occurrence files. It is recommended to perform backups regularly using the related "Data 
Exchange > Load from Occurrence file" function, even if your database administrator makes back-ups of 
your databases in the specific database management environment.  

6.1.2.3. COPY BETWEEN REPOSITORIES 

You can use this tool to transfer Occurrence data from one Repository database into another one 
passing through a set of ECCAIRS Occurrence files.  

You could use this tool as an extra safety measure in addition to, but not substituting, the regular 
database (RDBMS) backups.  

It can be used on an ad-hoc basis to make a copy or it can be used when you migrate between two 
ECCAIRS or database (RDBMS) versions. 

6.1.2.4. PURGE REPOSITORY 

This tool can erase all the Occurrences in a Repository. The utility offers you the possibility to backup the 
Occurrences before the removal. 

6.1.3. BATCHELOR 

The Batchelor is a tool which is used to make Batch type of modifications to a set of Occurrences stored 
in a Repository database or in an Occurrence file.  

It can be used to make simple straightforward changes but for advanced Users possibilities exist to 
make conditional changes and apply scripts on the data. 

This tool works directly on the physical structure of an Occurrence, thus modifying the content of the 
Repository database. 

The Batchelor is therefore aimed at advanced Users of the ECCAIRS Reporting System. 

6.1.4. RESTORER 

This tool let you restore identification data on de-identified Occurrence files. 

This tool is made available in the Data Manager only if the Repository you log on allows this function for 
your User/Role.  

6.1.5. DATA QUALITY 

The Data Quality tool performs a quality check on Occurrences either from file or from a Query in the 
database. The quality is evaluated through a set of Rules stored in Rule Libraries. 
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6.2. HOW TO USE THE DATA MANAGER 

6.2.1. EXPLORE THE DATA MANAGER BY ITS FUNCTIONS 

You can then explore the Data Manager through its functions: 

 Starting the Data Manager (see page 19). 

 Data Manager Layout (see page 158). 

 Exporter tool - to export Occurrences in a number of formats (see page 165). 

 Data Exchanger tool - to exchange Occurrences between Occurrence files and Occurrences in 
Repository databases, between two Repository databases and to purge Occurrences in 
Repository databases (see page 189). 

 Batchelor tool - to modify Occurrences in batch mode (i.e. not interactively) according to some 
conditions (see page 211). 

 Restorer tool - to restore identification data in de-identified Occurrences (see page 229). 

 Data Quality tool - to perform data quality checks on Occurrences (see page 235). 

 

6.2.2. EXPLORE THE DATA MANAGER BY WINDOWS AND MENUS 

You may also explore the Data Manager through its layout, menus and toolbars: 

 The Data Manager Main window (see page 158). 

 File menu (see page 161). 

 Help Menu (see page 164). 

 Exporter: Functions and Tab-Panels (see page 166). 

 Data Exchanger tool (see page 189): 

o Data Exchanger > Load: Tab-Panels (see page 191). 

o Data Exchanger > Save: Tab-Panels(see page 197). 

o Data Exchanger > Copy: Tab-Panels (see page 202). 

o Data Exchanger > Purge: Tab-Panels (see page 207). 

 Batchelor: Tab-Panels (see page 211). 

 Restorer: Tab-Panels (see page 229). 

 Data Quality: Tab-Panels (see page 235). 

6.2.3. DATA MANAGER CONFIGURATION FILES 

The application uses "Data Manager Configuration" files to store and recover configurations set for any 
of its tools.. These files have a (*.e5e) file extension. 
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6.3. DATA MANAGER WINDOW AND MENUS 

 

The ECCAIRS Data Manager Main window is made up of a three-panel work area and two bars: 

 Menu bar - at the top. Provides menus to manage the Data Manager configurations and help. 

 Data Manager panels - the central work area divided into three panels. 

 Status bar - placed at the bottom. Displays general information. 

6.3.1. MENU BAR 

The ECCAIRS Data Manager Main window has two menus accessible from the Menu bar: 

 

 File menu (see page 161). 

 Help menu (see page 164). 
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6.3.2. DATA MANAGER PANELS 

Tool Functions Selector panel 

The "Tool Functions Selector" panel let you select a specific function inside the Tool selected in the "Tool 
selector" panel (see next section). 
The Functions varies according to the specific Tool selected in the "Tool Selector" panel just below. 

 

Tools Selector panel 

The "Tools Selector" panel let you select one of the four Tools included in the Data Manager.  
Once you have selected the Tool you then have to select the Tool Function you wish to use. 

 

The four Tools included in the Data Manager are: 

 Exporter - to export Occurrences in the database in a variety of different formats (see page 165). 

 Data Exchanger - a multi-function tool to save/load Occurrences to/from Occurrences files, copy 
Occurrences across Repositories and purge Occurrences from a Repository (see page 189). 

 Batchelor - to write command-sets to batch process Occurrences (see page 211). 

 Restorer - to restore identification data to de-identified Occurrence files (see page 229). 
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Tool Configuration panel 

The "Tool Configuration" panel is the place where you have to configure the Tool Function parameters, 
including source, destination and logging options.  

 

Each configuration aspect is included in one of the four tab-selected panes whose content depends on 
the specific Tool Function selected 

6.3.3. STATUS BAR 

 

The Status bar displays, from left to right: 

 the current User. 

 the current Organisation. 

 the current Repository name. 

 the connection status to the database. 

 the current time and date. 
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6.4. FILE MENU 
The File menu includes functions to manage "Data Manager Configuration" files (see page 157) and to 
exit the application. 

 
Menu items: 

 New 

 Open 

 Save 

 Save As 

 Save with Credentials 

 Open Most Recently Used Data Manager Configuration files 

 Exit 
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6.4.1. FILE > NEW 

To blank any configuration made within the Data Manager tools without exiting the Data Manager itself, 
select "File > New" menu-item. 

If any setting was made to any of the configuration panel of any tool and function, then a dialog shows us 
to ask you to save them into an "ECCAIRS Data Manager Configuration" file (see page 157). 

 

Click: 

 OK - to save the current configuration. 
The system let you specify a filename and folder with the standard "Save" dialog that shows up.  

 Cancel - to discard the current configuration. 

6.4.2. FILE > OPEN 

To open a "Data Manager Configuration" file select the "File > Open" menu-item. 
Find and select the file in the standard "Open" dialog that shows up. 

Once the file has been loaded you will find into the tools configuration panels all the settings previously 
saved.  

6.4.3. FILE > SAVE  

Select the "File > Save" menu-item to save the current configuration of the tools into a "Data Manager 
Configuration" file (see page 157). 

If it is the first time you save the configuration then you have to specify the file as with the "File > Save 
As" menu-item.  

6.4.4. FILE > SAVE AS 

Select the "File > Save As" menu-item to save the currently configuration of the tools into a different 
"Data Manager Configuration" file (see page 157). 

Specify the file name and the folder where to save it with the standard "Save" dialog that shows up. 
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6.4.5. FILE > SAVE WITH CREDENTIALS 

Select the "File > Save with Credentials" menu-item to save both the current configuration of the tools 
and the Repository access credentials used to execute them into the "Data Manager Configuration" file 
(see page 157) 

6.4.6. FILE > OPEN THE MOST RECENTLY USED CONFIGURATION FILES 

You can quickly open any of the last opened "Data Manager Configuration" files by selecting its name 
among the menu-items listed just before the "File > Exit" menu-item. 

6.4.7. FILE > EXIT 

Exits the ECCAIRS Data Manager application. 

If any change has been made to any of the configuration panel of any tool and function, then a dialog 
shows us to ask you to save them into an ECCAIRS Data Manager Configuration file (see page 157). 

 

Click: 

 OK - to save the current configuration. Specify a Data Manager Configuration filename and folder 
with the standard "Save" dialog that shows up.  

 Cancel - to exit the Data Manager without saving the configuration. 
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6.5. HELP MENU 

 

The Help menu has two items: 

 Contents 

 About 

 

 

6.5.1. HELP > CONTENTS  

Displays online help for the application you are running. 
You can also invoke the online help at any time by pressing the "CTRL" and "F1" keyboard keys at the 
same time. 

6.5.2. HELP > ABOUT 

Opens a dialog displaying details on the version of the application you are running. 
Click on the "OK" button to acknowledge and close the dialog. 
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6.6. EXPORTER TOOL 
The Exporter tool exports subsets the Occurrences in the database in a variety of different formats, 
respecting the security profiles for the current User as defined in the Repository. 

Some examples of possible usage are: 

 Creation of proprietary customised reports. 

 Analysis of sub-sets of information in 3rd party environments. 

 Free text searches on all Attribute values. 

 Passing information to Users of non compatible systems. 

 Creating de-identified Occurrence files. 

To get more information follow these links: 

 Using the Exporter (see page 165). 

 Exporter Functions and Tab-Panels (see page 166). 

6.6.1. USING EXPORTER 

The Exporter tool provides different options for exporting data. You select them trough the "Tool 
Function" selector (see page 158). 

If you wish to export only some of the Attributes of the Occurrences extracted by a Query, then you have 
the following output options: 

 Exporting selected Attributes from a database into text file(s) (see page 174). 

 Exporting selected Attributes from a database into an Access Database (see page 176). 

 Exporting selected Attributes from a database into an Excel Workbook (see page 178). 

If you wish to export all the Attributes of the Occurrences extracted by a Query, then you have the 
following options: 

 Exporting Occurrences from a database or Occurrence file into a template (see page 185). 

 Exporting Occurrences from a database or Occurrence file into a text file as a tree. (see page 
187). 

Finally, you may wish to export a list of Attributes for each Occurrence using a template (see page 182). 

The first three export-options always provide a pair of tables as output. These tables can be in the form 
of text files, Access tables and in the form of Excel spreadsheets. The logical contents is always the 
same: Attributes listed in Flat Format or/and Expanded Format (see page 180). 

When exporting all Attributes, or the list of Attributes, the source Occurrences you want to export can be 
provided either by a Query on the database or by an Occurrence file. 

The general operating sequence to run the Exporter is: 

 Select the desired export format in the Tool Functions upper left panel (see page 159). 

 Select the destination file name and folder in the "Destination" tab-panel (see page 171). 

 Select the source Occurrences to be exported, using the "Source" tab-panel (see page 168). 

 Set the "Configuration" tab-panel: 
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o "Text File", "Excel Worksheet" and "Access Database" export functions - specify the 
Attributes to be exported (see page 170).  

o "List from Template" export function - specify the template file and the selections to get 
the Attribute values from the database (see page 183). 

o "Occurrence Report from Template" export function - specify the template file (see page 
186). 

o "Occurrence Tree Structure" export function - specify the type of tree to use (Taxonomy or 
any of the Views) and the value description type (short, detailed, etc) (see page 188). 

 Specify the logging options in the "Logging Activity" tab-panel (see page 173). 

 Click the "Execute" button. 

 According to the specific export-format choice, other dialog boxes may be displayed for additional 
choices. 

 The export output file is generated. 

6.6.2. EXPORTER: FUNCTIONS AND TAB-PANELS 

The Exporter tool includes six functions and a set of four configuration tab-panels: 

 

 Exporter functions/options - you can select them in the upper left function panel:  

o Text Files - to generate a pair of text files containing a number of specified Attributes of 
the selected Occurrences. 

o Access Database - to generate an Access database file containing a number of specified 
Attributes of the selected Occurrences. 
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o Excel Worksheet - to generate an Excel worksheet file containing a number of specified 
Attributes of the selected Occurrences. 

o List from Template - to generate a file where a few of the Attributes, for each 
Occurrence, are placed according to a formatted template defined by the User.  

o Occurrence Report from Template - to generate a file where the Occurrence Attributes 
are placed according to a formatted template defined by the User.  

o Occurrence Tree Structure - to generate a file where the Occurrence Attributes are 
placed in a hierarchical tree structure of one of the Views available or the base 
Taxonomy. 

 Configuration panel - you can select and edit parameters in each panel by clicking on the 
corresponding upper tab: 

o Source - to specify the origin of the Occurrences to be exported. 

o Configuration - the parameters to be set for the specific function selected: 

 Text Files 

 Access Database 

 Excel Worksheet 

 List from Template 

 Occurrence Report from Template 

 Occurrence Tree Structure 

o Destination - to set the export destination file. 

o Logging Activity - to set up logging and its options. 

 Execute button - you click this button to execute the export function specified. 
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6.6.3. SOURCE TAB-PANEL 

The "Source" tab-panel let you specify the Occurrences to be exported and, for Text, Excel and Access 
export function, also which Attributes to export. 

The source Occurrences are specified: 

 by a Query in the database - for the "Text File", "Excel Worksheet" and "Access Database" 
export functions. 

 

 by an Occurrence file or by a Query in the database - for the "List from Template", 
"Occurrence Report from Template", "Occurrence Tree Structure" export functions. 
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6.6.3.1. QUERY SECTION 

In the Query panel you specify the Query that will extract the specified Attributes of the Occurrences to 
be exported. 

Panel items: 

 Credentials - if you click the "connection" icon-button the system shows up the ECCAIRS 
"Login" dialog where you can logon to the Repository and with the User credentials you wish. 

 Query - the field shows either the name of the Query currently in use, if taken from a Query 
Library, of the generic text "(Query)" if the Query has been defined standalone on the spot (see 
below). 
The icon-buttons on the right let you:  

o  Edit the Query - if you click the "pencil" icon-button the system displays, according 
to the export function selected, either the "Query Editing" window (see page 281) or the 
"Query and Selections Editing" window (see page 281) that allows to: 

 Edit locally a Query already opened from a Query Library without the need to edit 
or define Queries using the Query Builder 

 Create and edit standalone Queries, i.e. not stored in a Query Library. 

o  Open a Query Library - if you click the "open" icon-button the system starts the 
ECCAIRS Query Builder application that, in the usual way, allows you access and define 
Query Libraries and Queries (see page 257).  

o  Preview the Query result - if you click the "glasses" icon-button the system shows 
a "Preview" dialog. 

 

The dialog displays the total count of Occurrences matching the Query and the list of 
these Occurrences, each with some Attributes displayed (as in the "Occurrence List" 
panel in the Browser). The Attributes displayed are specified in the Repository and 
Role/User that you have specified in the "Credentials" field.  
Click on the "Close" button to exit the "Preview" dialog.  

 Explanation - the explanation of the Query currently in use. 
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Select the Attributes to Export (where applicable) 

If the "Text File", "Excel Worksheet" and "Access Database" export functions you have to specify the 
Attributes to export using the "Selection" tab in the "Query Editing" window and the "Selection" window to 
select them (see page 289). 

6.6.3.2. OCCURRENCE FILE SECTION (WHERE APPLICABLE) 

Some functions also allow to export Occurrences taken from Occurrence files.  
If you select this option you have to specify in the "Occurrence File" lower sub-panel: 

 File Name - click the "..." button at the right of this field to locate and specify the source 
Occurrence file name using the standard "Open" dialog. 

 preview the Query result - if you click the "glasses" icon-button at the right, the system shows a 
"Preview" dialog. 

 

The dialog displays the total count of Occurrences matching the Query and the list of these 
Occurrences, each with some Attributes displayed (as in the "Occurrence List" panel in the 
Browser). The Attributes displayed are specified in the Repository and Role/User that you have 
specified in the "Credentials" field.  
Click the "Close" button to exit the "Preview" dialog.  
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6.6.4. DESTINATION TAB-PANEL 

The "Destination" tab-panel let you specify the export destination file. In case of "Access Database" and 
"Excel Worksheet" export functions both the "Flat Attribute" format and the "Expanded Attribute" formats 
are included in the same Access or Excel file. 

 

Panel items: 

 File Name - click the "..." button at the right of this field to specify the destination file name  and 
location using the standard "Save" dialog. 
The file extension automatically appended to the file name depends on the Tool Function 
selected for the export: it can be text (*.txt), rich text (*.rtf), html (*.htm), access (*.mdb), excel 
worksheet (*.xls). 

 Append Date/Time stamp to file name - choose this option to append a date and time stamp to 
the file name. For instance, if you choose "my export file" as file name with an "Excel Worksheet" 
export function, then the actual export file name after the execution on Sept. 18th 2011 at 13:50 
and 23 sec would be: 
my export file_18-09-2010 13-50-23.xls 
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Export Text Files: two files to specify 

In case of the "Text Files" export function the destination panel let you specify two different files: one for 
the "Flat Attribute" format and one for the "Expanded Attribute" format (see page 180).  
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6.6.5. LOGGING ACTIVITY TAB-PANEL 

The "Logging Activity" tab-panel let you enable/disable logging and specify its options.  

 

You can create a log file every time you execute a Data Manager tool. You cannot append logging to an 
existing log file. The file will be overwritten on execution. 
This means that a log file contains log messages for a single Data Manager tool execution. 

Panel items: 

 Log Activity - choose this option to enable logging. 

 Logging Destination section: 

o File Name - click the "..." button at the right of this field to specify the log file name and 
location using the standard "Save" dialog. 

 Logging Options section: 

o All messages / User feedback / Errors only - specify whether the log file includes all 
messages or only User feedback and error messages.  

o Append Date/Time stamp to LOG file name - select it to append a date and time stamp 
to the log file name. For instance, if you choose "mylogfile" as file name, then the 
actual log file name after the execution on Sept. 18th 2011 at 13:50 and 23 sec would be: 
mylogfile_18-09-2010 13-50-23.log  

o Automatically show log at the end of executions - select it to have Data Manager 
open the log file at the end of the execution. 
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6.6.6. EXPORT SELECTED ATTRIBUTES AS TEXT FILES 

The "Text Files" export function generates a text file containing, for all the Occurrences selected as input 
in the "Source" tab-panel, the values of a set of Attributes that you specify. 

You can choose to generate any or both type of text files: 

 Flat Attribute Format - one line per Occurrence with the set of Attributes specified.  
In some conditions there may be more than one line per Occurrence (see page 180). 

 Expanded Attribute Format - one line per specified Attribute, containing extended information 
on the Attribute.  
In some conditions there may be more than one line per Attribute (see page 180). 

You choose the type of text files (Flat, Expanded or both) in the "Destination" tab-panel (see page 172).  

You choose the Attributes to export by specifying Attribute selections in the "Source" tab-panel (see 
page 168). 

6.6.6.1. EXPORT OCCURRENCES 

To export Occurrences as Text Files: 

 Specify the Occurrences to export and which of their Attributes (see page 168). 

 Specify the export destination files (see page 171). 

 Set the configuration in the "Configuration" tab-panel (see page 175). 

 Execute the tool by clicking the "Execute" button. The tool displays a progress bar on the left of 
the button. 

 Once the export has been performed the system shows a dialog to ask you whether you want to 
open the file exported. 

 Examine the log file, if needed. 
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6.6.6.2. CONFIGURATION TAB-PANEL 

The "Configuration" tab-panel let you specify the exporting options. 

 

Panel items: 

 Choose the delimiter to separate your fields - you can specify the separator to put between 
Attribute values by selecting one of the radio buttons: Tab / Semicolon / Comma / Space / Other. 
in this latter case you have to enter in the field the separator character you wish to use. 

 Text Qualifier - you can select from the drop-down list the character to be used to "wrap" texts: 
double-quotes ("), quotes (') or none. 

 Value Type - you can select from the drop-down list the Value information to export among:  

o Only Value - exports only the Value. 

o Only Description - exports only the Value textual description. 

o Value and Description - exports the Value and its textual description. 

o Value or Description - exports either the Value, if this is meaningful by itself (e.g. the 
number of casualties) or, viceversa, its textual description. 

o Mixed Mode - exports either the Value alone, if this is meaningful by itself, or, viceversa, 
both the Value and its textual description. 

 Include column name in the first row - choose this option to put as first line in the export file a 
row with the names of the Attributes whose values are exported in the subsequent lines.  
The Attribute names are separated with same separator chosen for the Attribute values. 
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6.6.7. EXPORT SELECTED ATTRIBUTES TO ACCESS 

The Access export generates an Access database file (*.mdb) containing, for all the Occurrences 
selected as input in the "Source" tab-panel, the values of a set of Attributes that you specify. 

You can choose to generate any or both type of tables in the database file: 

 Flat Attribute Format table - one record per Occurrence with the set of fields containing the 
values of the Attributes specified. 
In some conditions there may be more than one record per Occurrence (see page 180). 

 Expanded Attribute Format table - one record per Attribute, of those specified, with fields 
hosting extended information on the Attribute.  
In some conditions there may be more than one record per Attribute (see page 180). 

You choose the type of tables to export (Flat, Expanded or both) in the "Configuration" tab-panel (see 
below).  

You choose the Attributes to export by specifying Attribute selections in the "Source" tab-panel (see 
page 168). 

6.6.7.1. EXPORT OCCURRENCES 

To export Occurrences as Access Database: 

 Specify the Occurrences to export and which of their Attributes (see page 168). 

 Specify the export destination files (see page 171). 

 Set the configuration in the "Configuration" tab-panel (see page 177). 

 Execute the tool by clicking the "Execute" button. The tool displays a progress bar on the left of 
the button. 

 Once the export has been performed the system shows a dialog to ask you whether you want to 
open the file exported. 

 Examine the log file, if needed. 
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6.6.7.2. CONFIGURATION TAB-PANEL 

The "Configuration" tab-panel let you have to specify the exporting options. 

 

Panel items: 

 Include in the Access file the following tables - use the radio buttons to select the type of 
tables to export : Flat, Expanded or both (see page 171). 

 Prefix for tables - specify the prefix that will be put to the table names in Access. 
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6.6.8. EXPORT SELECTED ATTRIBUTES TO EXCEL 

The Excel export generates an Excel workbook (*.xls) containing, for all the Occurrences selected as 
input in the "Source" tab-panel, the values of a set of Attributes that you specify. 

You can choose to generate any or both type of worksheet in the workbook file: 

 Flat Attribute Format worksheet - one row per Occurrence with the columns containing the 
values of the Attributes specified. 
In some conditions there may be more than one row per Occurrence (see page 180). 

 Expanded Attribute Format worksheet - one row per Attribute, of those specified, with columns 
hosting extended information on the Attribute.  
In some conditions there may be more than one row per Attribute (see page 180). 

You choose the type of worksheet to generate (Flat, Expanded or both) in the "Configuration" tab-panel 
(see page 179).  

You choose the Attributes to export by specifying Attribute selections in the "Source" tab-panel (see 
page 168). 

6.6.8.1. EXPORT OCCURRENCES 

To export Occurrences as Excel Worksheet: 

 Specify the Occurrences to export and which of their Attributes (see page 168). 

 Specify the export destination files (see page 171). 

 Set the configuration in the "Configuration" tab-panel (see page 179). 

 Execute the tool by clicking the "Execute" button. The tool displays a progress bar on the left of 
the button. 

 Once the export has been performed the system shows a dialog to ask you whether you want to 
open the file exported. 

 Examine the log file, if needed. 
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6.6.8.2. CONFIGURATION TAB-PANEL 

You have to specify the exporting options in the "Configuration" tab-panel. 

 

Panel items: 

 Include in the Excel file the following export formats - use the radio buttons to select the 
format type: Flat, Expanded or both (see page 180). 

 Include column name in the first row - choose this option to put in the first row the names of 
the Attributes whose values are exported in the subsequent rows.  
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6.6.9. ATTRIBUTE EXPORT FORMATS 

You can export the Attributes in two formats:  

 Flat Attribute Format - one line/row/record per Occurrence with the set of Attributes specified.  
In some conditions there may be more than one line per Occurrence. 

 Expanded Attribute Format - one line/row/record per specified Attribute, containing extended 
information on the Attribute.  
In some conditions there may be more than one line per Attribute. 

6.6.9.1. FLAT ATTRIBUTE FORMAT 

Each row include the data related to each Occurrence exported. 

There might be more than one row of data for each Attribute exported. For instance, in the Air Safety 
domain, when exporting the aircraft model there will be two rows if there are two aircrafts involved in the 
Occurrence. 

Its first three columns contain: 

 KEY - Occurrence signature, a code uniquely identifying an Occurrence in the ECCAIRS 
Reporting System. 

 ECCAIRS Number - the identifier for an Occurrence assigned by the for the responsible Entity. 

 Responsible Entity - the code for a the responsible Entity who entered the ECCAIRS Number, 
according to the Taxonomy in use in the Repository. 

There are two other columns for Attribute selected: 

 Attribute Value - the value or code of the Attribute as stored in the Occurrence. 

 Attribute Value Description - the expanded readable version of the Attribute value, according to 
the Taxonomy in use in the Repository.  

 

6.6.9.2. EXPANDED ATTRIBUTE FORMAT 

Each row will include data related to each Attribute to be exported. 

There might be more than one row of data for each Attribute exported.  

In particular if the Attribute has a multi-level Value List then there will be a line for each level. 

Also, if an Occurrence contains more than one instances of the Attribute, each belonging to a separate 
Entity instance, then there will be a line for the same Attribute for each Entity instance. For instance, in 
the Air Safety domain, if there are two aircrafts involved in the Occurrence on exporting the "Year Built" 
Attribute two lines will be generated.  

Its first three columns contain: 

 KEY - Occurrence signature, a code uniquely identifying an Occurrence in the ECCAIRS 
Reporting System. 

 ECCAIRS Number - the identifier for an Occurrence assigned by the for the responsible Entity. 

 Responsible Entity - the code for the responsible Entity who entered the ECCAIRS Number, 
according to the Taxonomy in use in the Repository. 
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There are six other columns which are used to describe each single Attribute on a line: 

 Attribute ID - the identifier of the Attribute, according to the Taxonomy in use in the Repository.  

 Attribute Description - textual description of the Attribute, according to the Taxonomy in use in 
the Repository.  

 Attribute Layout ID - the identifier of the layout chosen for the Attribute in the "Selection" 
window that shows up when specifying the Attribute in the "Source" tab-panel. 

 Attribute Layout Description - the layout chosen for the Attribute in the "Selection" window that 
shows up when specifying the Attribute in the "Source" tab-panel. 

 Attribute Value - the value of the Attribute as stored in the Repository database. 

 Attribute Value Description - the expanded readable version of the Attribute value, according to 
the Taxonomy in use in the Repository.  

 Unit - the measurement unit in which the Attribute value is expressed. 
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6.6.10. EXPORT OCCURRENCE LIST USING A TEMPLATE 

The "List from Template" export function generates a file where a few of the Attributes, for each 
Occurrence, are placed according to a formatted template defined by the User.  

The templates and the exported document can be Text files (*.txt), HTML files (*.htm) and Rich Text 
files (*.rtf). 

Instructions on building and using template files are given in the ECCAIRS White Paper available in the 
Support area of the ECCAIRS portal: 

http://eccairsportal.jrc.ec.europa.eu 

6.6.10.1. EXPORT OCCURRENCES 

To export Occurrences: 

 Specify the Occurrences to export (see page 168). 

 Specify the export destination file (see page 171). 

 Set the configuration in the "Configuration" tab-panel (see page 183). 

 Execute the tool by clicking the "Execute" button. The tool displays a progress bar on the left of 
the button. 

 Once the export has been performed the system shows a dialog to ask you whether you want to 
open the file exported. 

 Examine the log file, if needed (see page 173). 
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6.6.10.2. CONFIGURATION TAB-PANEL 

You have to specify the exporting options in the "Configuration" tab-panel. 

 

Panel items: 

 File Name - click the "..." button at the right of this field to locate and specify the template file 
name using the standard "Open" dialog. 
You can select Text files (*.txt), HTML files (*.htm) and Rich Text files (*.rtf). 

 Selections - here you have to specify all the Attributes that will be referenced in the template, 
both those that will appear in the formatted export and also those not appearing directly in the 
output but actually used inside the template to express conditions or to build control structures.  
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If you do not specify all the Attributes needed by the template, when you execute the export you get an 
"Configuration Errors" dialog showing all the errors detected. 

 

The "Selections" section lists all the Attributes specified so far. 

 

You can use the three right buttons to: 

 Add Attribute - add a new Attribute.  
You can specify the Attribute in the "Selection Builder" window that shows up (see page 288). 

 Edit Attribute - edit the Attribute currently selected.  
You can edit the Attribute specification in the "Selection Builder" window that shows up (see page 
288). 

 Remove Attribute - remove the Attribute currently selected. 
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6.6.11. EXPORT OCCURRENCES USING A TEMPLATE 

The export using a template generates a single output file where the Attributes of the Occurrence are 
placed according to a formatted template defined by the User.  

The templates and the exported document can be Text files (*.txt), HTML files (*.htm) and Rich Text 
files (*.rtf). 

Instructions on building and using template files are given in the ECCAIRS White Paper available in the 
Support area of the ECCAIRS portal: 

http://eccairsportal.jrc.ec.europa.eu 

As in the text-tree export format case, the (coded) database values of the Attributes are not exported.  

6.6.11.1. EXPORT OCCURRENCES 

To export Occurrences: 

 Specify the Occurrences to export (see page 168). 

 Specify the export destination file (see page 171). 

 Set the configuration in the "Configuration" tab-panel (see page 186). 

 Execute the tool by clicking the "Execute" button. The tool displays a progress bar on the left of 
the button. 

 Once the export has been performed the system shows a dialog to ask you whether you want to 
open the file exported.  

 Examine the log file, if needed (see page 173). 
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6.6.11.2. CONFIGURATION TAB-PANEL 

The "Configuration" tab-panel let you have to specify the exporting options in. 

 

Panel items: 

 File Name - click the "..." button at the right of this field to locate and specify the template file 
name using the standard "Open" dialog. 
You can select Text files (*.txt), HTML files (*.htm) and Rich Text files (*.rtf). 
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6.6.12. EXPORT OCCURRENCES AS TEXT-TREE 

The text-tree export format generates a single output file where the Attribute Values of the Occurrence 
are placed in a hierarchical tree structure defined by specific view chosen in textual form. The (coded) 
database values of the Attributes are not exported. 

 

6.6.12.1. EXPORT OCCURRENCES 

To export Occurrences as Text-Tree: 

 Specify the Occurrences to export (see page 168). 

 Specify the export destination file (see page 171). 

 Set the configuration in the "Configuration" tab-panel (see next section). 

 Execute the tool by clicking the "Execute" button. The tool displays a progress bar on the left of 
the button. 

 Once the export has been performed the system shows a dialog to ask you whether you want to 
open the file exported. 

 Examine the log file, if needed (see page 173). 
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6.6.12.2. CONFIGURATION TAB-PANEL 

The "Configuration" tab-panel let you have to specify the exporting options in. 

 

Panel items: 

 Type of Value Description - you can choose the type of description to use among: Description / 
Detailed / Explanation / Expanded.  
These are the Attribute Values type of descriptions defined in the Taxonomy in use in the 
Repository specified in the Repository/User credentials used. 

 Generate File According the Following Definition section: 

o Taxonomy Definition - choose this option to use the Repository Taxonomy as tree-
structure to attach the Entities and Attributes to export. 

o View Definition - select the View whose tree-structure to use the Repository Taxonomy 
as tree-structure to attach the Entities and Attributes to export. The Views are those 
available for the Repository/User credentials used.  
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6.7. DATA EXCHANGER TOOLS 

6.7.1. THE FOUR DATA EXCHANGER FUNCTIONS 

This tool includes four separate functions: 

 Load from Occurrence file (see page 191). 

 Save to Occurrence file (see page 197). 

 Copy Between Repositories (see page 202). 

 Purge Repository (see page 207). 

 

6.7.2. LOGGING ACTIVITY TAB-PANEL 

The "Logging Activity" tab-panel let you enable/disable logging and specify its options.  

You can create a log file every time you execute the tool. You cannot append logging to an existing log 
file. The file will be overwritten on execution. 
This means that a log file contains log messages for every single Data Manager tool execution. 
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Panel items: 

 Log Activity - choose this option to enable logging. 

 Logging Destination section: 

o File Name - click the "..." button at the right of this field to specify the log file name  and 
location using the standard "Save" dialog. 

 Logging Options section: 

o All messages / User feedback/Errors only - use the radio-button to specify whether the 
log file includes all messages or only User feedback and error messages.  

o Append Date/Time stamp to LOG file name - choose this option to append a date and 
time stamp to the log file name. For instance, if you choose "mylogfile.log" as file 
name, then the actual log file name after the execution on Sept. 18th 2011 at 13:50 and 
23 sec would be: 
mylogfile_18-09-2010 13-50-23.log  

o Automatically show log at the end of executions - choose this option to have Data 
Manager open the log file at the and of the execution. 

o Extended Activities - choose this option to generate an extra log file with extended 
messages on the exporting activities performed. The file is named as the "Logging 
Destination - File Name" entered before followed by the "_Extended" postfix. For instance, 
if you choose "mylogfile.log" as file name, the extended log file is named 
"mylogfile_Extended.log". 

o Summary Activities - choose this option to generate an extra log file with summary 
messages on the exporting activities performed. The file is named as the "Logging 
Destination - File Name" entered before followed by the "_Summary" postfix. For 
instance, if you choose "mylogfile.log" as file name, the extended log file is named 
"mylogfile_Summary.log". 
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6.8. DATA EXCHANGER - LOAD 
This function loads ECCAIRS Occurrence files in a Repository database. Occurrence files can be used 
to store, exchange and backup occurrences in an Repository.  

Typical usage of the "Data Exchanger - Load" function is for restoring the contents of your database from 
(a series of) Occurrence files.  

It is important to know that the "Data Exchanger - Load" function always respects the security settings of 
the Repository's security profile, so that confidentiality, if applied, is maintained. 

Usage of this function is mandatory when you migrate from one version of ECCAIRS to a newer major 
version of ECCAIRS and the data format and/or Taxonomy has been changed. In this case passing your 
data via Occurrence files guarantees you that all appropriate conversions and adaptations are 
performed. 

Though it is possible to save and load Occurrences also using the Browser application, in many cases 
using the "Data Exchange > Save to Occurrence file" and "Data Exchange > Load from Occurrence file" 
is more efficient, more clear, less likely to generate problems and better documented in the form of 
extensive logging options. 

The general operating sequence to use the "Data Exchanger - Load" function is: 

 Select the Occurrence files to load into the Repository database (see page 192). 

 Select the target Repository (see page 196).  

 Define the Load options (see page 194). 

 Set the Logging options (see page 189). 

 Execute the tool by clicking the "Execute" button. The tool displays a progress bar on the left of 
the button. 

 Once the task has been performed the system shows a result dialog with the count of the 
Occurrences processed successfully and those non processed for errors. 
Click the "OK" button to dismiss the dialog. 

 

 Examine the log file, if needed.  

There are four configuration tab-panels: 

 Source - to specify which Occurrence files to load into the Repository database. 

 Configuration - to set the duplication and de-identification options. 

 Destination - to set the destination Repository and access credentials. 

 Logging Activity - to set up logging and its options. This panel is the same for all the Data 
Exchange functions (see page 189). 

At the bottom of the window you have: 

 Execute button - you click this button to execute the load function. 
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6.8.1. SOURCE TAB-PANEL 

The "Source" tab-panel let you specify the Occurrences to be loaded into the Repository database.  
You can load Occurrences from several Occurrence files at once. 

 

Panel items: 

 Load list - the list of the Occurrence files already selected to be loaded into the Repository 
database.  
For each file the list displays: 

o File Name - the name of the Occurrence file. 

o Size - the size of the Occurrence file. 

o Modified - the last modification date of the Occurrence file. 

o Occurrences - the number of Occurrences included in the Occurrence file. 

o Path - the file system path to the Occurrence file. 

 Add - click this button to add an Occurrence file. Use the standard "Open" dialog to locate the 
Occurrence file. 

 Remove - select an Occurrence file in the list and click on this button to remove the file from the 
load list. 

 Clear - click this button to remove all the Occurrence files from the load list. 

 View File - click this button to show a "Preview" dialog. 
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The dialog displays the total count of Occurrences in the file and the list of these Occurrences, 
each with some Attributes displayed (as in the "Occurrence List" panel in the Browser).  
The Attributes displayed are specified in the Repository and Role/User that you have used in the 
"Credentials" field of the "Destination" tab-panel (see page 196).  

Click the "Close" button to exit the "Preview". 
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6.8.2. CONFIGURATION TAB-PANEL 

The "Configuration" tab-panel let you have to specify the load options. In particular you can specify any 
Attributes to de-identify before loading the Occurrences into the Repository database. 

 

Panel items: 

 Loader Options - "If Occurrence exists then"  
You can set the action that the tool must undertake when a duplicate Occurrence is detected 
when trying to load it into the database. 
The duplication is identified using the criteria which are specified in the Repository for the 
User/Role specified in the "Destination" tab-panel (see page 196). 
Select one of the options listed in the "If Occurrence exists then" drop-down list:  

o Overwrite Occurrence in database - the duplicate Occurrence in the database is 
removed and the new Occurrence from the Occurrence file is inserted. 

o Keep Occurrence in database - the duplicate Occurrence in the database is retained 
and the new Occurrence from the Occurrence file is ignored. 

o If Occurrence in database is older, overwrite - if the Occurrence from the Occurrence 
file has a more recent date than the Occurrence in the database then replace the 
duplicate Occurrence in the database by the new Occurrence from the Occurrence file. 

o If Occurrence in database exists, merge - merge the content of the Occurrence to be 
loaded into the Occurrence already inside the database. The merge procedure is 
performed according to the procedure specified in the Repository for the User/Role 
specified in the "Destination" tab-panel (see page 196). 

o Insert as new - insert the Occurrence as new Occurrence in the Repository database. A 
dialog is displayed, as in the "Prompt User" case, where you have to provide a new 
unique "ECCAIRS number". 
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o Stop uploading - stop the procedure. 

o Prompt User - a "Duplicate Occurrence" dialog will appear informing the User about the 
situation and asking the User how to proceed. 

 

You can choose the action ("Operation to execute:") to perform. The actions are the same 
as those listed above. 
You can choose the "Apply to All" option if you want to apply the same action to all the 
duplicate Occurrences detected.  

 Attributes to deidentify - if you need to de-identify the Occurrences to be loaded you have to 
specify which Attributes to de-identify. 
The panel lists the Attributes already selected for de-identification. 

 

Click the "mask-shaped" icon-button on the right and select the Attributes using the standard 
multi "Attribute Selection" dialog (see page 300). 
Using the dialog you can add or remove Attributes in the de-identification list. 
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6.8.3.  DESTINATION TAB-PANEL 

The "Destination tab-panel let you specify the Repository where the Occurrences are to be loaded. 

 

Panel items: 

 Current Source - if you choose this option the Occurrences will be loaded into the current 
Repository and with the current User credentials. This Repository and logon credentials were 
specified when starting the "Data Manager" application (see page 19). 
The current Repository and User are displayed in parentheses at the right of the check-box (e.g. 
MyRepository\MyUser). 

 Target Credentials - if you click the "connection" icon-button the system shows up the ECCAIRS 
"Login" dialog (see page 19) where you can login to the Repository you wish with the suitable 
User credentials. 



DATA MANAGER DATA EXCHANGER - SAVE 
 

 

197 

6.9. DATA EXCHANGER - SAVE 
This function saves Occurrence files into a Repository database 

Typical use of the "Data Exchange > Save to Occurrence file" and "Data Exchange > Load from 
Occurrence file" functions are for saving/restoring the contents of your database to/from (a series of) 
Occurrence files.  

It is important to know that this function always respects the security settings of the repository's security 
profile, so that confidentiality, if applied, is maintained. 

Usage of this function is mandatory when you migrate from one version of ECCAIRS to a newer major 
version of ECCAIRS and the data format and/or Taxonomy has been changed. In this case passing your 
data via Occurrence files guarantees you that all appropriate conversions and adaptations are 
performed. 

Though it is possible to save and load Occurrences also using the Browser application, in many cases 
using the "Data Exchange > Save to Occurrence file" and "Data Exchange > Load from Occurrence file" 
is more efficient, more clear, less likely to generate problems and better documented in the form of 
extensive logging options. 

The general operating sequence to use the "Data Exchanger - Save" function is: 

 Select the Source Repository and set the Query to extract from the database the Occurrences to 
save (see page 198). 

 Select the target Occurrence file(s) (see page 201). 

 Define the Save options (see page 200).  

 Set the Logging options (see page 189). 

 Execute the tool by clicking the "Execute" button. The tool displays a progress bar on the left of 
the button. 

 Once the task has been performed the system shows a result dialog with the count of the 
Occurrences processed successfully and those non processed for errors. 
Click the "OK" button to dismiss the dialog. 

 

 Examine the log file, if needed. 

There are four configuration tab-panels: 

 Source - to specify which Occurrence files of the Repository database to save. 

 Configuration - to set the de-identification and file-splitting options. 

 Destination - to set the destination Occurrence file. 

 Logging Activity - to set up logging and its options. This panel is the same for all the Data 
Exchange functions (see page 189). 

At the bottom of the window you have: 

 Execute button - you click this button to execute the load function. 
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6.9.1. SOURCE TAB-PANEL 

The "Source" tab-panel let you specify the Repository database Occurrences to be saved from the into 
the Occurrence file.  
This is done by using a Query on the Repository database. 

 

Panel items: 

 Credentials - if you click the "connection" icon-button the system shows up the ECCAIRS 
"Login" dialog where you can login to the Repository you wish with the suitable User. 

 Query - the field shows either the name of the Query currently in use, if taken from a Query 
Library, of the generic text "(Query)" if the Query has been defined standalone on the spot (see 
below). 
The icon-buttons on the right let you:  

o  Edit the Query - click the "pencil" icon-button to display the "Query Editing" window 
(see page 281) that allows to: 

 Edit locally a Query already opened from a Query Library without the need to edit 
or define Queries using the Query Builder 

 Create and edit standalone Queries, i.e. not stored in a Query Library. 

o  Open a Query Library - click the "open" icon-button to start the ECCAIRS Query 
Builder application that let you to access and define Query Libraries and Queries (see 
page 257).  
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o  Preview the Query result - click the "glasses" icon-button to display a "Preview" 
dialog. 

 

The dialog that displays the total count of Occurrences matching the Query and the list of 
these Occurrences, each with some Attributes displayed (as in the "Occurrence List" 
panel in the Browser). The Attributes displayed are specified in the Repository and 
Role/User that you have specified in the "Credentials" field.  
Click the "Close" button to exit the "Preview" dialog.  

 Explanation - the explanation of the Query currently in use. 
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6.9.2. CONFIGURATION TAB-PANEL 

The "Configuration" tab-panel let you specify the save options. In particular you can specify any 
Attributes to de-identify before saving the Occurrences into the Occurrence file. 

 

Panel items: 

 Destination - Split destination file when reached xxx Occurrences - choose this option to 
split the Occurrence file into several smaller ones in case it contains more than "xxx" 
Occurrences.  
Set the field at the right of the check-box with the maximum number of Occurrences that can be 
saved into a single file. 
The naming conventions for the splitted files is described in the "Destination" tab-panel (see page 
201). 

 Attributes to deidentify - if you need to de-identify the Occurrences to be loaded you have to 
specify which Attributes to de-identify. 
The panel lists the Attributes already selected for de-identification. 
Click the "mask-shaped" icon-button on the right and select the Attributes using the standard 
multi "Attribute Selection" dialog (see page 300). 
Using the dialog you can add or remove Attributes to the de-identification list. 
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6.9.3. DESTINATION TAB-PANEL 

The "Destination tab-panel let you specify the Repository where the Occurrences are to be loaded. 

 

Panel items: 

 Destination - File Name - click the "..." button at the right of this field to specify the destination 
file name and location using the standard "Save" dialog. 

If the destination Occurrence file has been split into several smaller ones, because of its size and the 
option set in the "Configuration" tab-panel, then each file will have the name specified in the "File Name" 
field above extended with the particular range of occurrences generated. 

For example: if the generated file name is LossOfControl.e5f with a total number of occurrences of 1789, 
and the split threshold is set to 1000, then the system will generate: 

 LossOfControl1-1000.e5f 

 LossOfControl1001-1789.e5f 
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6.10. DATA EXCHANGER - COPY BETWEEN REPOSITORIES 
The "Data Exchanger - Copy between Repositories" function transfer Occurrences from one Repository 
database into another one. 
We will call this function briefly as "Data Exchanger - Copy". 

You cam also choose to move Occurrences across Repository databases, rather then copy them. 

You could use this tool as an extra safety measure in addition to, but not substituting, the regular 
database (RDBMS) backups.  

It can be used on an ad-hoc basis to make a copy or it can be used when you migrate between two 
ECCAIRS or database (RDBMS) versions. 

 

The general operating sequence to use the "Data Exchanger - Copy" function is: 

 Select which occurrence to extract from the source Repository database (see page 203). 

 Select the target Repository (see page 206). 

 Define the Copy options: de-identification, copy/move and duplicate handling options(see page 
204). 

 Set the Logging options (see page 189). 

 Execute the tool by clicking the "Execute" button. The tool displays a progress bar on the left of 
the button. 

 Once the task has been performed the system shows a result dialog with the count of the 
Occurrences processed successfully and those non processed for errors. 
Click the "OK" button to dismiss the dialog. 

 

 Examine the log file, if needed. 

 

There are four configuration tab-panels: 

 Source - to specify which Occurrence files of the source Repository database to copy. 

 Configuration - to set the de-identification, copy/move and duplicate handling options. 

 Destination - to set the destination Repository database. 

 Logging Activity - to set up logging and its options. This panel is the same for all the Data 
Exchange functions (see page 189). 

At the bottom of the window you have: 

 Execute button - click this button to execute the copy function. 

 



DATA MANAGER DATA EXCHANGER - COPY BETWEEN REPOSITORIES 
 

 

203 

6.10.1. SOURCE TAB-PANEL 

The "Source" tab-panel let you specify the source Repository database Occurrences to be saved into the 
target Repository database.  
This is done by using a Query on the source Repository database. 

 

Panel items: 

 Credentials - click the "connection" icon-button to display the ECCAIRS "Login" dialog where 
you can login to the Repository you wish with the suitable User. 

 Query - the field shows either the name of the Query currently in use, if taken from a Query 
Library, of the generic text "(Query)" if the Query has been defined standalone on the spot (see 
below). 
The icon-buttons on the right let you:  

o  Edit the Query - click the "pencil" icon-button to display the "Query Editing" window 
(see page 281) that allows to: 

 Edit locally a Query already opened from a Query Library without the need to edit 
or define Queries using the Query Builder 

 Create and edit standalone Queries, i.e. not stored in a Query Library. 

o  Open a Query Library - click the "open" icon-button to start the ECCAIRS Query 
Builder application that let you access and define Query Libraries and Queries (see page 
257).  

o  Preview the Query result - click the "glasses" icon-button to display a "Preview" 
dialog. 
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The dialog displays the total count of Occurrences matching the Query and the list of 
these Occurrences, each with some Attributes displayed (as in the "Occurrence List" 
panel in the Browser). The Attributes displayed are specified in the Repository and 
Role/User that you have specified in the "Credentials" field.  
Click the "Close" button to exit the "Preview".  

 Explanation - the explanation of the Query currently in use. 

6.10.2. CONFIGURATION TAB-PANEL 

The "Configuration" tab-panel let you have to specify the copy options. In particular you can specify any 
Attribute to de-identify before loading the Occurrences into the target Repository database. 
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Panel items: 

 Copy Options section: 

o Move Occurrences - choose this option to move, rather than copy, Occurrences from the 
source Repository database to the target one. Consequently the Occurrences copied to 
the target Repository database will also be removed from the source one.  

o "If Occurrence exists then"  
You can set the action that the tool must undertake when a duplicate Occurrence is 
detected when trying to load it into the database. 
The duplication is identified using the criteria which are specified in the Repository for the 
User/Role specified in the "Source" tab-panel (see page 203). 
Select one of the options listed in the "If Occurrence exists then" drop-down list: 

 Prompt User - a "Duplicate Occurrence" dialog will appear informing the User 
about the situation and asking the User how to proceed. 

 

You can choose the action ("Operation to execute:") to perform. The actions are the same 
as those listed below. 
You can choose the "Apply to All" option if you want to apply the same action to all the 
duplicate Occurrences detected.  

o Overwrite Occurrence in database - the duplicate Occurrence in the target database 
is removed and the new Occurrence from the source database is inserted. 

o Keep Occurrence in database - the duplicate Occurrence in the target database is 
retained and the new Occurrence from the source database is ignored. 

o If Occurrence in database is older, overwrite - if the Occurrence from the source 
database has a more recent date than the Occurrence in the target database then 
replace the duplicate Occurrence in the target database by the new Occurrence from 
the source database. 

o If Occurrence in database exists, merge - merge the content of the Occurrence to 
be loaded into the Occurrence already inside the target database. The merge 
procedure is performed according to the procedure specified in the Repository for the 
User/Role specified in the "Destination" tab-panel (see page 206). 

o Insert as new - insert the Occurrence as new Occurrence in the target Repository 
database. A dialog is displayed, as in the "Prompt User" case, where you have to 
provide a new unique "ECCAIRS number". 

o Stop uploading - stop the procedure.  
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 Attributes to deidentify - if you need to de-identify the Occurrences to be loaded you have to 
specify which Attributes to de-identify. 
The panel lists the Attributes already selected for de-identification. 

 

Click the "mask-shaped" icon-button on the right and select the Attributes using the standard 
multi "Attribute Selection" dialog (see page 300). 
Using the dialog you can add or remove Attributes to the de-identification list. 

 

6.10.3. DESTINATION TAB-PANEL 

The "Destination tab-panel let you specify the target Repository where the Occurrences are to be 
copied/moved. 

 

Panel items: 

 Destination - Credentials - click on the "connection" icon-button to display the ECCAIRS "Login" 
dialog where you can login to the target Repository you wish with the suitable User credentials 
(see page 19). 
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6.11. DATA EXCHANGER - PURGE REPOSITORY 
The "Data Exchanger - Purge > Repository" function erase all or some of the Occurrences in a 
Repository.  

The function offers you the possibility to backup the Occurrences before the removal. 

 

The general operating sequence to use the "Data Exchanger - Purge" function is: 

 Select which Occurrences will be deleted from the Repository database (see page 208). 

 Specify if you wish to create backup Occurrence files for the Occurrences being removed (see 
page 210). 

 Define the backup options- splitting options for the backup Occurrence file, if any (see page 209). 

 Set the Logging options (see page 189). 

 Execute the tool by clicking the "Execute" button. The tool displays a progress bar on the left of 
the button. 

 Once the task has been performed the system shows a result dialog with the count of the 
Occurrences processed successfully and those non processed for errors. 
Click the "OK" button to dismiss the dialog. 

 

 Examine the log file, if needed. 

 

The "Purge" function of the "Data Exchanger" tool has four configuration tab-panels: 

 Source - to specify which Occurrence files of the Repository database to delete. 

 Configuration - to set splitting options for the backup Occurrence file, if any. 

 Destination - to set a backup Occurrence file to be created before removing Occurrences form 
the database. 

 Logging Activity - to set up logging and its options. This panel is the same for all the Data 
Exchange functions (see page 189). 

At the bottom of the window 

 Execute button - click this button to execute the purge function. 

 

 



DATA MANAGER DATA EXCHANGER - PURGE REPOSITORY 
 

 

208 

 

6.11.1. SOURCE TAB-PANEL 

The "Source" tab-panel let you specify which of the Repository database Occurrences will be deleted.  
This is done by using a Query on the Repository database. 

 

Panel items: 

 Credentials - click the "connection" icon-button to display the ECCAIRS "Login" dialog where 
you can logon to the Repository you wish with the suitable User. 

 Query - the field shows either the name of the Query currently in use, if taken from a Query 
Library, of the generic text "(Query)" if the Query has been defined standalone on the spot (see 
below). 
The icon-buttons on the right let you:  

o  Edit the Query - click the "pencil" icon-button to display the "Query Editing" window 
(see page 281) that allows to: 

 Edit locally a Query already opened from a Query Library without the need to edit 
or define Queries using the Query Builder. 

 Create and edit standalone Queries, i.e. not stored in a Query Library. 

o  Open a Query Library - click the "open" icon-button to start the ECCAIRS Query 
Builder application that let you access and define Query Libraries and Queries (see page 
257).  

o  Preview the Query result - click the "glasses" icon-button to display a "Preview" 
dialog. 
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The dialog displays the total count of Occurrences matching the Query and the list of 
these Occurrences, each with some Attributes displayed (as in the "Occurrence List" 
panel in the Browser). The Attributes displayed are specified in the Repository and 
Role/User that you have specified in the "Credentials" field.  
Click the "Close" button to exit the "Preview" dialog.  

 Explanation - the explanation of the Query currently in use. 

6.11.2. CONFIGURATION TAB-PANEL 

The "Configuration" tab-panel let you specify options on the backup Occurrence file that can be 
generated before removing Occurrences from the Repository database. 

 

Panel items: 

 Destination - Split destination file when reached xxx Occurrences - choose this option to 
split the backup Occurrence file into several smaller ones in case it contains more than "xxx" 
Occurrences. Set the field at the right of the check-box with the maximum number of 
Occurrences that can be saved into a single file. 
The naming conventions for the splitted files is described when dealing with the "Destination" tab-
panel. 
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6.11.3. DESTINATION TAB-PANEL 

The "Destination tab-panel let you specify if a backup Occurrence file should be created before removing 
Occurrences form the database. 

 

Panel items: 

 Backup folder section: 

o Backup Occurrence data into folder - choose this option to generate a backup 
Occurrence file containing the Occurrences that are being removed from the Repository 
database. 

o Folder Name - use the standard Windows folder selection dialog to locate the folder 
where the backup Occurrence file(s) will be stored. You can create a new folder for the 
backup using the same dialog. 

If the backup Occurrence file has been split into several smaller ones, because of its size and the option 
set in the "Configuration" tab-panel, then each backup file will have the name followed with the particular 
range of Occurrences saved. 
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6.12. BATCHELOR TOOL 
The Batchelor is a tool which is used to make Batch type of modifications to a set of Occurrences stored 
in a Repository database or in an Occurrence file.  

It can be used to make simple straightforward changes but for advanced Users possibilities exist to 
make conditional changes and apply scripts on the data. 

This tool works directly on the physical structure of an Occurrence, thus modifying the content of the 
Repository database. 

The Batchelor is therefore aimed at advanced Users of the ECCAIRS Reporting System. 

To get more information follow these links: 

 Using the Batchelor (see page 211). 

 Batchelor Functions and Tab-Panels (see page 213). 

 

6.12.1. USING BATCHELOR 

This tool let you specify the Occurrences to be processed with through a Query in the Repository 
database . 

Each action on the Occurrences is specified by a Processor which is triggered by specific conditions.  
You can add as many Processors as you wish. 
The Batchelor will execute sequentially all configured processors. 

The Occurrences processed can be saved in the Repository database or as an Occurrence file. 

Before using the Batchelor you should read about Processors and the way Batchelor executes them 
(see page 212). 

To perform a Batchelor conversion: 

 Define the Occurrences to be processed (see page 214). 

 Define the destination for the Occurrences processed (see page 218). 

 Set a backup folder, if any (see page 219). 

 Add/Remove/Move Processors (see page 217). 

 Setup each Processor (see page 221). 

 Set the Logging options (see page 220). 

 Execute the tool by clicking the "Execute" button. 

 Examine the log file, if needed. 
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6.12.2. PROCESSORS 

The Batchelor tool is based on Processors. A Processor is a collection of conditions and actions able to 
modify your source Occurrence data. 

The Batchelor is based on external components called Add-Ins.  
In fact the Processor passes each source Occurrence to the Add-in, which does the job and returns the 
possibly modified Occurrence back to the Batchelor environment.  

The Batchelor tool comes with a "Standard" Add-in, that is the one we refer to in this documentation.  
Also in the rest of the documentation we will use the word "Processor" to refer to the sum of the 
Processor (internal) and the standard Add-in (external) actions. 

For each source Occurrence the Batchelor: 

 executes the first Processor which, if its triggering condition is satisfied, executes the associated 
actions which involve modifications to the Occurrence. 

 the Batchelor then executes, for the same Occurrence, the second Processor if its triggering 
condition is satisfied on the basis of the results returned by the previous Processor, then the third 
Processor, and so on. 

 after the last processor has finished, the Batchelor skips to the second source Occurrence and 
walks through the entire batch of Processors again. 

The two elements of a Processor are: 

 Conditions 

 Actions 

Processors are managed (add, edit, delete) in the "Configuration" tab-panel (see page 217).and actually 
edited using the Configure "Standard" dialog (see page 221). 

6.12.2.1. CONDITIONS 

The conditions represent the necessary amount of information that allows the processor to understand 
whether the current Occurrence record must be processed by the Add-In or not. A condition consists of a 
comparison Attribute, a comparison operator and a comparison value.  

For each processor, a number of conditions can be specified concurrently, making use of a mixture of 
Attributes. 

You can set conditions on several Entities and, for each Entity, on several of its Attributes (see page 
224). 

All conditions are linked with an "AND" statement which means that the different comparisons are 
chained together into a single criterion where all the components must be true at the same time.  

To set conditions in logical "OR", i.e. only one condition need to be true, teen you need to define different 
processors (see page 224). 

6.12.2.2. ACTIONS 

The action is the operation that the processor performs on the Occurrence data .  

Action includes updating data (such as changing the number of engines from 2 to 4) but also activities 
like adding Attribute values and sub-Entities (like adding a second engine to an aircraft or adding a note), 
deleting and more. 



DATA MANAGER BATCHELOR TOOL 
 

 

213 

6.12.3.  BATCHELOR: FUNCTIONS AND TAB-PANELS 

 

The Batchelor tool includes four configuration tab-panels and the "Execute" button: 

 Configuration panel - you can select and edit parameters in each panel by clicking on the 
corresponding upper tab: 

o Source - to specify the Occurrences to be processed. 

o Configuration - to specify the processes that Batchelor will run on the Occurrences. 

o Destination - to set the destination for the processed Occurrences. 

o Logging Activity - to set up logging and its options. 

 Execute button - you click this button to execute all Processors in the "Configuration" tab-panel. 
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6.12.4. SOURCE TAB-PANEL 

The "Source" tab-panel let you specify the Occurrences that the "Batchelor" tool will process.  
The Occurrences may be specified by an Occurrence file or by a Query in the database. 

 

There are two sections in the "Source" tab-panel: 

 "Query" section  

 "Occurrence File" section 
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6.12.4.1. "QUERY" SECTION 

In the Query panel you specify the Query that will extract the Occurrences to be processed by the 
Batchelor. 

Panel items: 

 Credentials - click the "connection" icon-button to display the ECCAIRS "Login" dialog where 
you can login to the Repository you wish with the suitable User. 

 Query - the field shows either the name of the Query currently in use, if taken from a Query 
Library, of the generic text "(Query)" if the Query has been defined standalone on the spot (see 
below). 
The icon-buttons on the right let you:  

o  Edit the Query - click the "pencil" icon-button to display the "Query Editing" window 
(see page 281) that allow to: 

 Edit locally a Query already opened from a Query Library without the need to edit 
or define Queries using the Query Builder 

 Create and edit standalone Queries, i.e. not stored in a Query Library. 

o  Open a Query Library - click the "open" icon-button to start the ECCAIRS Query 
Builder application that allows you access and define Query Libraries and Queries (see 
page 257).  

o  Preview the Query result - click the "glasses" icon-button to display a "Preview" 
dialog. 

 

The dialog displays the total count of Occurrences matching the Query and the list of 
these Occurrences, each with some Attributes displayed (as in the "Occurrence List" 
panel in the Browser). The Attributes displayed are specified in the Repository and 
Role/User that you have logged in.  
Click the "Close" button to exit the "Preview" dialog. 
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 Explanation - the explanation of the Query currently in use. 

6.12.4.2. "OCCURRENCE FILE" SECTION  

If you select this option you have to specify in the "Occurrence File". 

Panel items: 

 File Name - click the "..." button at the right of this field to locate and specify the Occurrence file 
name using the standard "Open" dialog. 

 Preview the Query result - click the "glasses" icon-button at the right to display a "Preview" 
dialog. 

 

The dialog displays the total count of Occurrences in the file and the list of these Occurrences, 
each with some Attributes displayed (as in the "Occurrence List" panel in the Browser). The 
Attributes displayed are specified in the Repository and Role/User that you have logged in.  
Click the "Close" button to exit the "Preview" dialog. 
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6.12.5. CONFIGURATION TAB-PANEL 

The "Configuration" tab-panel let you specify the actions that the Batchelor tool must undertake on the 
source Occurrences specified in the "Source" tab-panel.  
The actions are specified as a set of Processors executed sequentially in the order specified.  
Each Processor action is triggered by some conditions on the input Occurrence. 

 

The panel lists the Processors defined so far, with their name and some other key properties of those 
defined in the "Edit Processor" dialog when adding or editing the Processor, including the Processor 
enable/disable status. 

A Processor will be executed only if it has been enabled (see the second column in the list) and if the 
"Execute on" condition has been satisfied by the previous Processor, if any.  
Both these options are set in the "Edit Processor" dialog that shows up when adding or editing a 
Processor (see page 221). 

Using the icon-buttons on the right you can: 

 Add Processor - add a new Processor.  
The "Edit Processor" dialog shows up to actually define the Processor (see page 221).  

 Edit Processor - edit the Processor currently selected in the list.  
The "Edit Processor" dialog shows up to actually define the Processor (see page 221). 

 Remove Processor - remove the Processor currently selected in the list.  

 Move Processor Up/Down - move up/down the Processor in the execution list.  
The execution order may be important if some Processors is based on Entities or Attributes 
which may be modified by other Processors.  
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6.12.6. DESTINATION TAB-PANEL 

The "Destination" tab-panel let you specify the target Repository where the Occurrences are to be 
copied/moved. 
You can also set up options to make test executions without altering any Occurrence data but generating 
logs to check the correct functionality of the Processors you have configured. 

 

There are two sections 

 "Save to" section 

 "Backup folder" section 



DATA MANAGER BATCHELOR TOOL 
 

 

219 

6.12.6.1. "SAVE TO" SECTION 

You can save the processed Occurrences either in the source (Repository database or Occurrence file) 
or in a new Occurrence file or even in both at the same time. 

You can also choose to disable all output options so that no Occurrence will be modified.  
However the Batchelor will still execute all the Processors and you may use the log file generated to 
check that the Processors configuration works correctly. 

Panel items: 

 Current Source - if you select this option the Occurrences will be modified directly inside the 
source of the Occurrences specified: either a Repository or an Occurrence file. The current 
Repository\User, or Occurrence file path, are displayed in parentheses at the right of the check-
box (e.g. MyRepository\MyUser, D:\ECCAIRS\MySourceOccurrenceFile.e5f). 

 New File - to save the processed Occurrences in a new Occurrence file: 

o File Name - click the "..." button at the right of this field to specify the destination 
Occurrence file name using the standard "Save" dialog. 

o Append Date/Time Stamp to File Name - choose this option to append a date and time 
stamp to the file name. For instance, if you choose "my export file" as file name with an 
"Excel Worksheet" export function, then the actual export file name after the execution on 
Sept. 18th 2011 at 13:50 and 23 sec would be: 
my export file_18-09-2010 13-50-23.xls 

o Include in Output File also Non Modified Occurrences - select it to include in the 
output Occurrence file also the Occurrences that will not be modified by the Batchelor 
Processors. 

6.12.6.2. "BACKUP FOLDER" SECTION 

Running a Batchelor processor may modify the source Occurrence if the "Current Source" option has 
been selected in the "Save to" section. To prevent the loss of important data it is recommended to create 
a backup of the Occurrences that will be processed. 

Panel items: 

 Backup Occurrence Data into Folder - select this option to generate a backup Occurrence file 
containing the Occurrences that are being modified in the Repository database. 

 Folder Name - use the standard Windows folder selection dialog to locate the folder where the 
backup Occurrence file(s) will be stored. You can create a new folder for the backup using the 
same dialog. This action will automatically create a new folder named with the date (yyyy-mm-dd) 
and time (h.min.sec) of execution. 
Inside this folder the application creates the file "E5Batchelor.e5l". 
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6.12.7. LOGGING ACTIVITY TAB-PANEL 

The "Logging Activity" tab-panel let you enable/disable logging and specify its options. 

 

You can create a log file every time you execute a Data Manager tool. You cannot append logging to an 
existing log file. The file will be overwritten on execution. 
This means that a log file contains log messages for every single Data Manager tool execution. 

Panel items: 

 Log Activity - choose this option to enable logging. 

 Logging Destination -section: 

o File Name - click the "..." button at the right of this field to specify the log file name and 
location using the standard "Save" dialog. 

 Logging Options section: 

o All messages / User feedback / Errors only - specify whether the log file includes all 
messages or only User feedback and error messages.  

o Append Date/Time stamp to LOG file name - select it to append a date and time stamp 
to the log file name. For instance, if you choose "mylogfile" as file name, then the 
actual log file name after the execution on Sept. 18th 2011 at 13:50 and 23 sec would be: 
mylogfile_18-09-2010 13-50-23.log  

o Automatically show log at the end of executions - select it to have Data Manager 
open the log file at the end of the execution. 
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6.12.8. EDITING PROCESSORS 

When you add/edit a Processor you get an "Edit Processor" dialog, where you define the "Add-In" that 
executes the Processor and you configure its actions. 

 

Dialog items: 

 Name - (text box - mandatory) a name for the Processor. This name is a mandatory requirement. 
If no name is given you get an error dialog and you will not be able to save the Processor. 

 Activation - (section) a setting section dealing with the specific Add-In used to implement the 
Processor:   

o Activation type - (drop-down list) the software framework in which the Add-In has been 
programmed to communicate with the ECCAIRS system: .NET or COM. 

o Assembly / class - (drop-down lists) the Assembly (software library module) and the 
specific class (method) to invoke when the triggering action takes place. They are bound 
to Add-Ins or other support modules provided by ECCAIRS. All the assemblies and 
corresponding classes are selectable via drop-down lists. The selections you should 
make are described in the installation/technical documentation provided with the Add-In or 
from the ECCAIRS System Administrator.    You normally use the Batchelor Add-In, so 
select form the drop-down lists: 

 Assembly = "Batchelor". 

 Class = "ECCAIRS 5 Batchelor". 

o Configuration - (display box and button) clicking on the corresponding arrow-shaped 
"Edit" button on the right let you configure the Add-In specified before with the "Assembly" 
and "Class" entry. You get an activation-type specific dialog where you may configure the 
Add-In, whenever appropriate. 
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You normally use the Batchelor Add-In, so clicking on the button the shows up the 
"Batchelor Standard Add-In Configure" dialog to actually define the Processor (see page 
223). 

If there are no configuration options available for a specific Add-in, other from the Batcher 
one, you get a notification dialog: "The component is not configurable".  
If, vice versa, any configuration is needed and you have not yet performed it when closing 
the Add/Edit dialog, ECCAIRS displays a warning message.  

 

o Properties - (read-only text box) displays summary technical information on the Add-In.  

 Details - (section) a setting section specifying if the Processor must be executed, depending on 
the result provided by the previous Processor listed in the "Configuration" tab-panel. Use the 
check boxes to choose one or more exit conditions provided by the previous Processor that allow 
the execution of the current Processor among: 

 

o Success - (check box) execute the Processor if the previous one returns a "success" 
state. 

o Warning - (check-box) execute the Processor if the previous one returns a "warning" 
state. 

o Error - (check-box) execute the Processor if the previous one returns an "error" state. 

 Enabled - (check box) choose this option to enable or disable the Processor. This way you can 
easily "switch on/off" an Processor with no reconfiguration needed or, for instance, configure it 
partially and then leave it disabled for later completion. 
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6.12.9. CONFIGURING PROCESSORS 

You configure a Processor using the "Configure Batchelor" dialog. 

 

This window displays all the Entities that represent the structure of an Occurrence. 
Entities, together with Attributes, are the building blocks of the Taxonomy. The Taxonomy is at the base 
of a Repository and its Views. 
To get a complete view of a Taxonomy can use the "Taxonomy Browser" tool within the ECCAIRS 
Reporting System. 

Dialog items: 

 Description text box - type here a title/description for the Processor. This action is mandatory. 

 Conditions/Activities panel - here you create/edit Conditions and Actions on Entities (see page 
224). 

 Expand/Collapse buttons - use these buttons to expand/collapse the Entity-tree. Remember 
that Entities are all children of the Occurrence, which is the root Entity, and may have child 
Entities. 
You can also expand/collapse single branches clicking on the nodes of the Entity-tree.  

 Filter button - use this button to show in the "Conditions/Activities" panel only Entities whose 
name matched the text string entered in the text box that shows up on clicking the button. 

 OK/Cancel buttons - to exit the dialog. Click the "OK" button to accept the editing done or 
"Cancel" to discard it. 

The items in the dialog are few, but most of the editing is done working inside the Conditions-Activities 
panel using its Right-click menu-items. 

To exit the dialog click: 

 OK - to accept the editing done and close the dialog. 

 Cancel - to discard the editing. 
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6.12.9.1. EVALUATING CONDITIONS 

The Processor can set Conditions on several Entities and they will all evaluated in logical AND. This 
means that all the Conditions on all the Entities must be satisfied to trigger the Actions associated to 
each Entity.  

Each Entity-Condition, in turn, is based one or more Attributes of the Entity. These Attribute-Conditions 
are evaluated in logical AND, this means that all the Attribute-Conditions must be satisfied to trigger the 
Condition Action(s).  

6.12.9.2. EXPRESSING CONDITIONS IN LOGICAL OR 

To sum up, within a single Processor all the Attribute-Conditions in all the Entity-Conditions must be 
satisfied together to trigger the Actions specified. 
If you need to express Entity-Conditions or, within the same Entity, Attribute-Condition that will be 
evaluated in logical OR, i.e. evaluated independently on the other one, then you need to define it into 
another Processor. 
If you need to do so, remember that each Processor works on the Occurrence modified by the previous 
Processor(s) in the list.  

You can associate to each Entity-Condition one or more Actions.  

6.12.9.3. HOW TO CONFIGURE A PROCESSOR 

To configure a processor, follow these steps: 

 (mandatory) Type a title/description for the Processor in the "Description" text box. 

 For each Entity you want to modify: 

o Select the Entity. 

o Add as many Conditions as needed by selecting the "Right click > Define Condition" 
menu-item.  
This will open the "Define Condition" dialog where you define a one or more Attribute-
Conditions on the Entity (see page 225). 

o An Entity-Condition red node is appended to the Entity node. 
The Attribute-Conditions are listed below the Entity-Condition. 
Each Attribute-Condition is a separate line and is also marked in red. 

o Select the Entity-Condition. 

o Add the Actions needed by selecting "Right click > Append Action" menu-item.  
This will open the "Action" dialog where you actually define the Action (see page 226). 

 Once you have set all Conditions and Actions on the Entity(ies) you can exit the "Configure 
Standard" dialog. To exit the dialog: 

o OK - to accept the editing done and close the dialog. 

o Cancel - to discard the editing. 
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6.12.9.4. DEFINE CONDITION DIALOG 

The "Define Condition" dialog let you define one or more Attribute-Conditions on the same Entity. 

 

The panel has two sections: 

 Condition on Entity - you can put a single Condition on the Entity. 

 Condition(s) on Attributes - you can put Conditions on any of the Attributes belonging to the 
Entity. 

Condition on Entity 

The options for the Entities are used to instruct the processor to look for: 

 Entity existing - this condition is true when this Entity is available in the Occurrence record. For 
instance, in the air safety domain, if an aircraft was involved in the incident and it was properly 
entered using the Browser.  
Under this option, additional choices are possible: 

o Any Entity - with this choice, the Entity can be in any position within the list of same 
Entities. For instance, it can be the first, second, fifth or last aircraft stored in the 
Occurrence. 

o Entity is the first - it is the first one. 

o Entity is the last - it is the last one. 

 Entity not existing - this condition is true when this Entity is not available in the Occurrence 
record. For instance, in the air safety domain, when air traffic control was involved in the incident 
but the ATS Unit was never entered. 

 Entity existing or not existing - a combination of the above with the exception of being able to 
track the position of the Entity in the Occurrence.  
This option can be used as a work around when you need to define another Processor only to 
express conditions in logical OR (see page 224). 

The options and choices above are mutually exclusive. 
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Conditions on Attributes 

The Attributes section of the panel can be used to restrict the focus of the tool to an even smaller set of 
Occurrences then those that would be considered using only the Entity conditions. By clicking on the 
button at the right side, Attribute conditions are added. 

The definition of the Attribute condition is done via the "Query Editing" dialog in the Query Builder (see 
page 281).  

Many Attribute-Conditions can be specified at the same time. Please keep in mind that specifying more 
than one Attribute-Condition may prevent the tool from updating the Occurrence record, due to the fact 
that the resulting condition is hitting more exceptions than targets. 

As in the Query Builder, most operators work only on existing data. For instance, in the air safety 
domain, if looking for records involving Boeing 747 aircrafts with a number of engines different from 4, 
those records for which this Attribute was never specified will not be processed. In this case, post an 
Attribute condition using the ‘has no value’ operator. In the event, this may require creating a second 
instance of the same Processor. 

6.12.9.5. ACTION DIALOG 

You set the Actions performed by a Processor using the "Action" dialog. 

 

There are two tab-panels available: 

 Standard tab-panel - you can set here actions on the Entity Attributes. See below. 

 Scripting tab-panel - here you can perform advanced management of conditions. This topic it 
goes beyond the scope of this document. Refer to the ECCAIRS Portal and the ECCAIRS Co-
ordination and Development team. 
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"Standard" tab-panel 

In the "Standard" tab-panel we have two or more sections, the "Action Type" section and one or more 
section(s) to specify actions suitable to the "Action Type" selected. 

Action Type section: 

 Append new Entity - A new empty Entity is added to the Occurrence that is child of the current 
Entity, in the above example this could be the Entity of the flight crew members.  
In the sections displayed below you must select the sub-Entity to append and one or more of its 
Attribute values. 

 Delete Entity - This action removes the current Entity, the Attributes of this Entity and all child 
Entities and Attributes as well. 

 Link Entity - This action creates a link between the current Entity and a new Entity. This type of 
action can be used for instance, in the air safety domain, for linking an aircraft to a determined 
airspace or event. 
In the sections displayed below you must select the sub-Entity to link and one or more of its 
Attribute values. 

 Unlink Entity - This action removes an existing link between the current Entity and another 
Entity. 

 Update Entity - This action will instruct the processor to operate changes on the values of one or 
more Attributes that are part of an Entity. 
In the section below there is a list of the Attributes that need to be updated. The list must contain 
at least one Attribute.  

 



DATA MANAGER BATCHELOR TOOL 
 

 

228 

 

THIS PAGE IS LEFT INTENTIONALLY BLANK 

 

 



DATA MANAGER DEIDENTIFICATION RESTORER TOOL 
 

 

229 

6.13. DEIDENTIFICATION RESTORER TOOL 
The "Deidentification Restorer" tool let you restore identification data on de-identified Occurrence files. 

This tool is included in the Data Manager only if the Repository and the Role/User you logged in allows 
this function for the User/Role.  

To get more information see: 

 Using the Restorer (see page 229). 

 Restorer Tab-Panels (see page 230). 

  

6.13.1. USING RESTORER 

To restore de-identified Occurrences: 

 Specify the De-Identified Source Occurrence file (see page 231). 

 Specify the restored destination Occurrence file (see page 233). 

 Set the options in the "Configuration" tab-panel (see page 232). 

 Set the Logging options (see page 234). 

 Execute the tool by clicking the "Execute" button. 

 The tool displays a progress bar on the left of the "Execute" button. 

 Once the task has been performed the system shows a result dialog with the count of the 
Occurrences processed successfully and those non processed for errors. 
Click the "OK" button to dismiss the dialog. 

 Examine the log file, if needed. 
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6.13.2. RESTORER: FUNCTIONS AND TAB-PANELS 

The Restorer tool includes four configuration tab-panels and the "Execute" button: 

 

 Configuration panel - you can select and edit parameters in each panel by clicking on the 
corresponding upper tab: 

o Source - to specify the Occurrences to be processed. 

o Configuration - to specify processing options. 

o Destination - to set the destination for the restored Occurrences. 

o Logging Activity - to set up logging and its options. 

 Execute button - click this button to start the De-Identified Occurrence restore process. 
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6.13.3. SOURCE TAB-PANEL 

The "Source" tab-panel let you specify the file hosting the De-Identified Occurrences.  

 

Panel items: 

 File Name - click the "..." button at the right of this field to locate and specify the source 
Occurrence file name using the standard "Open" dialog. 

 Preview the Query result - click the "glasses" icon-button at the right to display a "Preview" 
dialog. 

 

The dialog displays the total count of Occurrences in the file and the list of these Occurrences, 
each with some Attributes displayed (as in the "Occurrence List" panel in the Browser). The 
Attributes displayed are specified in the Repository and Role/User you have logged in.  
Click the "Close" button to exit the "Preview" dialog. 
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6.13.4. CONFIGURATION TAB-PANEL 

The "Configuration" tab-panel let you have to specify the identify restorer options in. 

 

Panel items: 

 Include in Output File also Non Modified Occurrences - choose this option to include in the 
output Occurrence file also the Occurrences that will not be modified by the identification restore 
action. 

 



DATA MANAGER DEIDENTIFICATION RESTORER TOOL 
 

 

233 

6.13.5. DESTINATION TAB-PANEL 

The "Destination" tab-panel let you specify the destination file for the deidentified Occurrences to restore. 

 

Panel items: 

 File Name - click the "..." button at the right of this field to specify the destination file name and 
location using the standard "Save" dialog. 

 Append Date/Time stamp to file name - choose this option to append a date and time stamp to 
the file name. For instance, if you choose "my restored file" as file name, then the actual export 
file name after the execution on Sept. 18th 2011 at 13:50 and 23 sec would be: 
my restored file_18-09-2010 13-50-23.e5f 
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6.13.6. LOGGING ACTIVITY TAB-PANEL 

The "Logging Activity" tab-panel let you enable/disable logging and specify its options.  

 

You can create a log file every time you execute a Data Manager tool. You cannot append logging to an 
existing log file. The file will be overwritten on execution. 
This means that a log file contains log messages for a single Data Manager tool execution. 

Panel items: 

 Log Activity - choose this option to enable logging. 

 Logging Destination section: 

o File Name - click the "..." button at the right of this field to specify the log file name and 
location using the standard "Save" dialog. 

 Logging Options section: 

o All messages / User feedback / Errors only - specify whether the log file includes all 
messages or only User feedback and error messages.  

o Append Date/Time stamp to LOG file name - choose this option to append a date and 
time stamp to the log file name. For instance, if you choose "mylogfile" as file name, 
then the actual log file name after the execution on Sept. 18th 2011 at 13:50 and 23 sec 
would be: 
mylogfile_18-09-2010 13-50-23.log  

o Automatically show log at the end of executions - choose this option to have Data 
Manager open the log file at the and of the execution. 
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6.14. DATA QUALITY TOOL 
The Data Quality tool performs a quality check on Occurrences either from file or from a Query in the 
database. The quality is evaluated through a set of Rules stored in Rule Libraries. 

To get more information follow these links: 

 Using the Data Quality tool (see page 235211). 

 Data Quality Functions and Tab-Panels (see page 236). 

 

6.14.1. USING DATA QUALITY 

The Data Quality tool evaluates the quality of a set of Occurrences by checking one or more Quality 
Rules.  

Quality Rules are stored in Quality Rules Libraries.  

Each Rule is expressed by one or more conditions that will be tested on each Occurrence selected for 
data quality evaluation. 

Each condition is composed by a standard Query which have actions associated both to its fulfilment 
(i.e. condition is true) or non-fulfilment (i.e. condition is false).The actions may be: 

 messages to include in the result file-splitting. 

 further "nested" conditions to evaluate. 

 none. 

The results of data quality processing is either a result file, including all the messages triggered by the 
conditions, or a statistics file, or both of them. 

The general operating sequence to run the Data Quality tool is: 

 Define the Occurrences to be exported in the "Source" tab-panel (see page 237). 

 Define the result and/or statistics file names and location in the "Destination" tab-panel (see page 
242). 

 Manage Quality Rule Libraries and Quality Rules in the "Configuration" tab-panel (see page 11). 

 Set the Quality Rules, with their conditions and related actions (see page 245). 

 Set the Logging options (see page 244). 

 Execute the tool by clicking the "Execute" button. 

 The Result files, if any, are generated and the Data Quality results are displayed in the "Results" 
window that shows up (see page 252). 

 Examine the log file, if needed. 
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6.14.2.  DATA QUALITY: FUNCTIONS AND TAB-PANELS 

 

The Data Quality tool includes four configuration tab-panels and the "Execute" button: 

 Configuration panel - you can select and edit parameters in each panel by clicking on the 
corresponding upper tab: 

o Source - to specify the Occurrences to be processed. 

o Configuration - to specify the Quality Rules used to evaluate the Occurrence. 

o Destination - to select which result to display and where. 

o Logging Activity - to set up logging and its options. 

 Execute button - to start the data Quality processing. 
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6.14.3. SOURCE TAB-PANEL 

The "Source" tab-panel let you specify the Occurrences that the "Data Quality" tool will process.  
The Occurrences may be specified by an Occurrence file or by a Query in the database. 

 

There are two sections in the "Source" tab-panel: 

 "Query" section  

 "Occurrence File" section 
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6.14.3.1. "QUERY" SECTION 

In the Query panel you specify the Query that will extract the Occurrences to be checked for Data 
Quality. 

Panel items: 

 Credentials - click the "connection" icon-button to display the ECCAIRS "Login" dialog where 
you can login to the Repository you wish with the suitable User. 

 Query - the field shows either the name of the Query currently in use, if taken from a Query 
Library, of the generic text "(Query)" if the Query has been defined standalone on the spot (see 
below). 
The icon-buttons on the right let you:  

o  Edit the Query - click the "pencil" icon-button to display the "Query Editing" window 
(see page 281) that allow to: 

 Edit locally a Query already opened from a Query Library without the need to edit 
or define Queries using the Query Builder 

 Create and edit standalone Queries, i.e. not stored in a Query Library. 

o  Open a Query Library - click the "open" icon-button to start the ECCAIRS Query 
Builder application that allows you access and define Query Libraries and Queries (see 
page 257).  

o  Preview the Query result - click the "glasses" icon-button to display a "Preview" 
dialog. 

 

The dialog displays the total count of Occurrences matching the Query and the list of 
these Occurrences, each with some Attributes displayed (as in the "Occurrence List" 
panel in the Browser). The Attributes displayed are specified in the Repository and 
Role/User that you have logged in.  
Click the "Close" button to exit the "Preview" . 
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 Explanation - the explanation of the Query currently in use. 

6.14.3.2. "OCCURRENCE FILE" SECTION  

If you select this option you have to specify in the "Occurrence File". 

Panel items: 

 File Name - click the "..." button at the right of this field to locate and specify the Occurrence file 
name using the standard "Open" dialog. 

 Preview the Query result - if you click the "glasses" icon-button at the right to display a 
"Preview" dialog. 

 

The dialog displays the total count of Occurrences in the file and the list of these Occurrences, 
each with some Attributes displayed (as in the "Occurrence List" panel in the Browser).  
The Attributes displayed are specified in the Repository and Role/User that you have logged in.  
Click the "Close" button to exit the "Preview" . 
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6.14.4. CONFIGURATION TAB-PANEL 

The "Configuration" tab-panel let you specify the rules that the Data Quality tool must evaluate on the 
source Occurrences specified in the "Source" tab-panel.  

Quality Rules are stored in Quality Rules Libraries. The panel lists the existing Quality Rules Libraries, 
each with its Rules listed below. 

 

When you perform the Data Quality evaluation, by clicking on the "Execute" button, only the Rules that 
have been checked in the panel will be evaluated  

By default all the Rules of all the Libraries are selected. 

By selecting/deselecting either the whole Library or any of its Rules you can choose which Quality Rules 
will be actually evaluated. 

Using the icon-buttons on the right, or the equivalent Right-click menu-items, you can operate on Library 
Rules and Rules themselves. 
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Menu items/icon-button items: 

 Add Library - to add a new Quality Rule Library. 

 Remove Library - to remove the Rule Library selected in the panel. 

 Export/Import Library - to export/import Data Quality Rule Libraries.  
The Libraries are saved in "ECCAIRS 5 Data Quality Library" format (*.edq). 

 Generate Query Library - to generate a Query Library including any of the Queries making up 
the Rules in the Rule Library selected in the panel.  
A "Generate Query Library" dialog shows up and let you select which of the Queries making up 
the conditions used in the Data Quality Rules you wish to save into a new ECCAIRS Query 
Library.  
The Query Library including the Queries that you have selected are saved in "ECCAIRS Query 
Library format" (*.eql). 

 

 Add a Rule - to add a new Data Quality Rule to the Library selected in the panel.  
A "Configure Role" dialog window shows up and there you can specify the Rule (see page 245).  

 Edit a Rule - to edit the Data Quality Rule selected in the panel. 
A "Configure Role" dialog window shows up and there you can modify the Rule (see page 245). 

 Remove a Rule - to remove the Data Quality Rule selected form its Library. 

 Messages - to add/edit/remove the messages triggered by conditions used to express a Quality 
Rule.  
The "Messages" dialog that shows up let you manage the messages associated with the Quality 
Rule Library currently selected (see page 249). 
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6.14.5. DESTINATION TAB-PANEL 

The "Destination" tab-panel let you specify let you specify the destination file for the Data Quality results 
and statistics 

 

Panel items: 

 Export Results to file - click the "..." button at the right of this field to specify the quality check 
result file name and location using the standard "Save" dialog. The Results are saved in an Excel 
worksheet format file (*.xls) that contains the same information as that displayed in the "Results" 
window at the end of the Quality Check process (see page 252). 
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 Export Statistics to file - click the "..." button at the right of this field to specify the quality check 
statistics file name and location using the standard "Save" dialog.  
The Statistics are saved in an Excel worksheet (*.xls) format file that contains the same 
information as that displayed in the "Statistics" window, which is accessible through the "Results" 
window at the end of the Quality Check process (see page 252).  
Note that if you have not specified the Statistics file name at this stage in the "Export Statistics to 
file" field, you will still be able to generate the Statistics Excel file at the end of the processing 
from the "Statistics" window (see page 254) . 

 

 Append Date/Time stamp to file name - choose this option to append a date and time stamp to 
the file name.  
For instance, if you choose "my export file" as file name with an "Excel Worksheet" export 
function, then the actual export file name after the execution on Sept. 18th 2011 at 13:50 and 23 
sec would be: 
my export file_18-09-2011 13-50-23.xls 
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6.14.6. LOGGING ACTIVITY TAB-PANEL 

The "Logging Activity" tab-panel let you enable/disable logging and specify its options. 

 

You can create a log file every time you execute a Data Manager tool. You cannot append logging to an 
existing log file. The file will be overwritten on execution. 
This means that a log file contains log messages for every single Data Manager tool execution. 

Panel items: 

 Log Activity - choose this option to enable logging. 

 Logging Destination -section: 

o File Name - click the "..." button at the right of this field to specify the log file name and 
location using the standard "Save" dialog. 

 Logging Options section: 

o All messages / User feedback / Errors only - specify whether the log file includes all 
messages or only User feedback and error messages.  

o Append Date/Time stamp to LOG file name - choose this option to append a date and 
time stamp to the log file name. For instance, if you choose "mylogfile" as file name, 
then the actual log file name after the execution on Sept. 18th 2011 at 13:50 and 23 sec 
would be: 
mylogfile_18-09-2010 13-50-23.log  

o Automatically show log at the end of executions - choose this option to have Data 
Manager open the log file at the end of the execution. 
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6.14.7. EDITING QUALITY CHECK RULES  

You create or edit a Data Quality Rule using the "Configure Rule" dialog. 

 

A Quality Rule is composed by one or more Conditions. All the Conditions will be evaluated sequentially. 

This window displays all the Conditions set. 

Each condition has two child nodes: 

  Condition True -  the action that will be performed when the Condition is met. 

  Condition False -  the action that will be performed when the Condition is not met 

You can define sub-conditions., i.e. a condition that will be checked only if its parent Condition is met (or 
not met). This way you may spare useless Conditions processing, since checking Rules/Conditions may 
be quite a demanding task, especially when operating on a large set of source Occurrences. 

If you need to enable/disable singles Conditions on the spot, then it may be convenient to defines Rules 
with a single condition in it, since only a whole Rule can be enabled/disabled while Conditions in a Rule 
not. 
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Dialog items: 

 Rule Identification section: 

o Name- (mandatory) the name assigned to the Rule. This is the name that will be 
displayed in the "Configuration" tab-panel. 

o Description - a description for the Rule. 

 Conditions section: 

o Add Condition - to add a Condition to the Rule.  
In the "Condition" dialog window that shows up you can define the Condition (see page 
247). 

o Edit Condition - to edit the selected Condition.  
In the "Condition" dialog window that shows up you can edit the Condition (see page 
247). 

o Remove Condition - to remove the selected Condition ..Beware that no confirmation is 
requested.  
If you remove a Condition by mistake, exit the "Configure Rule" dialog using the "Cancel" 
button, so that all modifications made to the Rule will be discarded. 

o Messages - to edit the message selected.  
This opens a "Message" dialog where you can edit the message text and its severity level 
associated (Information/Warning/Error). 

 

To exit click: 

 OK - to accept the editing done and close the dialog. 

 Cancel - to discard the editing done. 
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6.14.8. EDITING CONDITIONS IN A DATA QUALITY RULE 

You create or edit a Condition for a Rule using the "Condition" dialog. 

A Condition for a Quality Rule is made up by: 

 A standard ECCAIRS Query, evaluated on each Occurrence to be checked.  
The evaluation yields a True/False result. 

 The action that is triggered when the Query result is True and the action that is triggered when 
the Query result is False. 

You can define sub-conditions., i.e. a condition that will be checked only if its parent Condition is met (or 
not met). This way you may spare useless Conditions processing, since checking Rules/Conditions may 
be quite a demanding task, especially when operating on a large set of source Occurrences. 

 

Dialog items: 

 Name - (mandatory) the name assigned to the Condition.  
This is the name that will be displayed in the "Configure Rule" dialog. 

 Description - a description for the Rule.  

 Condition - the Query defining the Condition.  
To enter the Query you can use the two buttons on the right. 

o Create/Edit Query - to create a new or edit the selected Condition. The standard " Query 
Editing" window of the "Query Builder" is displayed (see page 281). 

o Import Query  - to import a Query from an existing Query Library. 
The "Import Query from Library" dialog shows up. 
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In the "Import Query from Library" dialog you can open a Query Library and select the 
Query to be imported and used in the Condition. 

 If Result is TRUE - the Query defining the Condition.  
To enter the Query you can use the two buttons on the right.  

o Then - the action that will be performed when the Condition is met.  

o Else - the action that will be performed when the Condition is not met. 

For both cases you can choose among three actions 

o None - no action. 

o Check Condition - allow for sub-conditions., i.e. a condition that will be checked only if its 
parent Condition is met (or not met). 

o Throw Message - append (write) a message to the Data Quality Result file. 
In this case you can either: 

 Select an existing message - from the drop-down message list. 

 

 Add a new message.  
In the "Message" dialog shows up you can define a new message (see page 251 
below). 

In both cases you can choose to append to the Result file also the Value of any of the 
Attributes involved in the criteria making up the Condition Query. 

 

To exit the "Condition" dialog click: 

 OK - to accept the editing done and close the dialog. 

 Cancel - to discard the editing done. 
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6.14.9. MANAGE MESSAGES IN A QUALITY RULE LIBRARY 

The "Messages" dialog let you manage the messages associated with the Quality Rule Library currently 
selected in the "Configuration" Tab-panel (see page 240). 

 

Dialog items: 

 Message list panel - the large central panel lists all the messages associated with the Quality 
Rule Library. 
Each message is listed along with its properties:  

o Msg. ID - the unique message identifier. 

o Severity - a quality category, chosen among: Information, Warning and Error. These can 
be used as filters when viewing the Data Quality check results. 

o Message - the text of the message. 

You can edit the message by selecting a message in the list and then either: 

o double-click on it 

o select "Right-click > Edit " menu-item. 

o select "Messages > Edit" menu-item. 

o click the "Edit" icon-button in the Toolbar. 

When editing a message you use the "Message" dialog that shows up (see page 251). 
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 Status bar - on the bottom, displays the "Total Count", i.e. the number of messages currently 
associated with the Quality Rule Library 

 File menu - in the Menu bar, with the following menu items: 

o Export - exports a Message file (*.msg) containing all the information about the 
messages. 

o Import - imports a Message file (*.msg), previously exported with the function above. 

o Close - closes the "Messages" dialog. 

 Messages menu - in the Menu bar, with the following menu items: 

o Add - adds a new Message. The "Message" dialog shows up. 

o Edit - edits the selected Message. The "Message" dialog shows up. 

o Remove - removes the selected Message. 

 Toolbar - with the following icon-buttons:  

o Close - same as "File > Close" menu-item. 

o Add  - same as "Messages > Add" menu-item. 

o Edit  - same as "Messages > Edit" menu-item. 

o Remove  - same as "File > Close" menu-item. 

o Filter - displays only the Messages that match the text string that you type in. 

o Severity - displays only the Messages that match the Severity level that you select with 
the drop-down list. 
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6.14.10. CREATE OR EDIT QUALITY CHECK MESSAGES 

You create a message using the "Message" dialog that shows up when either: 

 you create or edit a Condition for a Quality Rule using the "Condition" dialog and you select 
"Throw Message > Add a new message" in the "If Result is TRUE" Section (see page 247). 

 you select a Quality Rule Library in the "Configuration" Tab-panel and then select the 
"Right-click > Messages" menu-item to manage the messages associated with the Quality Rule 
Library itself (see page 240). 

 

Dialog items: 

 Msg. ID - the unique message identifier. If you try to assign an ID already in use, the system will 
warn you so. 

 Severity - a quality category, chosen among: Information, Warning and Error.  
These can be used as filters when viewing the Data Quality check results. 

 Message - the text of the message. 

When you edit an existing message, e.g. from the "Configure Rule" dialog window, you can only modify 
its "Severity" and the message text, not the Msg. ID. 

 

To exit click: 

 OK - to accept the editing done and close the dialog. 

 Cancel - to discard the editing done. 
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6.14.11. READING RESULTS OF THE DATA QUALITY CHECK 

Once the Quality Check process is completed, the Results window shows up .  
The Results window is the window which shows all the results of the Quality Check process. 

 

Dialog items: 

 Panels:  

o List of the Occurrences evaluated - in the left panel.  
Each Occurrence line displays: 

 Set of Identifier Attributes - the Special Attributes, according to the specific 
Taxonomy in use, that identifies the Occurrence.  
For instance, in the Aviation domain (the sample picture shown above), the 
Attributes displayed are: State File Number and State Reporting. 

 Result - the result is determined by the condition with the highest Severity Level 
for that occurrence.  
Let’s say, for example, that 20 conditions have been evaluated on a certain 
occurrence, 19 with Information level and 1 with Warning level.  
The overall Result will be Warning. 

o Rules (and their Conditions) evaluated - in the right panel. 
In addition to the Rules and their Conditions that have been evaluated, the panel also 
shows the Messages thrown and the Value(s) of the selected Attribute. If more than one 
Value is present for the Attribute, clicking on the   button will show all the values. 
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 Status bar - on the bottom, displays: 

o Total Occurrences - .(number) the total number of Occurrence that have been 
evaluated. 

o Occurrence with - a line with partial counts: 

 No errors - (number) the count of Occurrences without Error or Warning 
messages. 

 Warning - (number) the count of Occurrences with  Warning messages (as 
highest Severity Level). 

 Errors - (number) the count of Occurrences with Error messages (as highest 
Severity Level). 

 File menu - in the Menu bar on the top, with the following menus: 

o Export Results - exports the Results in an Excel format file (*.xls), as it happens when 
specifying the Result file in the Destination tab-panel.. 

o Export Statistics - exports the Result Statistics in an Excel format file (*.xls), as it 
happens when specifying the Statistics file in the Destination tab-panel.. 

o Close - closes the "Results" dialog. 

 View menu - in the Menu bar on the top, with the following menus: 

o Rule details - adds a new Message. The "Message" dialog shows up. 

o Statistics - shows a "Statistics" dialog  with some statistics about the Quality Check 
Process (see page 254 below). 

 Toolbar with the following items:  

o Close - (icon-button) same as "File > Close" menu-item. 

o Show Occurrences with Result - (drop-down list) shows only the Occurrences whose 
Severity level is that selected in the drop-down list.  
The Severity level is the worst expressed by all the Messages generated for that 
Occurrence in the Data Quality evaluation process. 

 

o Statistics - (icon-button) same as "View > Statistics" menu-item (see page 254 below).  

o Filter by - (drop-down lists set) to filter the list of the messages triggered by 
Rules/Conditions, for the Occurrence selected in the left panel. 
The list can be filtered by one or more conditions in logical AND, i.e.  the Messages 
displayed must satisfy all the filters set: 

 Filter by Library - (drop-down list) displays only the Messages generated by the 
Rules in the Query Rule Library selected from the drop-down list. 
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 Filter by Rules - (drop-down list) displays only the Messages generated by the 
Rule selected from the drop-down list. 

 

 Filter by Severity - (drop-down list) displays only the Messages with the Severity 
level selected from the drop-down list. 

 

Result Statistics 

You can view some statistics about the Quality Check Process.  

To view them, either click the "Statistics" icon-button on the Toolbar or select the "View > Statistics" 
menu-item and the "Statistics" dialog shows up. 

The "Statistics" dialog shows, for each Rule evaluated during the process, how many times each 
Message has been thrown, listing all the related Occurrences. 
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Dialog items: 

 Rule panel - (list box) lists the existing Quality Rules Libraries, each with its Rules listed below, 
just as in the "Configuration" tab-panel (see page 240). 
For each Rule evaluated during the process is displayed: 

 count - (number) a count how many times each Message has been thrown 

 Occurrence List - expanding the Message node by clicking onto it, the child nodes displays the 
list all the corresponding Occurrences. 

 Total Occurrence(s) - (number) at the bottom of the dialog there is a count of all the 
Occurrences processed in the Quality Check run. 

 Export Statistics - (button) click this the button to export the statistics generated.  
The Statistics are exported in Excel format (*.xls).  
The same result may be obtained specifying the Statistics destination file in the "Destination" tab-
panel (see page 242). 
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7. QUERY BUILDER TOOL 

7.1. THE QUERY BUILDER 
The ECCAIRS Query Builder is an integrated tool where Queries and Query Libraries are created, edited 
and managed. 

 

The Query Builder is a tool used by all the applications of the ECCAIRS Reporting System when dealing 
with Restriction Queries, i.e. when specifying/extracting Occurrences matching some conditions on their 
Attributes/Entities, and also with Selection Queries, i.e. when specifying Occurrence Attributes Values to 
extract/work with. 

The User cannot launch the Query Builder tool directly: it is only invoked automatically from the  
ECCAIRS applications, whenever there is the need to modify, create or execute a Query. 

7.2. USING THE QUERY BUILDER 
Before using the Browser you may need to read about some basic items: 

 Queries (see page 17). 

 Query Libraries and Categories (see page 18). 

You can then explore the Query Builder through its main windows: 

 Query Builder window (see page 259). 

 Query Editing window (see page 281). 

 Criterion Builder dialog (see page 290). 
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You can also explore the Query Builder through its functions: 

 You first have to create or open a Query Library using the "Library" menu, the "Library" panel and 
its Toolbar (see page 263). 
In addition to standard management functions you can set a Global Filter to select the 
Occurrences upstream, before any Query is executed (see page 269), Lock Libraries (see page 
268) and export the Queries to a text file (see page 270). 

 You can manage Queries inside the "Query" panel and using the "Query" menu and the "Query" 
panel and Toolbar (see page 275). 
You can create Query Categories using the "Category" menu and assign them Queries also 
using the "Query Right-click" menu (see page 274). 
You can copy Queries across Libraries opened in the "Query Builder" window (see page 275) but 
also import and export Queries in Libraries (see page 275). 

 When creating and adding Queries you will be using the "Query Editing" window (see page 281). 
Queries are built by Criteria, connected by Logical Operators and structured using Brackets (see 
page 17). 
You edit Queries through the "Edit" menu (see page 283). 
In addition to the more common Query type, which is technically referred to as Restriction since it 
restricts the Occurrences by posing some constraints (i.e. it extracts some Occurrences 
satisfying a condition from the database), there are also Selections which simply extract some 
Attribute values from the database, using a "Selection" window (see page 288). 

 To build a Criterion you will use the "Criterion Builder" dialog, operating on Attributes, Operators 
and Values (see page 290). 
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7.3. QUERY BUILDER WINDOW 

7.3.1. QUERY BUILDER LAYOUT 

When opening the Query Builder dialog window there may be one or more Query Libraries opened and 
shown: 

 the last Query Library used .Alternatively a new empty Library is implicitly created and opened. 

 any shared Query Library which is defined in the Repository for the Role/User with which you are 
logged in. The Shared Libraries, if any, are read-only (i.e. you cannot modify the Library and its 
Queries) and are marked by a "crossed pencil" icon. 

 

The Query Builder window items: 

 Library panel - on the left, used to list and manage Query Libraries, with its own Toolbar on the 
top (see page 260). 

 Query panel - on the right, used to list and manage Queries, with its own Toolbar on the top (see 
page 264). 

 Menu bar, with its menus: 

o Library menu (see page 266). 

o Category menu (see page 271). 

o Query menu (see page 273). 

o Help menu (see page 279). 

 Right-click menu, in two versions: 

o Library Right-click menu, in the "Library" panel on the left (see page 280). 

o Query Right-click menu, in the "Query" panel on the right (see page 280). 
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 Status bar - at the bottom, indicating the database indexing percentage. 
If the indexing percentage" is not 100% the results of Queries may be not be complete. 

To exit the "Query Builder" window you have two buttons on its bottom right:  

 OK - to return the Query selected to the calling application. 
For instance, when operating with the ECCAIRS Browser, the Browser will execute the Query 
selected. 

 Cancel - to exit without returning any Query selection. 

7.3.2. LIBRARY PANEL 

The "Library" panel lists all the Query Libraries currently opened in the Query Builder.  
Query Categories (see page 18), if any, are child nodes of the Query Library they belong to. 
The Queries included in the Query Library that you select are displayed in the "Query" panel on the right. 
If you select a Query Library Category instead, then only the Queries belonging to that Category will be 
listed in the "Query" panel. 
In the "Library" panel you can create, open, save and close Query Libraries and add and remove Query 
Categories inside each Library, plus a bunch of other functions accessible form the "Library" menu and 
the "Category" menu. 

 

Panel items: 

 Library Toolbar - on the top.  
A set of icon-buttons that performs most of the functions included in the "Library" menu (see page 
266) and in the "Category" menu (see page 271). 
Stop the mouse over a button to show a tooltip describing its function. 
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 Library-tree - a tree representation of the Query Libraries currently open within the Query 
Builder. 
The top nodes represent the Query Libraries. The child nodes are the Categories of each Query 
Library. See "Category" menu for details (see page 271). 
To display the Queries included in a Query Library select the corresponding node in the tree. 
The Queries are displayed in the "Query" panel on the right. If you select a Query Library 
Category instead, then only the Queries belonging to that Category will be listed in the "Query" 
panel. 
Select in the tree the Query Library or Category on which you want to perform functions. 
If you double-click on a Library or on a Category the first Query in the Library or Category is 
automatically opened for editing in the "Query Editing" window (see page 281).  
 
There are four kind of icons that are used to mark items in the Library-tree panel: 

 

o "Books" icon - for standard Libraries.  
When you select a standard library in the panel the Query Builder window Title bar shows 
the Library name and its location (i.e. the folder where the library is stored). 

 

o "Folder" icon - for Query Categories. These are child-nodes appended to the Library 
they belong to. 

o "Crossed Pencil" icon - for Shared Libraries, pre-defined in the Repository for the 
Role/User with which you are logged in.  
When you select a shared library in the panel the Query Builder window Title bar shows 
the Library name followed by "[Read-only]". There is no location/folder displayed in the 
Title bar since the Query Library is provided trough the Repository. 

 

o "Crossed Pencil" icon - for Locked Libraries.  
When you select a standard library in the panel the Query Builder window title bar shows 
the Library name and its location (i.e. the folder where the library is stored), followed by 
"[Read-only]". 
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 Expand/Collapse buttons - at the bottom.  
Click the "Collapse all" button (the leftmost) to show only the Query Library parent nodes. 

 

Conversely, click the "Expand all" button (the rightmost) to show the Query Library parent nodes 
and all their the child Category nodes. 
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7.3.3. QUERY LIBRARY FUNCTIONS 

You can use the: 

 "Library" menu - to create, open, save, close, lock, etc Query Libraries. 

 "Category" menu - to add and remove Categories inside each Library. 

 "Right-click" menu - to close a Library and perform functions of the "Category" menu. 

 "Query Toolbar" - to perform most of the functions available in the "Library" menu and 
"Category" menu.  
Stop the mouse over a button to show a Tooltip describing its function. 

 

7.3.4. QUERY FUNCTIONS 

You can use the: 

 "Query" menu - to add, edit , remove, copy, paste, import, assign Queries to Category, etc. 

 "Right-click" menu - to select quickly some of the functions available in the "Query" menu. 

 "Query" Toolbar - to perform most of the functions available in the "Query" menu. 
Stop the mouse over a button to show a Tooltip describing its function. 
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7.3.5. QUERY PANEL 

The "Query" panel lists all the Queries of the Query Library selected in the "Library" panel.  
If you instead select a Category in the "Library" pane, then the "Query" panel lists all the Queries 
included in that Category. 
You can add, edit and remove Queries and also import and export Queries from/to other Query Libraries. 

 

Panel items: 

 Query Toolbar - on the top.  
A set of icon-buttons that performs most of the functions included in the "Library" menu and in the 
"Category" menu. 
Stop the mouse over a button to show a tooltip describing its function. 

 

 Count button - at the right of the "Library" Toolbar. 
Click this button to execute the Query selected in the Query list (below) and see in the result box 
aside the number of Occurrences that the Query selects out of the database. 

 

 Query list - the list of the Queries included in the Query Library selected in the "Library" pane.  
If you instead select a Category in the "Library" pane, then the "Query" panel lists all the Queries 
included in that Category. 
Each Query is listed with its name, category (if any), author and last modification date. 
In the list you have to select the Query on which you want to perform functions. 
Double-clicking on a Query opens it in the "Query Editing" window.  
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 Filter button - at the bottom.  
The "Query" panel normally lists all the Queries included in the Query Library.  

 
To display only Queries whose name contains some text click the "Filter" button and type the 
filtering text into the text box aside. Filtering is performed dynamically: while you are typing the 
filtering text characters only the Queries matching the typed characters are displayed.  
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7.3.6. LIBRARY MENU 

The "Library" menu performs functions on Query Libraries and upstream global filtering. 

 

Menu items: 

 New  

 Open 

 Close  

 Save  

 Save as 

 Save All 

 Lock Library 

 Unlock Library  

 Global Filter 

 Export Query List to File 

 Open one of the Most Recently Used Query Libraries  

 Exit 

 

Beyond menu-items you can also: 

 Rename a Query Library 
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7.3.6.1. LIBRARY > NEW  

Creates a new Library. 

The system will ask you a name for the new Library. 

 

Click: 

 OK - to confirm. 

 Cancel - to cancel the action. 

A new folder-icon with the Library name is displayed in the "Library" pane.  

 

7.3.6.2. LIBRARY > OPEN  

Opens an existing Query Library.  

The system shows a standard "Open" dialog and you have to pick up the Query Library file (*.eql) you 
wish.  

The dialog is opened on the last used folder. 
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7.3.6.3. LIBRARY > CLOSE  

Closes a Query Library.  

If you have made any changes to the Query Library without saving it, then you will be asked whether you 
wish to save the changes before closing it. 

7.3.6.4. LIBRARY > SAVE  

Saves a Query Library.  

If it is the first time that you save the Query Library since you have created it, the system behaves as 
with the "Library > Save as" menu-item. 

7.3.6.5. LIBRARY > SAVE AS  

Saves a Query Library into a new Query Library file.  

The system shows a standard "Save" dialog and you have to select the folder and name for the Query 
Library file (*.eql) you wish.  

The dialog is opened on the last used folder. 

7.3.6.6. LIBRARY > SAVE ALL 

Saves all the Query Libraries currently open in the "Query Builder" window. 

7.3.6.7. LIBRARY > LOCK LIBRARY 

Locks a Query Library, preventing other Users to modify it. 

You have to provide a password, that will then be needed to unlock the Query Library. 

 

Click: 

 OK - to confirm. 

 Cancel - to cancel the action. 
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The Library folder-icon is changed into a locked-icon. 

 

7.3.6.8. LIBRARY > UNLOCK LIBRARY  

Unlocks a locked Query Library. 

You have to provide the password that was used to lock the Query Library. 

 

7.3.6.9. LIBRARY > GLOBAL FILTER  

You can define and apply a "Global Filtering" Query that will be executed upstream to pre-select 
Occurrences before any Query in the Library.  

The sub-items that you can select are: 

 Enable/Disable Global Filter - to enable or disable the Global Filter. This way you can quickly 
insert or remove the upstream filter on Occurrences. 

 Edit Global Filter - to edit the Query that performs the Global Filter. The editing is performed 
through standard "Query" dialog window. 

 Remove Global Filter - to delete the Query that performs the Global Filter.  
If you only need to temporarily remove the filter you may consider using the "Library > Global 
Filter > Disable Global Filter" menu-item. 
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7.3.6.10. LIBRARY > EXPORT QUERY LIST TO FILE  

Exports the textual definition of all Queries in the Query Library selected.  

The system shows a standard "Save" dialog and you have to select the folder and name for the text file 
to create.  

The dialog is opened on the last used folder during a save operation. 

 

7.3.6.11. LIBRARY > OPEN ONE OF THE MOST RECENTLY USED QUERY LIBRARIES  

the last items in the menu are the last four Query Library files that have been used. You can click on any 
of them to quickly re-open the Query Library.  

7.3.6.12. HOW TO RENAME A LIBRARY 

You can rename a Library by selecting its node in the "Library" panel and either: 

 hit the "F2" keyboard key, or 

 click onto the Library name at the side of the folder-icon. 

In both cases the Library name becomes displayed in reverse colours and surrounded by a box. 
At that point you can type in the new name. 
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7.3.7. CATEGORY MENU 

The "Category" menu performs functions on Categories. 

 

Menu items: 

 Add 

 Remove  

 Duplicate 

Beyond menu-items you can also: 

 Rename a Query Category 

7.3.7.1. CATEGORY > ADD  

Adds a Category within the current Query Library, or even to an existing Category.  
You can therefore also create sub-Categories, but only at one level (i.e. you cannot create sub-sub-
Categories). The system will ask you a name for the new Category. 

 

You can click: 

 OK - to confirm. 
A new folder-icon with the Category name is displayed below the "Library" node, or the 
"Category" node selected. 

 

 No - to cancel the action. 

To assign a Query to a Category you use the "Query > Assign to Category" menu-item (see page 274). 
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7.3.7.2. CATEGORY > REMOVE 

Removes a Category. 

If there is any Query included in that Category, the Query will be moved to the "Library" level, i.e. its 
Category will be removed but the Query will be set without Category.  
You will get a confirmation dialog before actually removing the Category. 

 

Click: 

 Yes - to remove the Category. 

 No - to cancel the removal. 

7.3.7.3. CATEGORY > DUPLICATE 

Duplicates the Category currently selected in the "Library" panel. 

ECCAIRS assigns to the new Category the name of the "source" Category followed by a progressive 
number. 

All the Queries included in the "source" Category are duplicated into the duplicated Category and their 
name is the name of the "source" Query followed by a progressive number 

7.3.7.4. CATEGORY > RENAME A CATEGORY 

You can rename a Category by selecting its node in the "Library" panel and either: 

 hit the "F2" keyboard key, or 

 click onto the Category name at the side of the folder-icon. 

In both cases the Category name becomes displayed in reverse colours and surrounded by a box. 
At that point you can type in the new name. 
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7.3.8. QUERY MENU 

The "Query" menu performs functions on Queries. 

 

Menu items: 

 Add 

 Edit 

 Remove 

 Assign to Category 

 Cut/Copy/Paste 

 Import from Library 

 Export to Library 

 Definition 

 Description 

 

Beyond menu-items you can also: 

 Rename a Query 
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7.3.8.1. QUERY > ADD  

Adds a Query to the Library. You first have to give a name to the new Query and then the system opens 
the "Query Editing" window where you can define the Query. 

 

7.3.8.2. QUERY > EDIT 

Edits the Query selected. The system opens the "Query Editing" window where you can edit the Query. 

7.3.8.3. QUERY > REMOVE 

Removes the Query selected. The system asks you to confirm the removal. 

 

7.3.8.4. QUERY > ASSIGN TO CATEGORY 

Assigns the Query selected to a Category. You indicate the Category by selecting them from the sub 
menu-items. 
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7.3.8.5. QUERY > CUT/COPY/PASTE 

Cuts, copies and pastes Queries also across Categories and Queries. If you copy and paste a Query 
within the same Query Library, then you will be prompted for a new name for the pasted Query.  

7.3.8.6. QUERY > IMPORT FROM LIBRARY 

Imports a Query from another Query Library file into the selected Query Library . 

Note that if you have both the Query Libraries open, then you just need to use "Query > Copy" and 
"Query > Paste". 

The system shows a standard "Open" dialog and you have to pick up the Query Library file (*.eql) 
including the Query you wish to import. An "Import Queries" dialog is then displayed.  

 

You can select in the upper yellow panel the Queries you wish to import. You can use the standard 
"SHIFT" key (contiguous) and "CTRL" key (non contiguous) multi item selection. Or even use the two top 
right buttons to select/deselect all Queries.  

The lower panel shows the definition of the Query you are selecting. 

Once you are satisfied with the selection use: 

 OK - to import the Queries 

 Cancel - to cancel the operation. 
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7.3.8.7. QUERY > EXPORT TO LIBRARY  

Exports Queries from the selected Query Library into another Query Library file. 
Note that if you have both the Query Libraries open, then you just need to use "Query > Copy" and 
"Query > Paste". 

You have to: 

 select the Queries you wish to export: you can use the standard "SHIFT" key (contiguous) and 
"CTRL" key (non contiguous) multi item selections within the "Query" pane. 

 then select the "Query > .Export to Library" menu-item. 

The system shows a standard "Save" dialog and you have to select the folder and name for the 
Query Library file (*.eql) into which you wish to export the Queries. If there is any Query with the 
same name in the target Query Library file then the system asks you to change the name of the 
Query to export. 

 

The system signals the export completion with a notification dialog. 

 

Click the "OK" button to acknowledge and close the dialog. 
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7.3.8.8. QUERY > DEFINITION 

Shows the definition of the selected Query in the lower part of the "Query" pane. 

Selecting this menu-item again turns off the display of the Query definition. 
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7.3.8.9. QUERY > DESCRIPTION 

Shows the textual description of the selected Query in the lower part of the "Query" pane, if any has 
been entered. 

Selecting this menu-item again turns off the display of the Query description.  

 

7.3.8.10. HOW TO RENAME A QUERY 

You can rename a Query by selecting it in the "Query" panel and either: 

 hit the "F2" keyboard key, or 

 click into the "Query Name" column of the Query in the list. 

In both cases the Query name becomes displayed in reverse colours and surrounded by a box. 
At that point you can type in the new name. 
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7.3.9. HELP MENU 

 

Menu items: 

 Contents  

 About 

7.3.10. HELP > CONTENTS  

Displays online help for the application you are running. 

You can also invoke the online help at any time by pressing the "CTRL" and "F1" keyboard keys at the 
same time. 

7.3.11. HELP > ABOUT 

Opens a dialog displaying details on the version of the application you are running. 

 

Click the "OK" button to acknowledge and close the dialog. 
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7.3.12. LIBRARY RIGHT-CLICK MENU 

The "Library Right-click" menu performs functions on Categories and closes Query Libraries. 

 

Menu items: 

 Close Library - same as "Library > Close" menu-item (see page 268). 

 Add Category - same as "Category > Add" menu-item (see page 271). 

 Remove Category - same as "Category > Remove" menu-item (see page 272). 

7.3.13. QUERY RIGHT-CLICK MENU 

The "Query Right-click" menu performs functions on Queries and assigns Query Categories. 

 

Menu items: 

 Add - same as "Query > Add" menu-item (see page 274). 

 Edit - same as "Query > Edit" menu-item. (see page 274). 

 Remove - same as "Query > Remove" menu-item (see page 274). 

 Assign to Category - same as "Query > Assign to Category" menu-item (see page 274). 

 Cut, Copy, Paste - same as "Query > Cut, Copy, Paste" menu-items (see page 275). 
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7.4. QUERY EDITING WINDOW 
The "Query" window is the place where you can edit a Query, i.e. define and combine Criteria.  

 

The "Query" window includes: 

 Menu bar - including: 

o Edit menu - (see page 283). 

o Help menu - (see page 285). 

 Right-click menu - (see page 286). 

 Toolbar - offers a set of buttons to access quickly the same functions of the "Edit" menu. 
Stop the mouse over a Toolbar button to show a Tooltip describing its function. 
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 "Query Definition" panel - where you see and edit on the Criteria and the logical operators 
among them. 

 

In the "Query Definition" panel it is possible to identify the three elements of which a Query is built upon: 

 Criteria - which are specified through the Criterion Builder dialog (see page 290). 

 Logical operators (see page 286). 

 Brackets (see page 287). 

By combining these elements, even complex Queries can be build quite easily. 

Query elements are added, deleted and edited in the Query Definition panel using the "Edit" menu-items, 
or corresponding Toolbar buttons and "Right-click" menu-items. 

You can also import Queries from Query Libraries and enter/display Query Descriptions using the same 
menus.  

Double-clicking a left bracket collapses and expands the contained elements. 

Possible errors in the Query syntax are indicated, while editing, by suitable message windows (for 
instance because of an unbalanced number of brackets). 

Also, the Query content can be completely cleared selecting "Edit > Clear" menu item. 

To exit the "Query" dialog click: 

 OK - to accept the Query specified/edited. 
The system checks for formal syntax errors (missing or excessive logical operators, wrong 
bracket use, etc) and, in case, points out the error(s) with explicative notification dialogs. 

 

 Cancel - to discard the Query editing done. 
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7.4.1. EDIT MENU 

The "Edit" menu offers all the functions to build Queries, within the "Query" window. 

 

For most of the menu-items you first have to select either the position inside the Query where the item-
corresponding element will be inserted or the element to be removed/edited. 

Menu items: 

 Add Open/Closed Bracket - for details on Brackets see page 287. 

 Add Open/Closed Square Bracket - for details on Brackets see page 287. 

 Add Criterion - for details on Criteria see page 286. 

 Add Sub Query - adds an existing Query (with all its Criteria) inside a Criterion. 
This way you may decouple the development and debug of complex Queries. 

 Add Operator AND/OR - for details on Operators see page 292. 

 Edit - opens the "Criterion Builder" dialog to edit the Criterion selected (see page 290). 

 Remove - removes the selected element. 

 Clear - clears the entire Query content. 

 Cut/Copy/Paste - copies a move elements inside the Query. 
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 Import from Library - imports a Query from a Query Library. This will overwrite all the Criteria 
(restrictions) already existent inside the Query being edited.  
The system shows a standard "Open" dialog and you have to pick up the Query Library file (*.eql) 
including the Query you wish to import. An "Import Queries" dialog is then displayed.  

 

You can select in the upper yellow panel the (single) Query you wish to import.  
Once you are satisfied with the selection use: 

o OK - to import the Query. 

o Cancel - to cancel the operation. 

 Exit - closes the "Query" window. 
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7.4.2. HELP MENU 

 

Menu items: 

 Contents  

 About 

7.4.3. HELP > CONTENTS 

Displays online help for the application you are running. 

You can also invoke the online help at any time by pressing the "CTRL" and "F1" keyboard keys at the 
same time. 

7.4.4. HELP > ABOUT 

Opens a dialog displaying details on the version of the application you are running. 

 

Click the "OK" button to acknowledge and close the dialog. 
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7.4.5. RIGHT-CLICK MENU 

The Right-click menu offers a quick access to the most common functions of the "Edit" menu. 

 

7.4.6.  CRITERION 

A Criterion is an expression involving 3 elements: 

 Attribute - for instance: State/Area (ADREP, Air Safety application domain) 

 Operator - for instance: equal to 

 Value - for instance: Andorra  

 For instance: 

 equal-to Andorra 

 

  

7.4.7.  LOGICAL OPERATORS 
A Logical Operator is one of the two logical operators AND/OR used to connect two or more Criteria: 

CRITERION AND/OR CRITERION 

(e.g. State/Area equal-to Andorra AND Local date equal-to Current Year) 
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7.4.8.  BRACKETS 

Brackets are used to group logical expressions to build complex Criteria. 

Curly brackets { } are used for normal grouping.  

Square brackets [ ] are used to limit the Criteria within the same branch of the Occurrence structure, for 
instance when more than one aircraft/ship/train is involved in an Occurrence. 
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7.5. SELECTIONS IN QUERIES 

7.5.1. RESTRICTION AND SELECTION 

What we normally call Queries in ECCAIRS, are actually called "Restrictions" in the relational database 
terminology, since you restrict the database records you are dealing with (i.e. the ECCAIRS 
Occurrences) based on some restrictive conditions on their Attributes. 

A Query (restriction) is made up by one or more criteria, connected by logical operators. 
A Criterion involves some sort of function, most commonly comparisons, between an Attribute and its 
possible values. 
The part of the Query that specifies/extracts the Attribute (and its values) is called "selection". 

Whenever you create or edit a Query (a restriction) the system opens a "Query" dialog where you find all 
the functions needed to specify all the criteria, with the selections and the functions involved. 

Stand-alone Selections 

Other times you only need to have Queries that extracts the Attribute values, that is "stand-alone" 
selections. 

Some ECCAIRS Applications, e.g. Data Manager, (see page 155), use a Selection Edit panel within the 
"Query" dialog to select a list of Attributes. 

Other ECCAIRS Applications, e.g. Grapher (see page 113), use directly a Selection dialog to select 
single Attributes. 

7.5.2. SELECTION DIALOG 

The Selection dialog let you select particular Attribute Values, for instance to populate x, y or z axis 
values in a graph. 

If you have to select a single Attribute, then the system just uses "Selection Builder" dialog directly. This 
is what happens for instance inside the "ECCAIRS Grapher" application. 

 

The "Selection Builder" dialog is basically the same as the "Attribute Definition" part of the "Criterion 
Builder" dialog (see page 291). 
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7.5.3. SELECTION PANEL INSIDE THE QUERY EDITING WINDOW 

If you have to select more than one Attribute at a time, out of the Occurrences obtained by a Query 
restriction, then you have a specific "Selections" panel inside a "Query (restrictions)" window. 

 

Be aware that when selecting multiple Attributes, specific rules apply when combining different functions 
for the Attributes. For example when one Attribute is used for grouping the other Attribute must also have 
specific functions applied (count, for instance). 
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7.6. CRITERION BUILDER DIALOG 
A Criterion is an expression involving 3 elements: 

 Attribute - for instance: State/Area (ADREP, Air Safety application domain) 

 Operator - for instance: equal to 

 Value - for instance: Andorra  

 For instance: 

 equal-to Andorra 

 

The "Criterion Builder" dialog is invoked to add/edit a Criterion by: 

 

 Double-clicking on an existing Criterion 

 Selecting "Edit > Edit" menu-item (or "Right-click-menu > Edit" or Toolbar edit icon-button) when 
focus is on a Criterion. 

 Selecting "Edit > Add Criterion" menu-item (or "Right-click-menu > Add Criterion" or Toolbar 
add icon-button) when the focus is on a logical operator or on after a left bracket.. 

The "Criterion Builder" dialog allows to define the three elements for a Query Criterion: 

 Attribute and Layout (see page 291). 

 Operator (see page 292). 

 Reference Value Specification (see page 292). 

  

To exit the dialog you use the two buttons at the bottom: 

 OK - to accept the Criterion specified/edited. 

 Cancel - to discard the Criterion editing. 
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7.6.1.  CRITERION ATTRIBUTE 

You have to specify one of the Attributes included in the Repository Taxonomy. 

A full qualified Attribute identification involves specifying the full Entity-path to the Attribute, starting from 
the Occurrence, which is the "root" Entity. 

You can specify an Attribute either by: 

 Using the ECCAIRS standard "Attribute Selection" dialog (see page 293).  
Once selected, both the "Id" field and the Entity-path and Attribute get completed/filled-in. 

 Entering directly the Attribute "Id" numerical code in the Attribute Id field. 

Once selected, both the "Id" field and the Entity-path and Attribute get completed/filled-in. 

 

Attribute Layout 

You also have to specify the Layout for the Attribute, choosing it from an Attribute-dependent drop-down 
list. The Layout specifies which aspect of the Attribute to consider in the Criterion. 

For instance which level, for multi-level Attribute values, or which Attribute instance, for Attributes which 
may belong to more then one instance of a Topic (e.g. the Attribute of which of the aircraft/ship/train 
involved in the Occurrence). 

 

But can also be which sub-part, alias or formatting to consider. For instance which part of a date/time 
Attribute.  

 



QUERY BUILDER TOOL CRITERION BUILDER DIALOG 
 

292 

7.6.2.  CRITERION OPERATOR 

The Operator can be chosen from the drop-down list proposed in the dialog. 

This can be chosen from the drop-down list proposed in the dialog.  
The types of operators proposed varies according to the Attribute selected.  

See the picture below for some sample Operators. 

 

The operators may require as reference value: 

 No specific value (i.e. the “has no value” operator) 

 A single value (e.g. “equal to”, “less than”, …) 

 Two values (e.g. “between”, “not between”, …) 

 Multiple values (e.g. “has at least one”, …). 

7.6.3. REFERENCE VALUE SPECIFICATION 

Reference Attributes Values are selected in various ways, according to the type of Value (see page 301). 
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8. ENTER VALUES AND SELECT ATTRIBUTES  

In all the ECCAIRS Reporting System applications you will need to select Attributes and Attribute Values 
and also enter Attribute Values. 

This section deals with the common dialog windows and functions used to perform the following actions: 

 Select an Attribute. 

 Select an Attribute Value in Multiple Level Value Lists. 

 Select Multiple Attributes Values. 

 Specify Attribute Values, both as reference Values in Queries and to enter Values for the 
Occurrence Attributes. 

8.1. SELECT AN ATTRIBUTE 
The "Attribute Selection" dialog let you specify one of the Attributes of the Repository Taxonomy. 
The Attributes are displayed under the Entity they belong to.  
All Entities are child Entities of the "root" Entity, the Occurrence, and may have their own child Entities. 

Initially the Attribute tree is displayed in fully expanded mode, i.e. all Attributes of all Entities are 
displayed. 

Using the four bottom leftmost buttons you can: 

 

 Display Attribute Descriptions - display at the bottom of the dialog the "Detailed Description" 
and the "Explanation" of the Attribute currently selected, as specified in the Taxonomy. 
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 Collapse Attribute tree - collapse all branches of the Attribute tree. Only the root Entity will be 
shown. 

 

 Expand Attribute tree - expand all levels of the Attribute tree. All the Attributes are displayed. 

 

 Expand/Collapse child Entities/Attributes - you can also expand and collapse single Entity 
branches: 

o To display Entity branches click on the "+" symbol used to mark the value node in the 
"Attribute-node" within the panel.  
The Attribute node gets then marked with the "-" symbol. 

o Conversely, to collapse an Entity branch level, click on the "-" symbol.  
The Attribute node gets then marked with the "+" symbol. 

 Filter Attribute List - you can use the funnel-shaped yellow button to filter the Attribute list. 
See next page for details. 

 
To exit the "Attribute Selection" dialog click: 

 OK - to confirm the Attribute selected. 

 Cancel - to exit without any selection. 
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8.1.1. ATTRIBUTE LIST FILTERING 

To apply a display filter on the Attribute list: 

  Click the yellow funnel-shaped icon-button at the bottom of the Attribute tree. 
An empty field shows up at the right of the icon. 

 

 Type in the filter text you wish and terminate with the RETURN keyboard key. 
The Attribute tree will now show only the Attributes and Entities containing the filtering text.  

 

To remove the filter: 

 Click again the yellow funnel-shaped icon-button. 
The text filtering field disappears and the whole set of Attributes is displayed in the tree. 
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8.2. SELECT AN ATTRIBUTE VALUE IN MULTIPLE LEVEL VALUE 
LISTS 

The "Value Tree navigation" panel displays the values included in the Value List.  
By default the panel displays all the values currently included in the Value List.  
The values are displayed in a tree-view arrangement, which allows to handle multi-level Value Lists.  

 

You can exploit the "Values display filtering" funnel-shaped button to select which values to display and 
how to display the Value tree and its branches (see page 297).  

The multiple selection dialog also offers a "show-value-detail" icon-button to toggle on/off display of 
value long descriptions, explanations and value aliases.  

 

To exit the dialog click: 

 OK - to confirm the Attribute Value selected. 

 Cancel - to exit without any selection. 
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8.2.1. VALUES DISPLAY FILTERING 

By default the "Value Tree Navigation" panel displays all the values currently included in the Value List. 

 

Clicking on the filter icon-button at the bottom part of the left panel opens a filter field where you can 
enter the filter text string. 
Now only the values that match the filter are displayed. 

 

You can also expand/collapse single branches of the Value tree (see next page). 
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8.2.2. EXPANDING/COLLAPSING VALUE BRANCHES 

Expand and collapse single value branches, i.e. the value branch to which the currently selected value 
belongs.  

 

 To display sub-level value branches click on the "+" symbol used to mark the value node in the 
"value-node" within the values pane.  
The value node gets then marked with the "-" symbol. 

 Conversely, to collapse a value branch level, click on the "-" symbol.  
The value node gets then marked with the "+" symbol. 
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8.2.3. EXPANDING/COLLAPSING ALL VALUE BRANCHES 

 Use the left-panel bottom "collapse" icon-button to collapse all the value branches at a time. 

 

 Use the left-panel bottom "expand" icon-button to expand all the value branches at a time. 
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8.3. SELECT MULTIPLE ATTRIBUTES 
When more than one Attribute need to be specified the system proposes a multiple selection dialog 
window. 

 

In the dialog you can add and remove Attributes to a selection list-panel (on the right), choosing then in 
the Attribute tree panel (on the right).  

You can use the standard Attribute tree navigation, display and filtering functions (see page 293).  

To exit the dialog there are two buttons at the bottom: 

 OK - to save the changes made so far. 

 Cancel - to discard the changes made so far. 
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8.4. ENTER ATTRIBUTE VALUES 
There are different ways you can enter the Attribute Value(s): 

 Free Text or Value 

 Selection in a Predefined Value List 

 Multiple Predefined Values Selection 

 Multi-level Predefined Value Selection 

 User Properties Values 

 Custom Case/Wizard-driven Attribute assignment 

 Ask Value at Query Run Time (only for Queries) 

8.4.1. FREE TEXT OR VALUE 

The User types in the Value needed, terminated by the [RETURN] key (or by moving to another Attribute 
with either the [TAB] key or by moving the mouse pointer). The system just checks that data entered is 
coherent with the type of data expected (numerical, alphanumerical, .etc), and signals, if appropriate, 
error warnings by cancelling the incorrect input data and issuing an alarm sound (bell sound). 

 

Clicking with the mouse right-button on any Attribute measurement unit will display a set of alternate 
units available. Changing the measurement unit of an Attribute already (filled in, specified), changes its 
Value accordingly. 

 

8.4.2. PREDEFINED VALUE SELECTION 

The User chooses among one of the predefined Attribute Values proposed in a drop-down list. 
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8.4.3. MULTIPLE PREDEFINED VALUES SELECTION 

When more than one Attribute Value may be specified, out of a predefined Value List, the system 
proposes a multi-value selection dialog window. 

 

In the dialog you can add and remove Attribute Values to a selection list-panel (on the right), choosing 
then in the Attribute Value List panel (on the right).  

 

The Value selection panes shows Value Lists, including multiple-level ones (Value Trees).  

You can use the standard Value Tree navigation, display and filtering functions (see page 296). 
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8.4.4. MULTI-LEVEL PREDEFINED VALUE SELECTION 

When you have to select Attribute Values out of a multiple-level Value List the system proposes a 
specific dialog box. 

 

In this hierarchical selection and search dialog you can select the Value using the standard Value Tree 
navigation, display and filtering functions (see page 296). 

 

You can also enter an Additional Value (i.e. not included in the predefined Value tree) if the Attribute 
allows for it . This is achieved by clicking on the " Additional Text" button and entering a Value in the text 
box on its right. 
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8.4.5. USER PROPERTIES VALUE 

If the Attributes foresees this option you may use one of the User properties as Value. 

The User properties are set in the User profile of the Repository to which you are logged in. 
Also you can edit these properties using the "Session > My Profile" menu-item, within the ECCAIRS 
Browser application 

Choose the "Property" option and select the specific property in the drop-down list.  
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8.4.6. CUSTOM CASES/WIZARD-DRIVEN ATTRIBUTE ASSIGNMENT 

Some specific Attribute may need to be set is a non-standard way. The ECCAIRS Browser allows the 
customisation , among others, of any Attribute modification/creation procedure. 
For instance the Value an Attribute may be a result of the computation made on a set of values, 
evaluations, etc. 

 

Special input procedures are activates, for instance a wizard-driven input. 

 

The system will assign itself the resulting Value to the Attribute. 

 

8.4.7. ASK VALUE AT QUERY RUN TIME 

When specifying Reference Values for a Query you may also choose to specify the Value later at run 
time.  
On executing the Query the system will ask you to specify the Value. 

Choose the "Ask later" option to activate this option. 

 
  



  
 

 

 


